Weird ABS Problem | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

Weird ABS Problem

93TwotoneXLT

Well-Known Member
Joined
March 2, 2006
Messages
159
Reaction score
0
City, State
Evansville, In
Year, Model & Trim Level
1993 XLT4x4
Ok, so here's the problem. Replaced the inner and outer wheel bearings and all 4 shocks on my X about 1 week ago. The ABS motor is coming on when I turn the steering wheel to the right and hold it there. When I return the wheel back to center the motor shuts off and the brakes are normal. If I press down on the brake pedal while turning the wheel to the right during this time it is really stiff then it kinda "pops" and the brakes are reasonably normal again. The pedal also gets "soft" so I pump the brakes and the boost gets back to normal, only to get soft again after a little while. What's weird is that all of this started after replacing the aformentioned parts. I will say that the brake pedal did occasionaly get soft on me every now and again, so I was going to replace the master cylinder as PM anyway. Anyone have any experience/ideas on what may be happening here? FYI: No ABS light on, the ABS works normally in a straight line forward or backward, and the brake pedal goes almost down to the floor when in reverse. The bearings were replaced only on the drivers side. The rotors, calipers, and pads are all less than a year old and I had the brakes bled after the problems started and no change. Thanks in advance for any help/ideas.:)
 








Top