weird idle | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

weird idle

kdogg212001

Well-Known Member
Joined
February 1, 2004
Messages
385
Reaction score
0
City, State
stockton, california
Year, Model & Trim Level
94 xlt
i have a 1994 explorer xlt 4.0 taylor wires, bosch plugs, bbk 66mm tb and kkm intake and flowmasters!

what i am experiencing is that when i am at a stop or and idle i get weird jumps in the rpms! sometimes its small, sometimes it jerks forward hard. sometimes in neutral if i rev it the rpms will jump really high and stay up there untill i tap the gas pedal!

could this be a sensor or maybe the IAC ? any guesses or someone know what it is?

thanks!
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





Runnin'OnEmpty

Explorer Addict
Joined
July 20, 2002
Messages
2,083
Reaction score
123
City, State
Southeast USA
Year, Model & Trim Level
2000 Sport
Kdogg, I'd first check out the throttle linkage to make sure it isn't binding or catching on something. Sometimes it's the simple stuff.....

ROE
 






kdogg212001

Well-Known Member
Joined
February 1, 2004
Messages
385
Reaction score
0
City, State
stockton, california
Year, Model & Trim Level
94 xlt
i dont think it can be the throttle linkage cause the idle can increase and decrease on its own! which kinda freaks me out at times! almost had a close call in the drive through. i am thinking maybe is something on that top end!
 






Runnin'OnEmpty

Explorer Addict
Joined
July 20, 2002
Messages
2,083
Reaction score
123
City, State
Southeast USA
Year, Model & Trim Level
2000 Sport
Well, since you've eliminated the linkage, it must be the IAC sticking. Try unpluging it, and see if it will just barely idle; about 350-400 rpm. If this checks out, I'd clean the IAC and shoot some WD-40 into the electrical end of it. Maybe that'll free it up some.....
 






kdogg212001

Well-Known Member
Joined
February 1, 2004
Messages
385
Reaction score
0
City, State
stockton, california
Year, Model & Trim Level
94 xlt
one last thing that confuses me! if in fact its sticking how can it gain rpms on its own? like if i am holding the brake pedal how can the car give its self gas? i dont mind cleaning it but i am just curious about how it can give its self gas! maybe the electrical part is messing up?
 






Runnin'OnEmpty

Explorer Addict
Joined
July 20, 2002
Messages
2,083
Reaction score
123
City, State
Southeast USA
Year, Model & Trim Level
2000 Sport
Kdogg, maybe the IAC is sticking and then releasing when the throttle advances on it's own.....? Since you don't have a CEL lit, the IAC is about the only thing I can think of that would give a 'rolling' idle like you describe.
maybe the electrical part is messing up?
Yes, it very well could be. If it is, then cleaning it won't do any good. Might have to replace it.....
 






alexefron

Well-Known Member
Joined
July 30, 2004
Messages
309
Reaction score
0
City, State
Rochester, NY
Year, Model & Trim Level
93 XLT
The IAC lets in more air, bypassing the throttle plate. Its worth trying to clean it. It takes about 15 minutes.
 






Runnin'OnEmpty

Explorer Addict
Joined
July 20, 2002
Messages
2,083
Reaction score
123
City, State
Southeast USA
Year, Model & Trim Level
2000 Sport
Doggman, just thought of something else: Check the vacuum hose to the fuel pressure regulator for raw fuel. If raw fuel was being sucked into the manifold on an erratic basis, that would also give a rolling idle. This condition usually triggers a code, but who knows.....
 






kdogg212001

Well-Known Member
Joined
February 1, 2004
Messages
385
Reaction score
0
City, State
stockton, california
Year, Model & Trim Level
94 xlt
i was told to spray some cleaner into there and the cleaner should remove most of the build up, which i have done, unless theres a reccomended cleaner.
 






kdogg212001

Well-Known Member
Joined
February 1, 2004
Messages
385
Reaction score
0
City, State
stockton, california
Year, Model & Trim Level
94 xlt
yeah the only code i am getting is 111 which means that everything passed! WACKY
 






jennyb1075

New Member
Joined
March 19, 2006
Messages
9
Reaction score
0
City, State
morgan city, louisiana
Year, Model & Trim Level
2000 explorer sport
If it's just the IAC will the CEL stay on?
 






Runnin'OnEmpty

Explorer Addict
Joined
July 20, 2002
Messages
2,083
Reaction score
123
City, State
Southeast USA
Year, Model & Trim Level
2000 Sport
Welcome JennyB. :)

An IAC that's acting up will not usually trigger a CEL/MIL light.

Do you have a CEL on? If so, post the symptoms and/or codes and we'll try to help.....
 






Top