Weird Speedometer problem 2012 Base Explorer | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Weird Speedometer problem 2012 Base Explorer

Rokkor

New Member
Joined
December 17, 2015
Messages
1
Reaction score
0
Year, Model & Trim Level
2012 Explorer Base
Last month I bought a used 2012 Ford Explorer Base model. A week ago it really rained a lot! And I park outside. I noticed that my passenger side front carpet was soaking wet. I mean a lot, almost a puddle. I took it to the Ford dealership where I bought it and they are going to fix the leaking front windshield. Good...

But just now I was setting in the vehicle with the key out of the ignition, the doors shut and every 12 seconds I heard this weird scratching noise like a mouse was in the dash. Only I noticed that it was the speedometer and every 12 seconds the needle would move from zero backwards and then bounce back to zero. It does this consistently and the engine is off.

I'm a bit freaked out, is the speedo needle moving normal? or could some electronics be shorting out from all the water in the vehicle?

If somebody has the 2012 base model could you set in your car with the engine off, doors shut, key out of the ignition and see if yours does this too? Please....and thank you in advance.

UPDATE: 30 minutes latter I went out to start the vehicle and the battery was dead, which is odd as I had just moved it only an hour before and it started fine. I checked the battery with a battery charger and its completely dead....Could this be a dead shot under the dash from so much water from the leaking windshield?....I'm almost positive I didn't leave anything on when I parked the vehicle, is there any accessory that can run and drawn the battery down? It seems like all the lights, radio etc shut them selves off when the key is out of the ignition.
 






Last month I bought a used 2012 Ford Explorer Base model. A week ago it really rained a lot! And I park outside. I noticed that my passenger side front carpet was soaking wet. I mean a lot, almost a puddle. I took it to the Ford dealership where I bought it and they are going to fix the leaking front windshield. Good...

But just now I was setting in the vehicle with the key out of the ignition, the doors shut and every 12 seconds I heard this weird scratching noise like a mouse was in the dash. Only I noticed that it was the speedometer and every 12 seconds the needle would move from zero backwards and then bounce back to zero. It does this consistently and the engine is off.

I'm a bit freaked out, is the speedo needle moving normal? or could some electronics be shorting out from all the water in the vehicle?

If somebody has the 2012 base model could you set in your car with the engine off, doors shut, key out of the ignition and see if yours does this too? Please....and thank you in advance.

UPDATE: 30 minutes latter I went out to start the vehicle and the battery was dead, which is odd as I had just moved it only an hour before and it started fine. I checked the battery with a battery charger and its completely dead....Could this be a dead shot under the dash from so much water from the leaking windshield?....I'm almost positive I didn't leave anything on when I parked the vehicle, is there any accessory that can run and drawn the battery down? It seems like all the lights, radio etc shut them selves off when the key is out of the ignition.

Did the dealership cover the repairs on the windshield or did you pay out of pocket?

If they paid for it then I would get them to fix the electrical issue.

There are like 3 Data Joint connectors behind the glove box. Your speed signal is likely transmitted through one of the connectors/networks. BTW if one block gets shorted out the whole network goes down.

If the network is down then some modules don't know when to go to "sleep" (low power mode) and that could drain your battery.
 






Back
Top