Weird tick? | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

Weird tick?

AGodlyCanuck

Well-Known Member
Joined
June 13, 2018
Messages
191
Reaction score
67
City, State
Nelson, BC. Canada
Year, Model & Trim Level
1992 Explorer 4dr 4x4 XLT
So i installed a Junkyard motor, Everything is pretty good. Ended up replacing starter, and alternator and now ill have to do the radiator.
However, it runs. Seems okay at 100km/h too.

I do have this odd tick sometimes. Randomly happens Its like 5 loud ticks that last 3 seconds and that get quieter with every tick. Abny ideas? any concerns?
 


Holiday Special! Join the Elite Explorers $20 for 2 years! Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




shucker1

Elite Explorer
Joined
May 4, 2008
Messages
2,109
Reaction score
444
City, State
Metairie, Louisiana
Year, Model & Trim Level
98 XLT 5.0
Which engine?

When does the "Tick" happen?

Cranked exhaust manifold if it happens during start up or bad timing chains perhaps.
 




AGodlyCanuck

Well-Known Member
Joined
June 13, 2018
Messages
191
Reaction score
67
City, State
Nelson, BC. Canada
Year, Model & Trim Level
1992 Explorer 4dr 4x4 XLT
Which engine?

When does the "Tick" happen?

Cranked exhaust manifold if it happens during start up or bad timing chains perhaps.
oh, sorry. Its a 4.0 OHV in a 92.
Happens at idle.
 




shucker1

Elite Explorer
Joined
May 4, 2008
Messages
2,109
Reaction score
444
City, State
Metairie, Louisiana
Year, Model & Trim Level
98 XLT 5.0
At first start?
 




shucker1

Elite Explorer
Joined
May 4, 2008
Messages
2,109
Reaction score
444
City, State
Metairie, Louisiana
Year, Model & Trim Level
98 XLT 5.0
Everything I have seen around here is that the V-8's are bad about cracked exhaust manifolds at first cold start.

The SOHC loves to eat timing chains when it gets older.

The OHV is not a really bad player for chains but may like exhausts leaks.
 








AGodlyCanuck

Well-Known Member
Joined
June 13, 2018
Messages
191
Reaction score
67
City, State
Nelson, BC. Canada
Year, Model & Trim Level
1992 Explorer 4dr 4x4 XLT
'tick' is hard to diagnose. The V6 is prone to lifter tick. Could also be a fuel injector. I had random ticks in my engine for years, no problems though.

Well, My father who was a licensed, Red seal mechanic for 30 years always gives us this one piece of advice...

"If the vehicle still runs and drives the same and its not seeming to bother the computer, vehicle or you in any real way then its probably fine"

So. thats what i think.. It seems like even you guys think its relatively benign as it runs and drives fine. so ill just see if it goes away. The engine was sitting under a tree for 20 years so it could take some time i guess.
 




Top