What would cause codes 172,173,176,177 | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

What would cause codes 172,173,176,177

94ranger330

New Member
Joined
October 7, 2008
Messages
2
Reaction score
0
City, State
Greene County GA
Year, Model & Trim Level
94 4.0 RANGER 4X4
My ranger is running really rough, It is throwing the codes mentioned wich are both side lean and rich but what could cause it. I have replaced o2 sensors, maf, spark plug wires and plugs, air filter. Please help.
 






MrShorty

Explorer Addict
Joined
December 27, 2001
Messages
5,078
Reaction score
19
City, State
Spanish Fork, UT
Year, Model & Trim Level
92 XLT and '87 Bronco II
Do you get equivalent codes (136, 137, 172, 173) from the KOER test or do you get a different combination? Have you checked fuel pressure? Gas in the vacuum line to the fuel pressure regulator (FPR)? Any indications from the old spark plugs if it's running rich, lean, or what? Does the condition of the exhaust indicate rich or lean condition?
 






94ranger330

New Member
Joined
October 7, 2008
Messages
2
Reaction score
0
City, State
Greene County GA
Year, Model & Trim Level
94 4.0 RANGER 4X4
I get no KOER codes except 111 but the check engine light comes on from time to time.
 






MrShorty

Explorer Addict
Joined
December 27, 2001
Messages
5,078
Reaction score
19
City, State
Spanish Fork, UT
Year, Model & Trim Level
92 XLT and '87 Bronco II
That suggests that the fault is intermittent. If you clear the CM codes and test drive until the CEL comes on, do you always get the same 4 codes, or different combinations? Any consistency to when the CEL comes on?
 






Top