Won’t shift into over drive only 96 ford ranger | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Won’t shift into over drive only 96 ford ranger

David Carnahan

New Member
Joined
August 18, 2019
Messages
1
Reaction score
0
City, State
Dundas,Ontario
Year, Model & Trim Level
96 ford ranger xlt
Hi their I have a 1996 for ranger and and I’m having an issue with it going into overdrive was working fine last night and then now it’s not wanting to go into over drive, it will shift from the first 3 gears np at all and won’t go into overdrive only. The fluid is fine checked that and when I looked underneath at the pan their is no visible leaks did find wiring harness for the transmissionand it’s very dirty, should I try and clean that? It will hit 3000 rpms doing 80 and higher if I go faster what’s could cause this issue?
 






Mike65

Elite Explorer
Joined
December 31, 2013
Messages
4,222
Reaction score
473
Location
In my garage working on one of our vehicles.
City, State
Horsepasture, Virginia.
Year, Model & Trim Level
00 Ranger 4x4, 99 Sport.
David, welcome. Are there any warning lights that are on?. You might want to go to a local parts store & have them hook up a scanner & see if there are any codes in the system.
 






RichnMo

New Member
Joined
October 11, 2021
Messages
7
Reaction score
0
City, State
Ozark, Mo.
Year, Model & Trim Level
1997 Explorer Limited
Hi their I have a 1996 for ranger and and I’m having an issue with it going into overdrive was working fine last night and then now it’s not wanting to go into over drive, it will shift from the first 3 gears np at all and won’t go into overdrive only. The fluid is fine checked that and when I looked underneath at the pan their is no visible leaks did find wiring harness for the transmissionand it’s very dirty, should I try and clean that? It will hit 3000 rpms doing 80 and higher if I go faster what’s could cause this issue?
You might pull the plastic surrounding the ignition key and tumbler area as my 97 explorer had a similar issue where it wouldn't go into OD. When I took that plastic off you could see the wires coming from the button in the shifter were worn through and no longer making contact. I repaired them and good as new ! Good luck I hope this helps
 






RangerX

Elite Ranger
Staff member
Moderator
Elite Explorer
Joined
July 14, 1999
Messages
10,418
Reaction score
648
City, State
Omao, Kauai
Year, Model & Trim Level
'93 Ranger XLT 4X4
Do you have the 4.0, 3.0, or 2.3 engine?
 






Top