• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

Xeek's '91

my white 1991 explorer xlt 4wd. bought it 3/19/2010. first vehicle ive ever owned.


3.19.2010 - starting out
DSC_1690.jpg

DSCN1204.jpg

DSCN1206.jpg

DSCN1226.jpg

DSCN1243-1244.jpg

need to fix these
DSCN1215.jpg

DSCN1216.jpg




things ive done:

5.1.2010
new rearview
DSCN1231.jpg

DSCN1232.jpg


new cupholder
DSCN1235.jpg

DSCN1236.jpg




5.4.2010
new fogs
DSCN1256.jpg

DSCN1257.jpg




5.7.2010
new grill
DSCN1260.jpg

DSCN1261.jpg

DSCN1263.jpg




5.8.2010
painted headlightdoors black
DSCN1266.jpg


the starter also went out on me. truck is down for now



5.10.2010
out starter out. thanks jd
DSCN1274.jpg

new starter
DSCN1271.jpg

installed
DSCN1276.jpg




5.13.2010
painted grille black
DSCN1285.jpg




5.14.2010
brush guard/bull bar, also removed the valance. makes it look higher without it
DSCN1290.jpg




5.17.2010
best addition ever, explorerforum plate frames and a sticker
DSCN1299.jpg




5.18.2010
DSCN1300.jpg

DSCN1301.jpg

DSCN1304.jpg




6.4.2010
clear turns/corners and amber bulbs
DSCN1316.jpg

DSCN1317.jpg

DSCN1318.jpg

DSCN1320.jpg

DSCN1321.jpg




6.17.2010
replaced drivers door handle
DSCN1215.jpg

DSCN1381.jpg




6.22.2010
replaced engine coolant temperature sensor (cel)
replaced temperature sending unit so my guage works now (need it in this heat)



6.24.2010
new KKM intake
DSCN1372.jpg

DSCN1373.jpg

DSCN1380.jpg




8.19.2010
train horns and flowmaster 50 suv kit(sounds a little to low but i still like it)

exhaust
DSCN1432.jpg

DSCN1442.jpg

DSCN1441.jpg


train horns
DSCN1430.jpg

DSCN1435.jpg

^left compresser - right air valve
DSCN1436.jpg

DSCN1437.jpg

DSCN1438.jpg

DSCN1439.jpg

DSCN1440.jpg



sound clip. does no justice, much better in person
http://s141.photobucket.com/albums/r44/xeeky/?action=view&current=DSCN1434.mp4



10.11.2010
cherrybomb glasspack 18"
DSC_1903.jpg

DSC_1905.jpg




11.07.2010
loud rattle i was hearing? heat sheild on top of the 2nd cat came off and wedged itself from falling.

also took the glasspack off, no muffler. pipe stops right before it would be at
http://s141.photobucket.com/albums/r44/xeeky/?action=view&current=nomuffler.mp4



11.14.2010
gave myself an oil change. mobil 1 synthetic, k&n filter



11.22.2010-11.23.2010
ive always had a bogging/no get up and go on a cold start. so i went ahead and tried this: http://ford40.com/sputtering.shtml

left it to soak all night, dried today. there was some dirt/dust on the filaments. put it back in today along with a new maf from a cobra.
not only was there no more bogging when cold, i didnt have the slow response/bog related to having my battery unplugged and it relearning itself either.

i reccomend doing this if you have probs and notice the maf filaments are dirty.

the new maf sensor:
130_0580.jpg



and the painted area behine the grille:
130_0579.jpg


i will be painting the grille, bull bar, front bumper, rear bumper all with bedliner.
and at some point paint along the sides of the truck following the top of the bumper line in bed liner



11.24.2010-11.28.2010
bed lined front bumper, rear bumper+rear sides, grill, and re-added wal-mart lights.
took off the hitch that was attached the the bumper also.
DSC_1915-.jpg

DSC_1916-.jpg

DSC_1917-.jpg




12.20.2010
100_0595.jpg

20101221112304.jpg




01.22.11 - clearance lights. LED, 13 per light, 65 total. very bright.
DSC_2009.jpg

DSC_2011.jpg




3.27.2011
so after 3 months of the engine overhaul, its finally back in, finished, and fired up at 11.47pm! after fixing the inertia switch(oddly popped out), it fired right up, no problems!
link to build thread: http://www.explorerforum.com/forums/showthread.php?t=302553

video of its first start up



4.20.2011
2nd aux tranny cooler
DSC_2313.jpg


pcv filter.
DSC_2315.jpg




5.30.2011
'99 8.8, aussie, 3.73, soa
DSC_2347.jpg

DSC_2348.jpg

132_1674.jpg

132_1708.jpg

132_1709.jpg




9.4.11
non ac box conversion
DSC_2508.jpg

DSC_2509.jpg

DSC_2510.jpg




9.22.11
4" rough county lift and swap to 3.73 gears
DSC_2506.jpg

DSC_2515.jpg

DSC_2523.jpg

IMG_20110919_185859.jpg

IMG_20110923_123114.jpg




10.1.11
f150 tow hook
IMG_20111001_180834.jpg

IMG_20111001_181425.jpg




10.9.11
15x8 creager soft 8s put on my 32x11.5 bfgs
IMG_20111009_102526.jpg




10.16.11
class V tow hitch
IMG_20111016_153006.jpg

IMG_20111016_152826.jpg

IMG_20111016_152911.jpg

IMG_20111016_161138.jpg




12.31.11
drivers window motor damage. so nice to have a working window
IMG_20111231_150226.jpg




1.7.12
f150 seats to bring it to 5.5" lift
project #1 completed.
IMG_20120107_125001.jpg

IMG_20120107_143306.jpg

IMG_20120107_145802.jpg


4" + f150 seats + fa400 arm + unsettled suspension = this angle.
IMG_20120107_145819.jpg




1.7.12
IMG_20120107_154510.jpg

IMG_20120107_155045.jpg

IMG_20120107_160137.jpg




1.14.12
IMG_20120109_152245.jpg

IMG_20120114_162355.jpg

IMG_20120114_162437.jpg

IMG_20120114_162452.jpg
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




Sams01XplrSprt

Southern Cali Explorer
Joined
November 14, 2004
Messages
14,191
Reaction score
2
City, State
Newport Beach California & Bay Area California
Year, Model & Trim Level
2001 Sport (sold)
nice x u got there
 












Tbars4

Moderator Emeritus
Elite In Memoriam
Joined
March 4, 2007
Messages
26,477
Reaction score
67
City, State
anaheim hills,california
Year, Model & Trim Level
95 ranger 4x4/ 91 X 4x4
...Your moving right along and the swag looks sweet on your X...:biggthump
 




Vargas

Well-Known Member
Joined
December 3, 2004
Messages
295
Reaction score
0
City, State
Seattle, WA
Year, Model & Trim Level
'94 EB & two '00 XLT
Quick, find that Ex some door cards.
 








Xeek

Elite Explorer
Joined
March 21, 2010
Messages
2,988
Reaction score
16
City, State
Virginia Beach, VA
Year, Model & Trim Level
1991 xlt
anyone think theres a bodylift or have i never noticed all of em have a gap?


pulled codes today,
KOEO:
11. System OK
CM 14. Ignition pickup (PIP) was erratic - Ignition Systems

KOER:
21.Engine Coolant Temperature (ECT) sensor out of range - ECT



for 14, i do have acceceration probs when cold, sometimes when warm if i gun it more. would cleaning the maf sensor help? i saw something about cleaning it to help hesitation, sputtering (http://ford40.com/sputtering.shtml)

for 21, i did just buy a new sensor today actualy, my temp guage doesnt work at all, at or a little past C, never moves at all
gonna try and install it along with a new thermostat tomorrow. would that fix the guage(if its not the guage itself) or is it another part?
 












red.EDDIE.4x4

Well-Known Member
Joined
May 26, 2009
Messages
704
Reaction score
10
City, State
Tulsa, Oklahoma
Year, Model & Trim Level
'93 Eddie Bauer 4x4
you X looks great. i like the grille!
you should paint everything behind the grille flat black so it doesnt show up as much.

also on a side note... ive been looking for the same lights you have under your bumper so i can put them in the little cut out in the middle of the bumper, where did you get yours?
 








jd4242

Explorer Addict
Joined
October 15, 2008
Messages
10,785
Reaction score
286
City, State
va beach
Year, Model & Trim Level
92explorer&94 ranger
Did you replace your maf too or just the filter?
 




IZwack

Moderator Emeritus
Joined
February 5, 2003
Messages
21,726
Reaction score
27
City, State
Germantown, MD
Year, Model & Trim Level
1998 Ford Explorer
DO you, by any chance, have a pink camera? :p:

DSCN1232.jpg
 








4x4troy

Well-Known Member
Joined
October 12, 2009
Messages
118
Reaction score
0
City, State
middleburg,fl
Year, Model & Trim Level
99 xlt 5.0 awd
very nice job so far,nice x
 




Joe Dirt

Explorer Addict
Joined
October 4, 2007
Messages
13,366
Reaction score
19
Year, Model & Trim Level
07 Camry
Looks really good! :thumbsup:
 




Xeek

Elite Explorer
Joined
March 21, 2010
Messages
2,988
Reaction score
16
City, State
Virginia Beach, VA
Year, Model & Trim Level
1991 xlt
got a problem here. about a week after i took the door panel off to replace the broken handle and screw in the speaker that for some reason had no screws holding it in when i got it :/
anyway now my drivers window acts funny. wanted to know if its the regulator or the motor. all the other windows are ok, besides the back 2 being slow since i got the truck

video: http://s141.photobucket.com/albums/r44/xeeky/?action=view&current=DSCN1384.mp4

when all the way up/down it continues it try and move(the sound you hear) even though the windows all the way up/down and shouldnt do anything at all



one more thing. the emblem on the hatch that says explorer, is it glued on or is there bolts on the inside holding it on. just asking before i try and remove it
 




Doomie17

Well-Known Member
Joined
August 24, 2007
Messages
212
Reaction score
0
City, State
harford county, md
Year, Model & Trim Level
04 limited, 93 xlt
inside the window motor there are little plastic guess u can call them bearings but they are probally shot and need to be replaced
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.








Top