Serious Explorations Ford Explorer and Ranger Message Board
#1 Resource for Ford Explorer and Ranger Owners - By Enthusiasts, for Enthusiasts.


Ford Explorer Generation Guide

EF Swag Store 2016 Ford Explorer Forums Elite Membership Chat Room My Posts Reviews Explorer Photo Gallery
Go Back   Ford Explorer and Ranger Forums "Serious Explorations" > Ford Explorer Ranger Repair - Troubleshooting - Modifications & Detailing Forums > 2011 - 2016 Ford Explorer 5th Generation Explorer > Stock 2011 - 2016 Ford Explorer Discussion

Notices

Stock 2011 - 2016 Ford Explorer Discussion 2011 - 2016 Ford Explorer reviews, problem solving, maintenance, TSB, service bulletins, owner reviews, specifications, Ecoboost.

MY Touch system is inoperative.

Reply
 
Thread Tools
Old 05-09-2011, 09:39 AM   #1
Brooklyn1530
Old Bridge NJ
2011 Ford Explorer LTD
 
Join Date: May 2011
Posts: 1

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Original Poster)
Smile MY Touch system is inoperative.

So Just have my new Explorer 2011 LTD, like ony 2 weeks now & the my touch system is out already. Car back at dealership. Concerns me that this happened already. A lot of money for this to go wrong so fast. Love the truck, but very worried now over the computer issues, because nothing works without the my touch. I am curious to see what they say is the problem...
Brooklyn1530 is offline   Reply With Quote
( Join the Elite Explorers )

Elite Explorer Special Offer!! -- Join between Nov 28 - Dec 5, 2014 and get two years for the price of one. That's right just $20 for a two yearElite Explorer membership. Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications really work without having to experiment on your own. Elite Explorer members can change the forum "styles" to eliminate most ads, including blue underlined links, and no ads on photos. Other benefits include the ability to store 1000 Private Messages, upload photo attachments directly to your posts and to our Photo Gallery and more. Join the Elite Explorers today.


Old 05-09-2011, 10:44 AM   #2
BrooklynBay
Brooklyn, NY
 
BrooklynBay's Avatar
88 89 93 95 96 Aerostars
 
Join Date: Nov 2005
Posts: 47,984

Vehicle Specs

Mentioned: 4 Post(s)
Tagged: 1 Thread(s)
Quoted: 212 Post(s)
Welcome to this forum! I've moved your post into its own thread with a new title in the stock 2011 Explorer section.
BrooklynBay is offline   Reply With Quote
Old 06-03-2011, 09:14 PM   #3
cschafer
2011 XLT 4WD
 
Join Date: Jun 2011
Posts: 2

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Brooklyn1530 View Post
So Just have my new Explorer 2011 LTD, like ony 2 weeks now & the my touch system is out already. Car back at dealership. Concerns me that this happened already. A lot of money for this to go wrong so fast. Love the truck, but very worried now over the computer issues, because nothing works without the my touch. I am curious to see what they say is the problem...
Me too! The dealer has it for a week and the only thing that worked was replacing the entire computer system Just got it back today and they forgot to include the software for the voice activated navigation.
cschafer is offline   Reply With Quote
Old 06-04-2011, 02:41 PM   #4
Brigitte
Lake Parsippany, NJ
2011 Explorer XLT
 
Join Date: Jun 2011
Posts: 2

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My Touch inoperative

It absolutely sucks not having the mytouch! The first time the electronic lady said, "climate, 72 degrees", we were sold!
Anyways, it went out today, after about 3 weeks. The guy on the phone said to check and/or remove the fuse, that is apparently located in the "interior fuse panel" to the left of the steering column, by the brake pedal. We couldn't find this at all in the jumble of wiring stuffed up under the drivers feet, so we called the guy that sold us the Explorer, and he suggested disconnecting the battery for three minutes, and then reconnecting it.
We're going to try that now, I'll let you know!
Matt Cotton
Lake Parsippany, NJ
Brigitte is offline   Reply With Quote
Old 06-04-2011, 02:44 PM   #5
X~FACTOR
Name is Ray
Valley Stream, Long Island
 
X~FACTOR's Avatar
'97 XLT 4-dr SOHC
 
Join Date: Jan 2003
Posts: 6,834

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Too many similar problems on the 2011 model. Time for a recall?




__________________
My Mods
X~FACTOR is offline   Reply With Quote
Old 06-05-2011, 08:14 AM   #6
cschafer
2011 XLT 4WD
 
Join Date: Jun 2011
Posts: 2

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Brigitte View Post
It absolutely sucks not having the mytouch! The first time the electronic lady said, "climate, 72 degrees", we were sold!
Anyways, it went out today, after about 3 weeks. The guy on the phone said to check and/or remove the fuse, that is apparently located in the "interior fuse panel" to the left of the steering column, by the brake pedal. We couldn't find this at all in the jumble of wiring stuffed up under the drivers feet, so we called the guy that sold us the Explorer, and he suggested disconnecting the battery for three minutes, and then reconnecting it.
We're going to try that now, I'll let you know!
Matt Cotton
Lake Parsippany, NJ
Yes I checked the website and there is a technical bulletin that was supposed to work but it didnot. The fuse was not the problem. The entire computer needed to be replaced. Phone synced etc,
Ford sais...
Chauntay: Thank you for waiting. I'll be with you in just a moment.
Chauntay: I am currently checking the SYNC equipment information.
Chauntay: There is a technical service bulletin that has not been completed in your vehicle.
Chauntay: This bulletin should resolve the concerns.
Chauntay: The bulletin number is 11-4-18.
cschafer is offline   Reply With Quote
Old 06-05-2011, 08:25 AM   #7
robbs49
 
Join Date: Jan 2011
Posts: 12

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
At 500 miles on a car I had 3 days mine went black screen. Point,other then I am not that happy, is taking off the negative battery terminal fixed it. Takes about 3 minutes. I really like though spending 40000 and having to do that. It's not a fuse problem it's a you need to cut the power to the unit completely problem so it can restart. It would have been cheesy, but a reset button put somewhere would have solved almost all of the black screen issues easily for consumers.

Last edited by robbs49; 06-05-2011 at 08:29 AM. Reason: Spelling-fuse
robbs49 is offline   Reply With Quote
Old 06-06-2011, 02:22 PM   #8
Rocketfan
Los Angeles, CA
93 Explorer XLT
 
Join Date: Apr 2011
Posts: 130

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I agree with robbs49. With all the complaints and suggestions regarding pulling fuses and battery to force a reset, it is clear that the one thing MFT needs is a reset button (anyone working with Microsoft products knows this/ even my iPhone needs a reset now and then to get things working properly again).

Knock on wood, MFT has been working great for me so far (except for the fact that iPhone voice controls (USB or bluetooth stereo) are very MISS and sometimes hit so far) but I haven't hit my second week yet (when issues for some start to show up). I wouldn't have a problem manually resetting MFT now and again given my experience with Apple and MS products and think this might fix some of the issues that seem to creep into MFT (and all similar computing devices) after 2 weeks or some period of time.
Rocketfan is offline   Reply With Quote
Old 06-06-2011, 08:49 PM   #9
Brigitte
Lake Parsippany, NJ
2011 Explorer XLT
 
Join Date: Jun 2011
Posts: 2

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Dealer fixed the MFT

My dealer told me to bring the car in, but I said, "no, it's too far", so he let me take it to the dealer close by me. They "downloaded" something, and it about 2 hours it was fixed.
Disconnecting the battery for 3 minutes didn't work for me on Sunday.
I never did find the fuse, it's up under the dash under your feet where an owner would never be able to get to it.
So far, so good.
Matt Cotton
Lake Parsippany, NJ
Brigitte is offline   Reply With Quote
Old 06-06-2011, 11:42 PM   #10
aarmchair
toronto, ontario canada
2011 xlt, FWD,ltr,tow,nav
 
Join Date: May 2011
Posts: 46

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
mine went blank saturday afternoon - just died while driving. it was the first fault that i had in it in 1 1/2 months of ownership.

I left it overnight, to see if it woudl reset itself, but, Sunday morning, it was still not working. I could get heat and adjust fans, etc through the manual controls, but nothing was available through Synch or MFT.

After reading about some of the issues on the forum, I looked for the elusive # 29 fuse, and realized that getting to this fuse was all but impossible. Thus i disconnected the nagative terminal on the battery. Left it for about 3 minutes, hooked it back up and the system came right back on. I lost nothing that had been programmed in.

The only intersting this was the wrench came on on the screen and the engine ran rough. Turned it off, restarted, and the wrench went away.

It is interesting how each person seems to have a bit of a different experience everytime the batterry is disconnected. Most seem to lose MFT programming. I never lost the info, and this wrench appearance is interesting.

All seems to be working now, which is good, but for how long who knows. At least i know of this quick fix, and it is much easier to do then replacing fuse # 29. Will need to make sure i keep a 7/8 wrench with me, or replace the battery nuts with butterfly nuts to make removing and reinstalling easier.
aarmchair is offline   Reply With Quote
Reply


Suggest this thread to friends:



Join the "Elite Explorers" Today!



Search Explorer Forum


Top of Page

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:00 AM.



US Flag
We Support Our Troops!

Explore the site!


Copyright 2014 - 1996 Rick Horwitz Photography



Ford Motor Company is not involved in the management of this site in any way.



All tips on this site are for use at your own risk and discretion.

Modifying the suspension on any vehicle will cause changes to its handling characteristics.



Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.