Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

Temp gauge spikes

Discussion in 'Stock 1991 - 1994 Explorers' started by socialDK, November 4, 2009.

^^Searches ExplorerForum.com^^



Do Not Sell My Personal Information



  1. socialDK

    socialDK Member

    Joined:
    August 5, 2007
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    6
    City, State:
    san jose,ca
    Year, Model & Trim Level:
    91 xl
    Well long story short I was having temp problems. I blew out a clog in the radiator, found out there was no thermostat in the housing so I replaced it and added fresh fluids.

    I went on a 15-20 min drive today. 4 times the gauge quickly jumped from the NO to far M then went back down to below the N. 2 times I'm guessing was due to the engine warming up for the first time in the day then the thermostat opening cooling the engine. But what would cause the other 2 that I cant explain? I was not stopped at a light but I was slowing down. I don't think I lost any fluid but not 100% on that will keep an eye out.
     
  2. Support EF

    Join the Elite Explorers for $20.

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. Robrt32

    Robrt32 Active Member

    Joined:
    August 26, 2008
    Messages:
    319
    Likes Received:
    2
    Trophy Points:
    0
    City, State:
    Sledge Mississippi
    Year, Model & Trim Level:
    94 Explorer XLT
    Did you burp the cooling system? Mine still swings a little but not as much as your desribing
     
  4. socialDK

    socialDK Member

    Joined:
    August 5, 2007
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    6
    City, State:
    san jose,ca
    Year, Model & Trim Level:
    91 xl
    I thought I did. Perhaps I didn't let it get to operating temp. I did notice that my recovery container was very low, almost empty low but the radiator seemed full. What could that mean?
     
    Last edited: November 6, 2009

Share This Page







We Support Our Troops!