Slight rough idle after spark plug change | Page 2 | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Slight rough idle after spark plug change

robertoa1a

Well-Known Member
Joined
January 24, 2009
Messages
975
Reaction score
8
City, State
Jacksonville, FL
Year, Model & Trim Level
96 5.0 xlt 2wd white/char
The keychain looking gapper is neat because the hole is actually used to open the gap and prys it open from around the outside. The OEM plugs are great. As far as other parts I have had good luck with borg and warner replacement parts in a budget crunch.
 






John A Rossi

New Member
Joined
August 19, 2009
Messages
8
Reaction score
1
City, State
Norristown, Pa.
Year, Model & Trim Level
94 Eddie Bower
I`ve got a 94 that was given to me (FREE) by a neighbor who let it sit for 4 years. It is in really excellent shape, except for all of the wires that were destroyed by hungry squirrels. I have gotten everything that I need from the U-pull it yard and am currently removing and replacing wireing harness, vacuum lines, heater blower box, etc that was eaten. when replacing the plug wires with Summit blue 8mm wires, I had one wire that had a short metal lead that goes into the coil pack that just would not stay installed snuggly. In trying to get it inserted snuggly, I broke the locking tab that holds it down. :( (HELP) WHAT DO i DO kNOW? Do I need to buy a new set of wires, Hopefully not. Is there a possibility that I could cut off all the wire leads to the coil pack and replace them with the ones for a regular didtributor? I would love to replace them if they would stay tightly installed. Those locking tabs are really crappy in my opinion. All ideas would be greatly appreciated.
 






Top