Dismiss Notice



Register Today It's free! This box will disappear once registered!

2003 Explorer replaced IAC Valve now loud humming

Discussion in 'Stock 2002 - 2005 Explorers' started by clspruiell, September 28, 2012.

^^Searches ExplorerForum.com^^





  1. clspruiell

    clspruiell New Member

    Joined:
    August 6, 2012
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Birmingham, AL
    Year, Model & Trim Level:
    2003 Explorer
    Last week my 4.6L Explorer began idling very rough and finally would die. I pulled into an Express Oil change where they replaced the Idle Air Control Valve. It cost almost $200.

    Well today, at idle I began getting a bad hum / rumble from the air intake. Sounds like a blower.

    I have read other threads, but they all seem to said the IACV is bad, but I just replaced it.

    It also has a new air filter from Express.

    A car guy around here mentioned it could be the throttle body could be gunked up and that should always be done when replacing the IACV.

    Ideas about what this could be and how much it might cost?? Thanks!!
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. matt0248

    matt0248 Active Member

    Joined:
    July 12, 2010
    Messages:
    761
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Chicago
    Year, Model & Trim Level:
    02 XLT V8
    Replace the IAC with a motorcraft one only. I used a Borg Warner one and it did the same thing, annoying loud humming noise from the intake. I compared the old to the new and the new BWD one was different on the inside air path. It must have been causing the air turbulence/humming noise.
     
  4. 05explorerXLT

    05explorerXLT Member

    Joined:
    August 28, 2006
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    City, State:
    Las Vegas
    Year, Model & Trim Level:
    05 XLT
    Yup, if it has a fog horn like sound to it then they either installed a cheap IAC or the wrong one.
     
  5. clspruiell

    clspruiell New Member

    Joined:
    August 6, 2012
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Birmingham, AL
    Year, Model & Trim Level:
    2003 Explorer
    Update... I had express replace with the same part, within 5 seconds, humming again. So we got advanced to bring us another brand (idk which brand) and its been working well for a day and a half.

    The ONLY thing I see is sometimes it'll bog down to around 500 rpms while sitting still. It's usually quick to correct itself, but acts like it wants to do the same thing. That does not happen every time I stop at a redlight, just sometimes.
     
  6. matt0248

    matt0248 Active Member

    Joined:
    July 12, 2010
    Messages:
    761
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Chicago
    Year, Model & Trim Level:
    02 XLT V8
    Motorcraft is the ONLY way to go, IMHO. I have tried others and they do not work as well.
     

Share This Page







We Support Our Troops!