Dismiss Notice



Register Today It's free! This box will disappear once registered!

ABS Light "ON" ??

Discussion in 'Stock 1995 - 2001 Explorers' started by rock5b, July 31, 2011.

  • Searches ExplorerForum.com
    1. rock5b

      rock5b New Member

      Joined:
      July 31, 2011
      Messages:
      3
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Boron, California
      Year, Model & Trim Level:
      1997 Explorer 4AWD XLT
      All of a sudden one day my ABS light stayed on after I started and took off. It has been on for quite some time now. Obviously I checked the fuses and connections first. Well, I finally had to R/R steering rack 3rd time, so while it was up on the rack, I checked the front 2 sensors-visually good. What is bothering me is while doing the diagnostic tree thing on AllDataDIY and talking to my local ford dealer, one thing I was supposed to visually check was the reluctor ring the sensors are supposed to sense for wheel speed. They are non existent on my truck. ???????????????????? Anyone have an answer for 1) Why now reluctor ring? 2) Why every 18-24 months I have to replace my steering rack assy (leaking inner tie rod seal)?http://www.explorerforum.com/forums/images/icons/icon6.gif:exp:
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.

    Share This Page







    We Support Our Troops!