Dismiss Notice



Register Today It's free! This box will disappear once registered!

Help Please Injectors replaced!!!

Discussion in 'Under the Hood' started by monkeydude3, December 8, 2004.

^^Searches ExplorerForum.com^^
  1. monkeydude3

    monkeydude3 Active Member

    Joined:
    May 8, 2004
    Messages:
    477
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Millbrook, Illinois
    Year, Model & Trim Level:
    2001 Explorer Sport Trac
    Hello all~
    I have a 1994 XL explorer, 2wd stick shift trans... 4.0L OHV engine. I just replaced all six of the fuel injectors exactly right, in my auto class, but now I have a few problems. It still runs a little bit rough, and over by the engine I hear a "tsst tsst tsst tsst" really fast paced and suttle, but it wasn't there before... and now at the tail pipe when it idles i hear "pop pop pop pop idle pop pop" faint popping in the exhaust, and it does this all the time.... I want to know if I may have uncovered a vacuum leak somewhere or if this is normal as the computer re learns the fact it has six new injectors.... any help would be greatly appreciated. Thanks!

    George
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.







We Support Our Troops!