1. Register Today It's free! This box and some ads will disappear once registered!

    Dismiss Notice

Hey gang, give a listen and tell me what you think this could be...

Discussion in 'Ford Lincoln Mercury' started by ragajungle, July 24, 2011.

^^Searches ExplorerForum.com^^



Do Not Sell My Personal Information


  1. ragajungle

    ragajungle Well-Known Member

    Joined:
    November 8, 2008
    Messages:
    1,030
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Chicago, IL
    Year, Model & Trim Level:
    89 BroncoII & 05 Taurus
    For those Explorer drivers who have been unfortunate enough to have experience with Escort/Tracer

    strange whirring sound started recently. FYI New Timing belt, timing tensioner, belt tensioner. Cam???
    http://www.youtube.com/watch?v=6viPQ7FqeSI

    FYI This video was borrowed from youtube, and is a 1.9L - mine is a 2.0L SOHC (exact same motor) and makes the exact same noise...

    Thanks for giving a look!
    -Mike
     
  2. Support EF

    Join the Elite Explorers for $20.

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no advertisements, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. BrooklynBay

    BrooklynBay Moderator & long time member. Staff Member Moderator Elite Explorer

    Joined:
    November 11, 2005
    Messages:
    54,115
    Likes Received:
    457
    Trophy Points:
    113
    City, State:
    Brooklyn, NY
    Year, Model & Trim Level:
    88 89 93 95 96 Aerostars
  4. ragajungle

    ragajungle Well-Known Member

    Joined:
    November 8, 2008
    Messages:
    1,030
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Chicago, IL
    Year, Model & Trim Level:
    89 BroncoII & 05 Taurus
    Thanks Brooklyn, In my case the tensioner is "spring tensioned" and there is no adjustment. The earlier Escort 1.9L had a manually tensioned belt. This weekend I am going to drop the serp and see if the noise persists.
     
  5. ragajungle

    ragajungle Well-Known Member

    Joined:
    November 8, 2008
    Messages:
    1,030
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Chicago, IL
    Year, Model & Trim Level:
    89 BroncoII & 05 Taurus
    Well I dropped the ACC drive belt, which illiminates A/C, P/S, and ALT. So it is either the Water Pump, Timing tensioner or A cam bearing.... Uhg.
     
  6. Jack Flash

    Jack Flash Active Member

    Joined:
    October 11, 2007
    Messages:
    368
    Likes Received:
    1
    Trophy Points:
    16
    City, State:
    Ethel, MS
    Year, Model & Trim Level:
    (3) '88 BII's, '99 Ranger
    doesn't sound like a water pump. most likely is the tensioner. while you're in there, I'd replace the belt, too.

    not trying to alarm you, but I've seen one of the 2.0 engines have the cam to seize up in the head. the people had little oil pressure & hadn't changed oil in years.

    ,
    ,

    J...I have an Escort wagon that gets 35 mpg on the road !
     

Share This Page







We Support Our Troops!