Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

Interior lights stay on

Discussion in 'Stock 2002 - 2005 Explorers' started by lrm, September 10, 2008.

^^Searches ExplorerForum.com^^





  1. Fox Fader

    Fox Fader Active Member

    Joined:
    May 30, 2009
    Messages:
    223
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Columbus, GA
    Year, Model & Trim Level:
    searching
    Good thread, glad to know this.
     
  2. Support EF

    Elite Explorer 2 for 1 Sale! $20 for 2 years!

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. rkmiller5

    rkmiller5 New Member

    Joined:
    September 28, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Germantown, WI
    Year, Model & Trim Level:
    2002 Explorer
    Not the Door Jam Sensor. It's a broken wire in the door

    I had the same symptoms.
    1. Door Ajar Light off
    2. Key in ignition warning on even with door closed
    3. Dome light stayed on until the battery saver timeout turned it off
    4. Hitting lock twice on the key fob gave a double horn beep like a door was ajar.
    5. Keyless entry would not lock car
    6. Keyless entry would unlock car but set off alarm until code was entered.
    7. Radio would turn off immediately instead of courtesy off.

    I replaced the door jam sensor (What a Pain!) No change
    Then read this forum and found the black wire between the door and body.

    I had to remove the door panel, and speaker, then remove the electrical tape to peel back the rubber boot far enough.

    The black wire was almost cut clean.

    I spliced it together and everything works great!

    Thanks for all of you who posted this before me
     
  4. alexk

    alexk Active Member

    Joined:
    February 22, 2009
    Messages:
    827
    Likes Received:
    1
    Trophy Points:
    28
    City, State:
    New Jersey
    Year, Model & Trim Level:
    15 Sport
    I got to thinking, mine does this and could it somehow be related to the puddle lamp on the drivers side not working?
     
  5. YountExplr

    YountExplr Active Member

    Joined:
    January 11, 2008
    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Chino Valley, AZ
    Year, Model & Trim Level:
    '97 XL
    so what would I look for if my rear passenger door was activating the door ajar light and I have intermittent control of the window from the drivers controls, but control of it from the door itself. Also my locks work from my rear button (by the glass hatch) but not so much from my drivers controls (only on occation).
     
  6. LoKo498

    LoKo498 Active Member

    Joined:
    July 24, 2009
    Messages:
    120
    Likes Received:
    1
    Trophy Points:
    18
    City, State:
    J.C.,N.J.
    Year, Model & Trim Level:
    2002 XLT
    I have the same problem on my 02 Explorer. Just started happening about 2 weeks ago & getting worse. I read that the WD40 trick will work & to look for the broken black ground wire.
    I will try both them tricks in the morn & let you guys kno what happens.
    With the truck parked & alarm armed, it sometimes go off for no reason in the night.
    Thank you guys for this great how to & hopefully this will fix my problem.
     
  7. JeffBoston

    JeffBoston New Member

    Joined:
    February 20, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    2003 Explorer
    you guys all rock
    i took off the panel, spliced the ground wire and the wire that ran the power mirrors.
    everything works again.
    many thanks
    jeff
     
  8. LoKo498

    LoKo498 Active Member

    Joined:
    July 24, 2009
    Messages:
    120
    Likes Received:
    1
    Trophy Points:
    18
    City, State:
    J.C.,N.J.
    Year, Model & Trim Level:
    2002 XLT
    I sprayed some WD40 in the door latch area & it seems to work. Been going good for about 3 weeks now!!!
     
  9. dklimek

    dklimek New Member

    Joined:
    December 6, 2010
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    1997 XLT
    I LOVE THIS FORUM!!! I have literally been driving myself friggin crazy trying to pin this problem down, my lock doesn't work, my radio is messed up, the electronics have started to stay on a little after the key is turned off, and the dimmer setup is screwed up..the door ajar light wont go off nor will the lights. Going to pull it apart more in a little!
     
  10. Oldwolf

    Oldwolf Active Member

    Joined:
    September 22, 2005
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    16
    City, State:
    Cary, NC
    Year, Model & Trim Level:
    2002 XLT, 4x4, 4.0 SOHC
    Why are you guys removing the door panel if the break is in the wire in the rubber boot?

    I fixed mine a while back by sliding the boot away from the wire far enough to fix it.

    It is broken again, because again, the puddle lamp has stopped working.

    Has anyone bough a new wiring harness yet? It looks like it might plug in behind the door panel and under the dashboard. Can anyone confirm this?
     
    Last edited: April 12, 2011
  11. BigRondo

    BigRondo USMC 1371 Elite Explorer Moderator Emeritus

    Joined:
    February 15, 2010
    Messages:
    7,886
    Likes Received:
    10
    Trophy Points:
    48
    City, State:
    Worcester, MA
    Year, Model & Trim Level:
    2002 XLT V6 4x4
    Taking the door panel off allows easier access to the broken wires. I pulled the broken wire into the door and connected a piece of new wire then ran the new in through the boot and connected to the other end of the broken wire. This new piece of wire will relieve the stress on the wire.

    I suspect that yours broke again because the stress wasn't relieved.
     
  12. mkaroc

    mkaroc New Member

    Joined:
    June 28, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    2003
    Interior lights stay on; door ajar;

    just wanted to say thanks for the suggestions; the WD-40 on the door latches worked great. Door ajar notice, interior lights wont go off, accessories don't work after key is removed; key in the ignition warning chime with door closed - all fixed with WD40 to the sticking door latch relay. Power to the internet!
     
  13. BigRondo

    BigRondo USMC 1371 Elite Explorer Moderator Emeritus

    Joined:
    February 15, 2010
    Messages:
    7,886
    Likes Received:
    10
    Trophy Points:
    48
    City, State:
    Worcester, MA
    Year, Model & Trim Level:
    2002 XLT V6 4x4
    Welcome aboard mkaroc!! :salute:

    Glad you got it fixed! :biggthump
     
  14. rc2009

    rc2009 New Member

    Joined:
    June 21, 2012
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    2002 Ford Explorer
    im stumped

    I cant figure it out. Sometimes the alarm horn beeps twice sometimes just once. And unless you turn the dome lights off by the switch they just stay on. Ive read on here that it could be in the door latched or could be the ground wire in the boot. But the windows still work and locks still lock and unlock. I do have a blown courtesy light bulb in my mirror. Could that be my problem why they stay on. Like I said. Im stumped. I would gladly appreciate the help. Thanks.
     
  15. BigRondo

    BigRondo USMC 1371 Elite Explorer Moderator Emeritus

    Joined:
    February 15, 2010
    Messages:
    7,886
    Likes Received:
    10
    Trophy Points:
    48
    City, State:
    Worcester, MA
    Year, Model & Trim Level:
    2002 XLT V6 4x4
    Welcome aboard!! :salute:

    I had similar electrical issues with my 02 xlt. The dome lights would stay on until the battery saver feature turned them off, the accessory delay wasn't working, the driver side puddle light didn't work, the keypad on the door would set off the alarm when I pressed it, the door ajar light would flash and beep at highway speeds, the radio would shut off as soon as I turned the key off, the delayed accessories didn't work, etc. The alarm would beep twice when I armed it. Recently all 4 windows stopped working. Most recently the driver door lock actuator stopped working.

    A lot of electrical issues can be traced back to broken/damaged wire(s) in the boot between the body and the driver's door. I found 2 broken wires and repaired them. The thin black ground wire was broken and after repairing it all was back to normal. When the windows stopped working, I repaired the thick black ground wire and the windows now work like a champ. I had to repair the pink/black wire to fix the driver door lock actuator.

    Here is the thread for removing the door panel: http://www.explorerforum.com/forums//showthread.php?t=303524

    Here is a great thread for checking for broken/damaged wires, thanks to synyster for this awesome write-up: http://www.explorerforum.com/forums//showthread.php?t=270081

    Be sure to take your time when looking for broken/damaged wire(s). Check all the wires for breaks/damage. When you think you're done looking, look again, and again, and again. A bright flashlight can be very helpful.

    Could also be related to the door ajar switch.

    Here is a great thread for checking/replacing the door ajar switch, thanks to borland for the awesome write-up: http://www.explorerforum.com/forums/showthread.php?t=249253

    Hope this helps out! :biggthump
     
  16. rc2009

    rc2009 New Member

    Joined:
    June 21, 2012
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    2002 Ford Explorer
    Ok so after driving my explorer and diagnosing problems. I found out unless you have the dash light switch turned off, when you turn the truck off and take the key out the radio shuts off and the interior and puddle lights come on and the theft light blinkes without the door opened. Also the alarm horn goes off twice like a door is open. But whenever you turn the switch off everything goes back to normal except the theft light still blinks. So can anybody help me with whats going on with my explorer?
     
  17. BigRondo

    BigRondo USMC 1371 Elite Explorer Moderator Emeritus

    Joined:
    February 15, 2010
    Messages:
    7,886
    Likes Received:
    10
    Trophy Points:
    48
    City, State:
    Worcester, MA
    Year, Model & Trim Level:
    2002 XLT V6 4x4
    Have you checked for broken/damaged wire(s) in the boot between the body and the driver's door, and/or sprayed WD40 into the door latch opening on each door?
     
  18. rc2009

    rc2009 New Member

    Joined:
    June 21, 2012
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    2002 Ford Explorer
    I havent tried looking for the broken wire between the driver door and body. I did spray wd-40 in all the door latched and that didnt work. Another thing I noticed by coincidence was when you turn the rear defroster on the door ajar indicator goes off. Idk what the deal with that is. My next solution though is the the boot between the driver door. If that is it how would I go about repairing it?
     
  19. BigRondo

    BigRondo USMC 1371 Elite Explorer Moderator Emeritus

    Joined:
    February 15, 2010
    Messages:
    7,886
    Likes Received:
    10
    Trophy Points:
    48
    City, State:
    Worcester, MA
    Year, Model & Trim Level:
    2002 XLT V6 4x4
    I had similar electrical issues with my 02 xlt. The dome lights would stay on until the battery saver feature turned them off, the accessory delay wasn't working, the driver side puddle light didn't work, the keypad on the door would set off the alarm when I pressed it, the door ajar light would flash and beep at highway speeds, the radio would shut off as soon as I turned the key off, the delayed accessories didn't work, etc. The alarm would beep twice when I armed it. Recently all 4 windows stopped working. Most recently the driver door lock actuator stopped working.

    A lot of electrical issues can be traced back to broken/damaged wire(s) in the boot between the body and the driver's door. I found 3 broken wires and repaired them. The thin black ground wire was broken and after repairing it all was back to normal. When the windows stopped working, I repaired the thick black ground wire and the windows now work like a champ. I had to repair the pink/black wire to fix the driver door lock actuator.

    Here is the thread for removing the door panel: http://www.explorerforum.com/forums//showthread.php?t=303524

    Here is a great thread for checking for broken/damaged wires, thanks to synyster for this awesome write-up: http://www.explorerforum.com/forums//showthread.php?t=270081

    Be sure to take your time when looking for broken/damaged wire(s). Check all the wires for breaks/damage. When you think you're done looking, look again, and again, and again. A bright flashlight can be very helpful.
     
  20. RLH

    RLH New Member

    Joined:
    September 30, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Year, Model & Trim Level:
    2002 exporer xlt 4x4
    Thanks for all the info on a broken wire in the door boot. Had the same problem and was getting ready to start checking door switches. Read your solutions and checked for a broken black wire and there it was. Repaired it and now everything is working great. Thanks again. saved me lots of time and work.
     
  21. Majin1084

    Majin1084 New Member

    Joined:
    December 2, 2014
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    City, State:
    Miami, FL
    Year, Model & Trim Level:
    02 Explorer V8 Limited
    Hey guys, just started having this problem as well. On a side note I just broke my shifting gear lever on my explorer as well this past Monday and my 6 CD radio won't let me eject my CDs out. What bad luck I've had this week with my car. Anyways I notice this with my car, I don't have the door ajar problem but I did notice before this started happening that whenever I pushed the rear defrost that my car would say door ajar, but now that this happened with the interior lights it stop doing that all of a sudden. While I was trying to figure it out, I also noticed on my driver side door the mirror with the light would not turn on when I would unlock the door with the alarm like the other side did, yet when I had the door open the light would come on, then I realized that it would turn off when I would close the door half way. Anyways I'm going to open the door panel this weekend, while also fixing my other problems. Hoping some of the solutions that I've read dealing with this issue is just a loose/broken wire. I'll be posting a picture of this issue so if anyone catches something I miss, please let me know. So I can correct.
     

Share This Page







We Support Our Troops!