Dismiss Notice



Register Today It's free! This box will disappear once registered!

radiator question

Discussion in 'Stock 1995 - 2001 Explorers' started by grerod, July 12, 2011.

  • Searches ExplorerForum.com
    1. grerod

      grerod New Member

      Joined:
      December 30, 2007
      Messages:
      23
      Likes Received:
      0
      Trophy Points:
      0
      Year, Model & Trim Level:
      96 sport 4wd
      Changed the radiator in a 96 explorer and now i have a leak at the transmission lines. I wanted to see if it was okay to use teflon tape on the connections.
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. joecrna

      joecrna Active Member

      Joined:
      October 25, 2006
      Messages:
      740
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      Las Flores, CA
      Year, Model & Trim Level:
      98 XLT 4X4 sohc
      Use the special oil/gas teflon tape. First I would loosen and recheck your connections. Did the threads on the radiator or tubes get damaged. They really shouldn't need teflon tape.
       
    4. grerod

      grerod New Member

      Joined:
      December 30, 2007
      Messages:
      23
      Likes Received:
      0
      Trophy Points:
      0
      Year, Model & Trim Level:
      96 sport 4wd
      I checked them and they seem fine it is not a big leak but just enough to be a problem on the ground and the engine.
       

    Share This Page







    We Support Our Troops!