1. Tip...
    If you hold most smartphones sideways
    you can bring up a more full featured version of the forum.
    Dismiss Notice
Dismiss Notice



Register Today It's free! This box will disappear once registered!

im getting nothin from my trans.

Discussion in 'Transmissions & Transfer Cases' started by dugzilla, August 8, 2011.

^^Searches ExplorerForum.com^^





  1. dugzilla

    dugzilla New Member

    Joined:
    May 9, 2011
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    anderson mo
    Year, Model & Trim Level:
    92 xlt
    ok so i was giving this 92 ex xlt with auto trans. i start it up and put it in any gear and nothing motor just revs the weird thing is i dont have to press the break peddle to do this. i have changed the filter and filled it back up. so now what do i do? please someone help me. thanks
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


  3. PopRichie77

    PopRichie77 Well-Known Member

    Joined:
    June 14, 2010
    Messages:
    1,197
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Quakertown, PA
    Year, Model & Trim Level:
    2001 Explorer Sport 4X4

Share This Page







We Support Our Troops!