1. Tip...
    If you hold most smartphones sideways
    you can bring up a more full featured version of the forum.
    Dismiss Notice
Dismiss Notice



Register Today It's free! This box will disappear once registered!

Radio Problem?

Discussion in 'Explorer Audio & Navigation' started by mercuryman97, January 3, 2005.

  • Searches ExplorerForum.com
    1. mercuryman97

      mercuryman97 Active Member

      Joined:
      September 9, 2004
      Messages:
      123
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      greenville,sc
      Year, Model & Trim Level:
      1997 Mercury Mountaineer
      i have a 1997 mercury mountaineer....and when i turn on my radio, all i hear is static, it seems that the atenna is unplugged but when i looked at the back of my cd player my atenna is still plugged in, but still i have no radio, any ideas to why this might be happening and how to fix it?
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.

    Share This Page







    We Support Our Troops!