Dismiss Notice



Register Today It's free! This box will disappear once registered!

Speakers cut out randomly - fix for this?

Discussion in 'Stock 2002 - 2005 Explorers' started by mikeywou, July 18, 2011.

  • Searches ExplorerForum.com
    1. mikeywou

      mikeywou New Member

      Joined:
      July 18, 2011
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Oregon
      Year, Model & Trim Level:
      2004 XLT
      It started with the driver's side speaker, cutting out. Sometimes by turning the volume up real loud, the speaker would kick back on. Now it is also happening with the passenger side speaker. Any ideas on why this is happening? I was thinking that maybe an aftermarket stereo would fix the problem...or is it the speaker system or wiring? Any help would be appreciated. Thanks.
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. Drummadude

      Drummadude New Member

      Joined:
      July 13, 2011
      Messages:
      28
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Midwest
      Year, Model & Trim Level:
      2002 Explorer XLT Blue
      I haven't done any car audio, but as for home audio, loose wiring can be a culprit for the speakers not working correctly. You might see if you can take the speaker out and check the connections.
       
    4. Braydon

      Braydon New Member

      Joined:
      April 17, 2011
      Messages:
      23
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      West Haven, Utah
      Year, Model & Trim Level:
      93 xlt
      yeah happens to me once in a while to. my guess is bad connections, just from my own experiences.
       

    Share This Page







    We Support Our Troops!