Dismiss Notice



Register Today It's free! This box will disappear once registered!

Transmission, klunk, in overdrive

Discussion in 'Under the Hood' started by rkudart, December 20, 2004.

^^Searches ExplorerForum.com^^
  1. rkudart

    rkudart New Member

    Joined:
    December 20, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Sammamish,WA
    Year, Model & Trim Level:
    1996 xlt v8 awd
    Need Help,Transmission, klunk, in overdrive

    Hello all- I have a 1996 explorer xlt v8 awd. When driving on the highway with the OD on, everything runs fine until the vehicle hits 60 mph, then theres a klunk, the vehicle continues to drive ok and the klunk is intermittent over 60 mph, not happening alot but its there. When the overdrive is turned off this doesn`t happen. The transmission was just flushed at the dealership and a new filter. I`ve reset the computer and have no codes to report. Thanks for all your input. Ralph
     
    Last edited: December 27, 2004
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.







We Support Our Troops!