MFT 3.8 bug and downgrade to 3.7.11 | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

MFT 3.8 bug and downgrade to 3.7.11

13Sport

Explorer Addict
Joined
June 29, 2012
Messages
1,118
Reaction score
11
City, State
Los Angeles, CA
Year, Model & Trim Level
2015 Explorer Sport
MFT 3.8 has an annoying bug where it will only connect to the favorite bluetooth device for audio when the vehicle is started. My setup is an iPad mounted on the dash connected via bluetooth for audio, and an iPhone connected as phone. Since 3.8 whenever turning the vehicle on it does not connect to the last connected bluetooth for audio it will connect to the phone, if the phone has audio turned off it will default to AM radio after the connection fails.

I finally got annoyed with this and downgraded MFT back to 3.7.11. It was between Siri integration and having to switch audio sources every time I entered the vehicle (even after short stops like getting gas or grabbing a water), or having no Siri and having the audio work as expected, I chose the audio functionality.

*edit: Downgrade procedure:

**** PROCEED AT YOUR OWN RISK ****

I have performed this operation 4 times with no problems, but I take no responsibility if something gets messed up while attempting this downgrade.

*** PROCEED AT YOUR OWN RISK ***

**NOTE:
THIS IS FOR US VERSIONS OF MFT ONLY. I can't verify the behavior on non US versions, if you attempt this downgrade on a non US version you may end up with a non-functional MFT.

1) Obtain the original 3.7.11 installation zip. This is available in a few locations online, the file name is Gen2v3713build14122updatepackageNARev3.zip or Gen2v3713build14122updatepackageNARev4.zip, if you download Rev3 you will need 7zip to unzip it.

2) Unzip installation package, you will have a SyncMyRide folder, and two files (autoinstall.lst and DONTINDX.MSA).

3) Copy the folder and two files to a USB stick (formatted as FAT)

4) Edit the autoinstall.lst file with a text editor (notepad on windows textedit on mac)

The second group of files starts with
[SYNCGen2_4.30.13171]

Add at the beginning of this group
[SYNCGen2_3.08.15128]

The group should like like the following
Code:
[SYNCGen2_3.08.15128]
[SYNCGen2_4.30.13171]
[SYNCGen2_4.31.13319]
Item1 = BT4T-14D546-EE
Open1 = SyncMyRide\BT4T-14D546-EE.cab 
Item2 = EA5T-14D546-AKB
Open2 = SyncMyRide\EA5T-14D546-AKB.cab 
Item3 = EA5T-14D546-ALB
Open3 = SyncMyRide\EA5T-14D546-ALB.cab 
Item4 = EA5T-14D546-HB
Open4 = SyncMyRide\EA5T-14D546-HB.cab 
Item5 = BT4T-14D546-FB
Open5 = SyncMyRide\BT4T-14D546-FB.cab 
Item6 = EA5T-14D546-AHB
Open6 = SyncMyRide\EA5T-14D546-AHB.cab 
Item7 = EA5T-14D546-AEB
Open7 = SyncMyRide\EA5T-14D546-AEB.cab 
Options = AutoInstall

Here is the final version of the file on the USB stick

Code:
autoinstall.lst with added Master Patch
;+++++++++++++++++++++++++++++++++++++++++++++++! 
;          Microsoft Windows Automotive         ! 
;         USB Installation Directive File       ! 
;         3.7 (14122) Update from:              ! 
;         10308,10337,11038,11063,11081,11134   ! 
;         12023,12156,12285,13171,13319         ! 
;         Other versions not supported          ! 
;         autoinstall.lst (NA)                  ! 
;                                               ! 
;+++++++++++++++++++++++++++++++++++++++++++++++! 
 
;;; 
;;; The following tags are software versions supported by this update 
;;; 
[SYNCGen2_4.22.10308]
[SYNCGen2_4.22.10337]
[SYNCGen2_4.23.11038]
[SYNCGen2_4.23.11063]
[SYNCGen2_4.23.11081]
[SYNCGen2_4.23.11134]
[SYNCGen2_4.26.12023]
[SYNCGen2_4.28.12156]
[SYNCGen2_4.29.12285]
Item1 = BT4T-14D546-EE
Open1 = SyncMyRide\BT4T-14D546-EE.cab
Item2 = EA5T-14D546-AKB
Open2 = SyncMyRide\EA5T-14D546-AKB.cab
Item3 = EA5T-14D546-ALB
Open3 = SyncMyRide\EA5T-14D546-ALB.cab
Item4 = EA5T-14D546-HB
Open4 = SyncMyRide\EA5T-14D546-HB.cab
Item5 = EA5T-14D546-ACB
Open5 = SyncMyRide\EA5T-14D546-ACB.zip
Item6 = BT4T-14D546-FB
Open6 = SyncMyRide\BT4T-14D546-FB.cab
Item7 = EA5T-14D546-AHB
Open7 = SyncMyRide\EA5T-14D546-AHB.cab
Item8 = EA5T-14D546-ADB
Open8 = SyncMyRide\EA5T-14D546-ADB.cab
Item9 = EA5T-14D546-AEB
Open9 = SyncMyRide\EA5T-14D546-AEB.cab
Options = AutoInstall 
 
[SYNCGen2_3.08.15128]
[SYNCGen2_4.30.13171]
[SYNCGen2_4.31.13319]
Item1 = BT4T-14D546-EE
Open1 = SyncMyRide\BT4T-14D546-EE.cab 
Item2 = EA5T-14D546-AKB
Open2 = SyncMyRide\EA5T-14D546-AKB.cab 
Item3 = EA5T-14D546-ALB
Open3 = SyncMyRide\EA5T-14D546-ALB.cab 
Item4 = EA5T-14D546-HB
Open4 = SyncMyRide\EA5T-14D546-HB.cab 
Item5 = BT4T-14D546-FB
Open5 = SyncMyRide\BT4T-14D546-FB.cab 
Item6 = EA5T-14D546-AHB
Open6 = SyncMyRide\EA5T-14D546-AHB.cab 
Item7 = EA5T-14D546-AEB
Open7 = SyncMyRide\EA5T-14D546-AEB.cab 
Options = AutoInstall 
 
;;; 
;;; The following are the Target image files 
;;; 
[SYNCGen2_4.32.14122]
Item1 = EA5T-14D546-AFB
Open1 = SyncMyRide\EA5T-14D546-AFB.cab
Item2 = EA5T-14F657-AC
Open2 = SyncMyRide\EA5T-14F657-AC.zip
Item3 = EA5T-14F497-AC
Open3 = SyncMyRide\EA5T-14F497-AC.zip
Item4 = EA5T-14D546-BC
Open4 = SyncMyRide\EA5T-14D546-BC.zip
Item5 = EA5T-14D546-DC
Open5 = SyncMyRide\EA5T-14D546-DC.zip
Item6 = EA5T-14D546-AJB
Open6 = SyncMyRide\EA5T-14D546-AJB.cab
Item7 = EA5T-14D546-ATD
Open7 = SyncMyRide\EA5T-14D546-ATD.zip
Item8 = EA5T-14D546-AGB
Open8 = SyncMyRide\EA5T-14D546-AGB.cab
Item9 = BT4T-14D546-EE
Open9 = SyncMyRide\BT4T-14D546-EE.cab
Item10 = EA5T-14D546-LB
Open10 = SyncMyRide\EA5T-14D546-LB.cab
Options = AutoInstall 
 
;;; 
;;; The following tags are software versions NOT supported by this update 
;;; 
[SYNCGen2_4.21.10212]
[SYNCGen2_4.23.11069]
[SYNCGen2_4.23.11015]
[SYNCGen2_4.27.12047]
[SYNCGen2_4.27.12058]
[SYNCGen2_5] 
Item1 = BT4T-14D546-EE
Open1 = SyncMyRide\BT4T-14D546-EE.cab 
Item2 = EA5T-14D546-NB
Open2 = SyncMyRide\EA5T-14D546-NB.cab 
Options = AutoInstall


5) Start the vehicle, place the usb stick in the port like a normal upgrade, the system will reboot several times during the upgrade, and sometimes look stuck installing files. My system took ~25 minutes while showing file 2 of 9 after the initial image install.

Be patient and let the process complete, do not remove the USB stick during the install.

Please report back on this thread if the procedure was successful, or if you had any issues.
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





Keep in mind that version 3.7 was released for 2014+ models only.

Peter
 






Keep in mind that version 3.7 was released for 2014+ models only.

Peter

And 3.7.11 installed and worked fine on all 2011+ models, it was only released to 2014+ because the majority of the changes only related to 2014+ models... I can also downgrade from 3.8 to 3.7.11 to 3.6.2 if the user is really worried about that.
 












I am interested in the process.

Thanks

Ok, I will update again, and then test the process and write up instructions to post this weekend. This will require the original 3.7 update from Ford.
 






Thats interesting because the bug I saw in v3.8 was....

When I would have the iphone connected via Bluetooth, and be listening to Sirius, I would hold down the steering wheel button to activate SIRI but it would fail to start SIRI, and would start a Bluetooth audio session.

I was running iOS 9.2 Beta 3

Now I'M running iOS9.3 Beta 1 and it seems to be fixed, likely something on the iOS side not MFT side.

Are you running Beta iOS?
 






Are you running Beta iOS?

Nope, iPad and phone are stock 9.2, I have development devices that I run the betas on for testing, but my every days are stock.

On top of that downgrading MFT solved the issue and brought the expected behavior back, so I'm 100% positive it's a bug in MFT 3.8
 






So far 3.8 hasn't given me any issues but it hasn't solved my problem of getting my phone connected. :scratch:

Peter
 

Attachments

  • P1170368_001.JPG
    P1170368_001.JPG
    40.6 KB · Views: 693






Thats interesting because the bug I saw in v3.8 was....

When I would have the iphone connected via Bluetooth, and be listening to Sirius, I would hold down the steering wheel button to activate SIRI but it would fail to start SIRI, and would start a Bluetooth audio session.

I was running iOS 9.2 Beta 3

Now I'M running iOS9.3 Beta 1 and it seems to be fixed, likely something on the iOS side not MFT side.

Are you running Beta iOS?

I occasionally have the exact same problem, I assumed that it was when I was using navigation though as all 3 times it's happened to me is when I had route guidance active. Good to know I'm not crazy.
 






so far 3.8 hasn't given me any issues but it hasn't solved my problem of getting my phone connected. :scratch:

Peter

For some reason the smiley emoticons are not working on my cell so I'll just say it: I'm ROTFLMAO at that one, Peter! That's hysterical!
 






Thats interesting because the bug I saw in v3.8 was....

When I would have the iphone connected via Bluetooth, and be listening to Sirius, I would hold down the steering wheel button to activate SIRI but it would fail to start SIRI, and would start a Bluetooth audio session.

I was running iOS 9.2 Beta 3

Now I'M running iOS9.3 Beta 1 and it seems to be fixed, likely something on the iOS side not MFT side.

Are you running Beta iOS?

I downloaded 9.3 Beta 1 and still have the issue. I deleted both, reverse paired, rebooted iPhone and it only works once.
 






I've updated the original post with instructions for downgrading from 3.8 to 3.7.11 on US (north america) vehicles only. If you are unable to find the download file for 3.7.11 PM me and I can provide you with a modified installation zip that you can just copy to your USB and run.
 






I've updated the original post with instructions for downgrading from 3.8 to 3.7.11 on US (north america) vehicles only. If you are unable to find the download file for 3.7.11 PM me and I can provide you with a modified installation zip that you can just copy to your USB and run.

Downgrade successful. It worked without any problems.

Thanks!!! :salute:
 






Could i use this procedure to install a europen v3.8 over my us 3.8? (maybe with a downgrade previously)

Or had someone idea how i can get a german language installed?
 












Ok, the change to german language was canceled, for me is English enough :)

But i had one more question:

Is there a possibility to update the nav software (not maps with the SD-Card)?

I use the "EA5T-14F657-AD" on my mft but there is a update to "EA5T-14F657-AE".

I tried to modify my autoinstall.lst to (i used the autoinstall file from the "sync version test"):

Code:
;+++++++++++++++++++++++++++++++++++++++++++++++!
;          Microsoft Windows Automotive         !
;         USB Installation Directive File       !
;         3.7 (14122) Update from:              !
;         10308,10337,11038,11063,11081,11134   !
;         12023,12156,12285,13171,13319         !
;         Other versions not supported          !
;         autoinstall.lst (NA)                  !
;                                               !
;+++++++++++++++++++++++++++++++++++++++++++++++!
;;;
;;; The following tags are software versions supported by this update
;;;
[SYNCGen2_4.22.10308]
[SYNCGen2_4.22.10337]
[SYNCGen2_4.23.11038]
[SYNCGen2_4.23.11063]
[SYNCGen2_4.23.11081]
[SYNCGen2_4.23.11134]
[SYNCGen2_4.26.12023]
[SYNCGen2_4.28.12156]
[SYNCGen2_4.29.12285]
Item1 = BT4T-14D546-EE
Open1 = SyncMyRide\BT4T-14D546-EE.cab
Item2 = EA5T-14F657-AE
Open2 = SyncMyRide\EA5T-14F657-AE.zip
Options = AutoInstall
[SYNCGen2_3.08.15128]
[SYNCGen2_4.30.13171]
[SYNCGen2_4.31.13319]
Item1 = BT4T-14D546-EE
Open1 = SyncMyRide\BT4T-14D546-EE.cab
Item2 = EA5T-14F657-AE
Open2 = SyncMyRide\EA5T-14F657-AE.zip
Options = AutoInstall
;;;
;;; The following are the Target image files
;;;
[SYNCGen2_4.32.14122]
Item1 = EA5T-14F657-AE
Open1 = SyncMyRide\EA5T-14F657-AE.zip
Options = AutoInstall
;;;
;;; The following tags are software versions NOT supported by this update
;;;
[SYNCGen2_4.21.10212]
[SYNCGen2_4.23.11069]
[SYNCGen2_4.23.11015]
[SYNCGen2_4.27.12047]
[SYNCGen2_4.27.12058]
[SYNCGen2_5]
Item1 = BT4T-14D546-EE
Open1 = SyncMyRide\BT4T-14D546-EE.cab
Item2 = EA5T-14F657-AE
Open2 = SyncMyRide\EA5T-14F657-AE.zip
Options = AutoInstall

but after a few min of "installing" i get a error that say not enough space.....

maybe someone had a hint or a working solution :)
 






Ok, I will update again, and then test the process and write up instructions to post this weekend. This will require the original 3.7 update from Ford.
13Sport,
I have 3.6 downgrade package which seems to be little different from original one.
Is 3.7 downgrade package different from original 3.7 or it is just Autoinstall correction?
 






Ok, the change to german language was canceled, for me is English enough :)

But i had one more question:

Is there a possibility to update the nav software (not maps with the SD-Card)?
I could be wrong but I believe the software or most of it is all on the S/D card. If you remove that card, I doubt the Navigation will work. I haven't tried it though.

Peter
 






I could be wrong but I believe the software or most of it is all on the S/D card. If you remove that card, I doubt the Navigation will work. I haven't tried it though.

Peter
Peter,
I think it is opposite.
SD card contains maps data only, while whole navigation application software is stored in APIM.
Navigation application might bу updated separately from MFT itself, but right installation package is needed.
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





Peter,
I think it is opposite.
SD card contains maps data only, while whole navigation application software is stored in APIM.
Navigation application might bу updated separately from MFT itself, but right installation package is needed.
You could well be correct Denis. I haven't tried Nav without the card to see if it will actually come up. Come to think of it, that is likely why they said that Nav has to be added at the factory and why jmr061 has to replace the APIM to add Nav. Good point.

Peter
 






Back
Top