SYNC 3.4 Most recent version? | Page 3 | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

SYNC 3.4 Most recent version?

themishmosh

Well-Known Member
Joined
May 10, 2019
Messages
524
Reaction score
159
City, State
NE Ohio
Year, Model & Trim Level
2020 Explorer ST
anything new?

Seems pretty stable. I did have a blank carplay screen a couple of times. If I select a different menu from the bottom screen buttons, like audio, and then go back to carplay using the bottom screen button, the carplay screen is there like nothing happened. I also noticed a couple times that the GPS position when first starting the car is wrong for the first few minutes. This is after the car is parked out in the open on a clear day, so not sure what that's about. There isn't a "no GPS" symbol either. The position on the map is in the general vacinity but just wrong.
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





irvingpop

New Member
Joined
January 16, 2020
Messages
4
Reaction score
0
City, State
Portland, OR
Year, Model & Trim Level
2020 Explorer ST
I had my 2020 ST at the dealership yesterday for a tire repair, and asked them to check for software updates. Perhaps that was a mistake, because they upgraded me from 19200 to 19274 and now I can't use the cyanlabs tool :(

OTOH, maybe this is fine because my biggest complaint was unreliable Apple Carplay connections (forcing a restart multiple times per week) so if that's fixed I'll be thrilled.
 






MM07

Elite Explorer
Joined
January 13, 2019
Messages
759
Reaction score
189
City, State
MA
Year, Model & Trim Level
2018 Explorer Limited
Why would you need their tool?

You can upgrade to 20136 easily.
 






Ken St John

Active Member
Joined
July 16, 2019
Messages
56
Reaction score
30
Location
Tacoma, WA
City, State
WA
Year, Model & Trim Level
2020 Explorer ST
Yep. There's some new nav voice functionality when the 19Q1 map is paired up with the latest 20136 build as well, for those that use it.
Any idea when/if the newer build for Sync 3.4 will be "released" or available? Our ST is on 19274 and the owner site says that's the latest available. Last week I asked the dealer about an update, and they said there was none available. I did download and install the NA119 map update and all's well.

(BEGIN RANT: Frankly, when I was watching the F-150 announcement and Ford bragged about the OTA updates, I broke out laughing. This is something the legacy car companies are terrible at!! Tesla apparently pushes out all sorts of updates all the time ... but for the rest of the industry, it looks like you need to complain at least two or three times about issues before an "update" will solve a problem. Shouldn't be difficult to adapt the Windows Update style of technology so that on your routine oil change or service visit, the vehicle is plugged in and updated wherever it needs!!)

Cheers!!

Ken
 






peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
34,468
Reaction score
3,280
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
^^ Your post was moved to this more appropriate thread.

Peter
 






UofMEngineer

Well-Known Member
Joined
July 18, 2019
Messages
331
Reaction score
86
City, State
Michigan
Year, Model & Trim Level
20' Escape Hyb Titanium
Any idea when/if the newer build for Sync 3.4 will be "released" or available? Our ST is on 19274 and the owner site says that's the latest available. Last week I asked the dealer about an update, and they said there was none available.

OASIS MY20 related SSM shows "July", MY19 related SSM shows "early August". So, perhaps end of the month for your case, being a MY20.
 






Chicago ST

Member
Joined
June 28, 2019
Messages
30
Reaction score
31
Year, Model & Trim Level
2020 Explorer ST
I’m running Sync 3.4 19274 build and just noticed today that voice commands no longer work for navigation. I push the voice command button and speak a command but the visual voice menu just goes away. I updated the maps database a couple of days ago and wonder if that broke something? I did a master reset but that didn’t help. Has anyone else had this issue?
 






ArvadaMike

Elite Explorer
Joined
March 6, 2020
Messages
18
Reaction score
6
Location
USA
City, State
Arvada, CO
Year, Model & Trim Level
2020 Explorer ST
I’m running Sync 3.4 19274 build and just noticed today that voice commands no longer work for navigation. I push the voice command button and speak a command but the visual voice menu just goes away. I updated the maps database a couple of days ago and wonder if that broke something? I did a master reset but that didn’t help. Has anyone else had this issue?
Haven't seen that.
 






UofMEngineer

Well-Known Member
Joined
July 18, 2019
Messages
331
Reaction score
86
City, State
Michigan
Year, Model & Trim Level
20' Escape Hyb Titanium
FYI, it sounds like the latest v3.4 update should be available shortly. You can try checking in the next few days for the USB download from the owner site, or via a dealer update if you wanted to go that route. OTA isn't switched on just yet.
 






UofMEngineer

Well-Known Member
Joined
July 18, 2019
Messages
331
Reaction score
86
City, State
Michigan
Year, Model & Trim Level
20' Escape Hyb Titanium
Looks like it’s live for download now.
 






SMD2020ST

Member
Joined
January 23, 2020
Messages
11
Reaction score
1
City, State
Waldorf, MD
Year, Model & Trim Level
2020 Explorer ST
Looks like it’s live for download now.
I guess I'll be checking throughout the day, the Sync updates site is telling me my SYNC system (SYNC3.4.19101) is up to date.
 






UofMEngineer

Well-Known Member
Joined
July 18, 2019
Messages
331
Reaction score
86
City, State
Michigan
Year, Model & Trim Level
20' Escape Hyb Titanium
I guess I'll be checking throughout the day, the Sync updates site is telling me my SYNC system (SYNC3.4.19101) is up to date.

Yeah, it seems like it's popping for certain models so far still.
 






Dale5403

Well-Known Member
Joined
February 18, 2020
Messages
782
Reaction score
220
City, State
Mondovi, WI
Year, Model & Trim Level
2020 Explorer ST
Do you know what version the newest update from Ford should be? Mine is saying that mine is up to date with version 19274
 






Joe Stewart

Elite Explorer
Joined
October 10, 2018
Messages
258
Reaction score
98
Location
Austin, Texas
City, State
Austin, Texas
Year, Model & Trim Level
2017 Explorer Platinum
Mine says 20136
 












Ken St John

Active Member
Joined
July 16, 2019
Messages
56
Reaction score
30
Location
Tacoma, WA
City, State
WA
Year, Model & Trim Level
2020 Explorer ST
A new Sync 3.4.43 just showed up for our VIN on the Owner site. Not sure of the build number, but mine had been 19274 and this one is apparently an update ... report back as soon as I can get it installed, I will!!

Ken

UPDATE ... after a late night trip around town, my Sync is now listed as 20136. Took about 20 minutes, which also allowed me to verify that the auto high beams worked (we've not had a need to drive at night much). Everything seems OK, except that my Sirius is not working. I'm guessing it needs one of those "updating Sirius" things or maybe a second reboot. I'll see what happens in the morning! Cheers!
 






Dale5403

Well-Known Member
Joined
February 18, 2020
Messages
782
Reaction score
220
City, State
Mondovi, WI
Year, Model & Trim Level
2020 Explorer ST
It showed up for mine today. Confirmed the update on the Ford Owners site and if confirmed I'm now up to date.
 






peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
34,468
Reaction score
3,280
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
A new Sync 3.4.43 just showed up for our VIN on the Owner site. Not sure of the build number, but mine had been 19274 and this one is apparently an update ... report back as soon as I can get it installed, I will!!

Ken

UPDATE ... after a late night trip around town, my Sync is now listed as 20136. Took about 20 minutes, which also allowed me to verify that the auto high beams worked (we've not had a need to drive at night much). Everything seems OK, except that my Sirius is not working. I'm guessing it needs one of those "updating Sirius" things or maybe a second reboot. I'll see what happens in the morning! Cheers!
Updated and reported update today. Sync 3 Version 3.4 Build 20136. It took about 15 minutes to update in the vehicle.

Peter
 






UofMEngineer

Well-Known Member
Joined
July 18, 2019
Messages
331
Reaction score
86
City, State
Michigan
Year, Model & Trim Level
20' Escape Hyb Titanium
It showed up for mine today. Confirmed the update on the Ford Owners site and if confirmed I'm now up to date.

Updated and reported update today. Sync 3 Version 3.4 Build 20136. It took about 15 minutes to update in the vehicle.

Peter

Check your update packages for a 14G391-BL (Non-Nav) or -CL (Nav). There seems to be an issue right now with some MY20 updaters not being fed the file. If it's not there, let me know and I'll get you fixed up.
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





N3DD

Well-Known Member
Joined
August 18, 2019
Messages
128
Reaction score
14
Year, Model & Trim Level
2020 Explorer Limited
Check your update packages for a 14G391-BL (Non-Nav) or -CL (Nav). There seems to be an issue right now with some MY20 updaters not being fed the file. If it's not there, let me know and I'll get you fixed up.


They must be working on it as I get this message

Oops! Something went wrong on our end. A message has been sent to our support team, please try again later.
 






Top