Dismiss Notice



Register Today It's free! This box will disappear once registered!

Engine bogs down when A/C is on

Discussion in 'A/C & Heater systems - HVAC' started by cdburk, June 28, 2011.

  • Searches ExplorerForum.com
    1. cdburk

      cdburk New Member

      Joined:
      June 28, 2011
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Texas
      Year, Model & Trim Level:
      1994 Ranger XL
      I have a '94 Ranger XL 2.3L and just recently when the A/C compressor kicks on the battery gauge drops some and the engine really bogs down when idling almost to the point of dying. Then the compressor kicks off while the A/C is still on and the battery gauge goes back to its normal position. It seems to me that the compressor kicks off and on more than it should but my question is this. Does it sound like a compressor going bad and causing a drain on the alternator/battery?

      Any ideas would be greatly appreciated.
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



    3. extreme_exploder

      extreme_exploder New Member

      Joined:
      March 19, 2010
      Messages:
      17
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      OKC
      Year, Model & Trim Level:
      '91 Eddie Bauer 2-Dr
      Man, I have the same exact problem (91 Explorer). Can't quite figure it out. But it's definitely electrical. It still does the same thing when I completely unplug the A/C compressor.
       
    4. extreme_exploder

      extreme_exploder New Member

      Joined:
      March 19, 2010
      Messages:
      17
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      OKC
      Year, Model & Trim Level:
      '91 Eddie Bauer 2-Dr
      Figured it out a while ago if anyone's curious, I had a bad crimp on my positive battery cable. Caused lots of weird problems.
       

    Share This Page







    We Support Our Troops!