Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

*OFFICIAL* MFT - MyFord Touch v2 Software Bugs and Fixes Thread

Discussion in '2011-2016 My Ford Touch / In Vehicle Technology' started by baxterdown, March 7, 2012.

^^Searches ExplorerForum.com^^



Do Not Sell My Personal Information



  1. astrorex

    astrorex New Member

    Joined:
    February 8, 2011
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Seattle, WA
    Year, Model & Trim Level:
    '11 XLT
    I just got mine upgraded at the dealer (no usb stick for me, mine is one of the early models, so had to go visit the dealer) ... the system feels and works much better, baxterdown, you should really reconsider your option.

    I've started slow, but only connecting my phone now. It synced my phonebook much faster than before and I was able to use the voice commands soon after turning on the car... but yes, there are some things missing from the older version like the wallpaper, the temp guage etc.

    Overall, I'm satisfied ... next step, start connecting all those USB music sticks and iPod/Zunes ...
     
  2. Support EF

    Join the Elite Explorers for $20.

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. katiems

    katiems New Member

    Joined:
    September 22, 2011
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    CA
    Year, Model & Trim Level:
    2011 Explorer
    My new update I got last week at the dealer, worked ok for 2 days, then it started having problems. Its back at the dealer once again. I was listenning to Sirius according to the dashboard screen, but the sound said I was listening to AM (as well as the screen near the steering wheel).... apparently I could change stations AM/FM, but it still looked like I had the sirius station on. The car also defaults to FM radio regardless on what it was before you turn off the car.

    Im very annoyed but the IVT team seems actually interested in helping me.
     
  4. pwscott

    pwscott Elite Explorer

    Joined:
    October 29, 2011
    Messages:
    113
    Likes Received:
    0
    Trophy Points:
    16
    City, State:
    Windsor County, VT
    Year, Model & Trim Level:
    2016 Explorer Platinum
    Callsign:
    N3KDJ
    MFT Upgrade

    Mine seems a world better to me. I suffered through the other for 10,000 miles.

    Only things I see so far are:

    -When choosing "Shuffle, All" for my iPod, it will play random songs until it hits multiple versions of the same song, then it will play all of them, so it might play song 'xyz' ver. #1, the ver. #2,...but after you skip through that it will fall back to then playing the next songs in alphabetical order.

    -Also, while I was psyched to see my AM/FM and Sirius presets were maintained, I did lose all my favorite destinations and home in GPS

    -Finally, I have one of the photos I had loaded as my wallpaper and can't figure out how to change that- hopefully I am not stcuk with that one particular image forever???
     
  5. ercole

    ercole Member

    Joined:
    March 18, 2011
    Messages:
    77
    Likes Received:
    2
    Trophy Points:
    18
    City, State:
    Verona, NJ
    Year, Model & Trim Level:
    2011 Limited
    I was also one of those with an early build (Jan 2011), and Syncmyride stated I needed to go to my dealer. Seemed like everyone at Fette knew what was going on. Even the woman answering the phone was in the loop saying to bring it on in. Work order was 11A02 on the invoice. They ran out of SD cards, but ordered one for me to come by and get the next day, but fortunately, someone who had their truck updated a day earlier brought their extra SD card that they just got in the mail for someone else to use. He popped it in and we're set. He just asked if I get my card in the mail to do the same. I haven't received a thing and some forum members writing here that live by me state they received their mailing already, so I'm going to assume I'm not getting one.

    In addition to not showing the current radio song playing when in the 4 quadrant main screen (it simply shows the current station that's playing and the 6 presets with the word "Entertainment" listed in the lower left side), the "Climate" side only lists the current temperature set for the driver and passenger. In 2.11, the current vent setting was shown along with the fan speed bar. The only way to see that now is by going into the "Climate" screen itself. I found that feedback useful without having to go into the Climate screen.
     
  6. cnsheets

    cnsheets Active Member

    Joined:
    September 7, 2011
    Messages:
    949
    Likes Received:
    0
    Trophy Points:
    16
    Year, Model & Trim Level:
    2011 Explemoner
    well, bluetooth phone stopped working last night. The phone pairs, and calls ring through coming in or out, but when I answer, its dead air, I can not hear the other person and they can not hear me. I have to switch to privacy mode and use the phone up to my ear or the phones speakerphone function in order to talk. I tried turning the car off, opening the door and restarting and no go. Even this morning after sitting all night, same thing. Guess I'll try a fuse pull. This will be the second fuse pull with the new upgrade.
     
  7. harlenm

    harlenm Active Member

    Joined:
    July 24, 2011
    Messages:
    771
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Shelton, CT
    Year, Model & Trim Level:
    2013 Limited(lemon swap)
    unpair and repair before you do that.
     
  8. Sgt1411

    Sgt1411 Elite Explorer

    Joined:
    February 22, 2011
    Messages:
    4,273
    Likes Received:
    328
    Trophy Points:
    103
    City, State:
    VanBC/GoodyearAZ
    Year, Model & Trim Level:
    2017 Explorer SPORT
    Day 2 with the install, and Im having many of the issues here so I did a fuse pull.

    Then I had these;

    Did anyone notice if you turn on Breadcrumbs in the Navigation options and then drive to a location and return the same route, the Breadcrumbs are gone off the previously driven route?.....old version didn't do that. You could trace the Breadcrumbs back.

    Got in the vehicle turned it on and screen sat black for 6-8 seconds.

    When you go to the Navigation map does it draw the map in around 2-3 seconds?

    I used steering wheel voice button to control audio commands and everything froze, hung "Listening" for 60-120 seconds.

    Put the vehicle into park, reverse camera came on for 1-2 seconds.

    Im still confused why on this version they would NOT use the remote start power cycle to initiate the MFT software since it still needs boot up time.

    And where are all the extra cool new features we waited a year to see?
     
  9. cnsheets

    cnsheets Active Member

    Joined:
    September 7, 2011
    Messages:
    949
    Likes Received:
    0
    Trophy Points:
    16
    Year, Model & Trim Level:
    2011 Explemoner
    No go. Tried to unpair and pair, still nothing thought MFT for phone. Will try fuse pull tomorrow.
     
  10. rmp301

    rmp301 Active Member

    Joined:
    October 19, 2011
    Messages:
    313
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Yonkers, New York
    Year, Model & Trim Level:
    2012 Explorer XLT
    With the new update, nav screen is showing adjacent streets to the one I am on. Sometimes dosen't show any street. It will correct itself in time, but this is something new since the install. Heck, bad enough when I don't know where I am ........ Now the truck is just as confused! :eek:
     
  11. ModMiFord

    ModMiFord New Member

    Joined:
    October 16, 2011
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    2012 Explorer LTD 4WD
    I had a few quirks in the system after the upgrade. (Bluetooth music wouldn't work, backup camera would stay stuck on forever after reverse, my phone's name was too long and bled over the signal/batt strength icons, etc, etc)

    Did a master reset via the new MFT menu. Once it ran, I spent some time re-pairing the bluetooth audio and phone, re-doing all MFT vehicle settings, putting in the radio and nav favorites etc. fresh start....

    This fixed every single issue. I guss it's just like installing new software on your home PC, the MFT needs a full reboot after doing the upgrade.

    The system has been flawless now and I highly reccomend doing it....
     
  12. cnsheets

    cnsheets Active Member

    Joined:
    September 7, 2011
    Messages:
    949
    Likes Received:
    0
    Trophy Points:
    16
    Year, Model & Trim Level:
    2011 Explemoner

    After initial install i had quirks also, I did do a master reset as well as a fuse pull. Everything was good until day before yesterday when the phone started acting up. It pairs, calls ring through and I can dial out through MFT, but there is no audio, I cannot hear the other person and they can not hear me. I have to switch to privacy mode and use the phone normally. Tried to unpair and pair the phone, still does not work. Will try doing another fuse pull and another master reset.
     
  13. ModMiFord

    ModMiFord New Member

    Joined:
    October 16, 2011
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    2012 Explorer LTD 4WD
    Sheesh... Hope it works the second time and doesn't rear its's head again for ya. I really want to belive that our time in hell is over for good.... Good luck buddy!
     
  14. I would like to say my system is bug free and has been for a few days now. I don't really use alot of stuff on it. The navigation is working great as is my phone. No major problems at all. As a matter of fact, my 16 year old son said it is way faster. He noticed when I was using voice commands. Almost immediate response time.
     
  15. Gwkeeler

    Gwkeeler New Member

    Joined:
    July 22, 2011
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Virginia
    Year, Model & Trim Level:
    2011 Limited
    I've had the upgrade now for 2 weeks. The dealership did it as mine was a 2011 early build. I have had pretty much no problems. The system is much faster and more responsive. The only issue I have had is controlling my bluetooth audio from the steering wheel controls. I don't know if that's a MFT issue or an iPhone issue. All I know is if I turn my phone off and back on everything is fine.
     
  16. Gwkeeler

    Gwkeeler New Member

    Joined:
    July 22, 2011
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Virginia
    Year, Model & Trim Level:
    2011 Limited
    I've had none of these issues.
     
  17. Me either. I haven't had any of these. I wonder if it's the APIM thingy.
     
  18. drober30

    drober30 Active Member

    Joined:
    March 27, 2011
    Messages:
    594
    Likes Received:
    0
    Trophy Points:
    16
    City, State:
    Grand Blanc, MI
    Year, Model & Trim Level:
    2011 Limited 302A
    Bug

    When you press the voice button and try to "barge" in and say set as destination, it pauses the voice command instead of carrying out the command.
     
  19. Spengracin

    Spengracin Active Member

    Joined:
    July 14, 2011
    Messages:
    798
    Likes Received:
    2
    Trophy Points:
    0
    City, State:
    Fairfield, Ca
    Year, Model & Trim Level:
    2012 AWD Limited
    Tommorow mine gets done, several small items to fix at dealer
     
  20. FireRunt

    FireRunt New Member

    Joined:
    March 21, 2012
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Long Island
    Year, Model & Trim Level:
    2011 Ford Explorer XLT
    If the MFT Team is reading this board, can they answer our questions and concerns???

    Above all, why would you use only Ford Employees to beta test the system? I find it insulting to say the least. It took many months to do your beta testing and I find it very hard to believe that not one tester mentioned any of these issues. That's the insulting part in my eyes. How about having people from this board and other forums submit applications to beta test for you....I would think after having such negative feedback earlier this year and last year, you would want end users, who use it everyday for various functions, to do the testing for you. You chose internal people who probably have a company car, use it to go to work, don't bother to test the functions, and who most likely will not sit in front of it for hours like your loyal customers do.

    Ford, You should be ashamed of yourselves for having a closed mind on this.

    Think about it....not one beta tester mentioned that you can't see what's playing on the main screen if the bottom left quadrant??

    Did any of them try to input an address in the address book and notice that the space bar doesnt work?

    I'm sorry if I offended anyone, but this needed to be said....is anyone in agreement with me?
     
    Last edited: March 26, 2012
  21. Sgt1411

    Sgt1411 Elite Explorer

    Joined:
    February 22, 2011
    Messages:
    4,273
    Likes Received:
    328
    Trophy Points:
    103
    City, State:
    VanBC/GoodyearAZ
    Year, Model & Trim Level:
    2017 Explorer SPORT
    The other variable is the model year of the Ford employee's beta test vehicle. As employee's many get a new car every 6 months. So did all the beta testers use 2012/13 MY APIM's?

    I wonder how many 2011 APIM's were tested with the Upgrade because as you say some of these bugs are too blatant to have been missed.

    Or were they identified but a decision was made to get the release out ASAP and bug fixes would be reviewed later.

    I think many of us 11MY owners will now need new APIM's
     

Share This Page







We Support Our Troops!