Dismiss Notice



Register Today It's free! This box will disappear once registered!

problems with my 99 mounty

Discussion in 'Under the Hood' started by Mountaineer924, September 15, 2002.

^^Searches ExplorerForum.com^^
  1. Mountaineer924

    Mountaineer924 New Member

    Joined:
    July 14, 2002
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Plano, Tx
    Year, Model & Trim Level:
    1999 Mountaineer
    well last night i was coming up to a stop light and at idle my car would shake..it was weird and when rolling from about 1-6mph it was worse...couldn't feel it to much after 1st gear. anyway a little later my check engine light came on so i was like ah crap..i added a quart of oil(i was low) and that calmed the engine downa little but not by much and the CEL was off. then this morning it was on..im not to sure what it could be..fuel pump? injectors? spark plugs? im 16 and i need a car for school--any help would be appriciated!!!
    thanks,
    Kyle
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


  3. Robert

    Robert Well-Known Member

    Joined:
    October 26, 1999
    Messages:
    3,956
    Likes Received:
    1
    Trophy Points:
    48
    Location:
    CA
    City, State:
    Kelseyville, CA
    Year, Model & Trim Level:
    '13 Ram 1500 Longhorn
    Go to Autozone and have them rea the codes. Post the codes here and then follow the advice you get. Without the codes, there is nothing anyone can do.
     






We Support Our Troops!