• Register Today It's free! This box and some ads will disappear once registered!

ABS kicking in on dry pavement


ponkotsu

Active Member
Joined
October 29, 2012
Messages
620
Reaction score
5
City, State
Colorado Springs, CO
Year, Model & Trim Level
2005 Lincoln Aviator
This is an '05 Aviator. Today my ABS started kicking in under low brake force on dry pavement. It was pretty violent and erratic. Made it difficult to stop. Did it about 3 times and then stopped.

My first thought is a bad wheel speed sensor. This might correlate with another issue I have. Often when stopping at high speed I get significant steering wheel wobble. The front end is all brand new parts and properly aligned, so it's not suspension related. And I've measured the rotors and they are parallel well within spec. Tires are in decent shape and recently balanced.

Wheels don't appear to have any play in them like a bad bearing, but I've been fooled by that before where they feel tight only to find out they are fried.

If not the wheel speed sensor, I'm not sure what it could be other than a bad connection.

I found hubs super cheap on Amazon so I ordered them as insurance until I figure it out. Anyone think this diagnosis is correct?
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




Number4

"I'm counting to 3, then I'm getting your dad."
Elite Explorer
Joined
March 16, 2013
Messages
4,056
Reaction score
145
City, State
Woodstock, GA
Year, Model & Trim Level
04 Ford Explorer 4.6l
A bad hub could certainly be the issue. However, here is my suggestion. Part out your car. I'll take the front knuckles and the backup sensor assembly.
I know it can be hard to let go sometimes, but this simply works out best for me.
Before throwing parts at it though, might have the ABS system properly diagnosed.
 




Albino 94LTD

Recovering from Moab 2016
Elite Explorer
Joined
June 24, 2003
Messages
3,903
Reaction score
98
City, State
Newcastle Wa
Year, Model & Trim Level
White 94 Limited
Callsign
KG7PKQ
I experienced the same and it was a bad hub assembly.

The sensor tolerance is pretty tight so it doesn't take much play to get out of range.
 




ponkotsu

Active Member
Joined
October 29, 2012
Messages
620
Reaction score
5
City, State
Colorado Springs, CO
Year, Model & Trim Level
2005 Lincoln Aviator
I experienced the same and it was a bad hub assembly.

The sensor tolerance is pretty tight so it doesn't take much play to get out of range.
After doing some research I think this is a pretty common problem. I bet they are original just like everything else was on this truck, so are due for replacement.
 




ponkotsu

Active Member
Joined
October 29, 2012
Messages
620
Reaction score
5
City, State
Colorado Springs, CO
Year, Model & Trim Level
2005 Lincoln Aviator
A bad hub could certainly be the issue. However, here is my suggestion. Part out your car. I'll take the front knuckles and the backup sensor assembly.
I know it can be hard to let go sometimes, but this simply works out best for me.
Before throwing parts at it though, might have the ABS system properly diagnosed.
Absolutely brilliant idea. I'll throw away an $8k vehicle because a $100 part is worn out. Brilliant!
 




Number4

"I'm counting to 3, then I'm getting your dad."
Elite Explorer
Joined
March 16, 2013
Messages
4,056
Reaction score
145
City, State
Woodstock, GA
Year, Model & Trim Level
04 Ford Explorer 4.6l
Like I said, it would work out for me.
 




Albino 94LTD

Recovering from Moab 2016
Elite Explorer
Joined
June 24, 2003
Messages
3,903
Reaction score
98
City, State
Newcastle Wa
Year, Model & Trim Level
White 94 Limited
Callsign
KG7PKQ
After doing some research I think this is a pretty common problem. I bet they are original just like everything else was on this truck, so are due for replacement.
Do you by chance hear any grinding like grit against the rotor? That was my big indicator.
 




ponkotsu

Active Member
Joined
October 29, 2012
Messages
620
Reaction score
5
City, State
Colorado Springs, CO
Year, Model & Trim Level
2005 Lincoln Aviator
Do you by chance hear any grinding like grit against the rotor? That was my big indicator.
Nothing I hear when I'm driving, but when spinning the wheel a little by hand I can feel and hear it hitting hard on half the revolution. I got new OEM Motorcraft hubs on Amazon for $39each. with free shipping. I think it was a typo, because after I ordered the price went up to $149. So this is a no-brainer, the Aviator is getting new hubs this weekend.
 




ponkotsu

Active Member
Joined
October 29, 2012
Messages
620
Reaction score
5
City, State
Colorado Springs, CO
Year, Model & Trim Level
2005 Lincoln Aviator
This project snowballed a bit. Changed out both front hubs with new Motorcraft. I mentioned earlier that I got them super cheap. Seriously, I only baid $80 for the pair including shipping. They are Timken branded in Motorcraft box so I know I got the the good stuff. After changing the hubs out, I still had some vibration when braking. I never suspected the brakes because they were just redone right before I bought it last year. Freshly cut rotors and new pads. Well, I guess I should have checked. Brought the rotors in to get the resurfaced. The mechanic measured them and said they were .008" out of parallel. I checked for myself and they were terrible. He said he'd never seen such a bad job of cutting a rotor. So looks like whoever did the brake job did a total hack job. I bought from a used car lot so probably the did it. I'm guessing the bad rotor is what was causing the ABS issue and maybe damaged the hub. The hubs felt super tight so I kept them for spares. New rotors, pads and hubs, and the Aviator is smooth. Not much left to fix!
 




Top