Extra parts in clutch kit. Need it running for work Monday | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Extra parts in clutch kit. Need it running for work Monday

DryDog

Active Member
Joined
February 14, 2004
Messages
93
Reaction score
3
City, State
Woodbury, MN
Year, Model & Trim Level
'91 XL
I'm installing a Luk Pro Gold in my 91 X. Clutch is in but I am stumped at the slave. There are 2 parts in the kit I do not know what to do with. One is a small O-ring, I am thinking hydraulic line. The other is labled Release Bearing Retaining Ring. Where do these go?

I am past the hours for Luk's questions hotline. I know I will need all day tomorrow to put everything back together. Please help, Thanks
Matt
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





jimbo74

Elite Exploder
Joined
December 27, 2000
Messages
18,414
Reaction score
22
City, State
Nor*Cal
Year, Model & Trim Level
2001, F150, XLT 4x4
not sure about the oring or the otehr thing really, but when i did the clutch on my toyota, the throwout bearing wouldnt come out with me pulling on it... there was a c-clip like thing that held it into place, i beleive that is what this release bearing retaining ring probably is
 






DryDog

Active Member
Joined
February 14, 2004
Messages
93
Reaction score
3
City, State
Woodbury, MN
Year, Model & Trim Level
'91 XL
The retaining ring is sized to fit on the slave sleeve but, I don't see a goove on the bearing where it would hold it in place. It feels solidly stuck in place pushed on the way Haynes said to install it.
The slave is the reason I am in there in the 1st place. I would hate to put this ring in the wrong place and have to go back in.
 






RangerX

Elite Ranger
Staff member
Moderator
Elite Explorer
Joined
July 14, 1999
Messages
10,418
Reaction score
646
City, State
Omao, Kauai
Year, Model & Trim Level
'93 Ranger XLT 4X4
I put the same clutch in my Ranger the other month, and had the same questions. :D The small black O-ring goes in the hydraulic line at the disconnect. You should see one in there when you get it apart. Just replace old with new. The retaining ring slips over the the cylinder after you have the spring and the blue bearing on it. You have to gently force it to stretch on, as it's slightly smaller. There is a ridge or groove to hold it, I forget which.
Study the slave you take out, and you'll see how it all goes. ;)

Here's what came in my LUK kit. They sent two of the retaining springs. :confused:
 

Attachments

  • slave.jpg
    slave.jpg
    40.1 KB · Views: 203






DryDog

Active Member
Joined
February 14, 2004
Messages
93
Reaction score
3
City, State
Woodbury, MN
Year, Model & Trim Level
'91 XL
This is awesome!! Thanks so much!!!
 






RangerX

Elite Ranger
Staff member
Moderator
Elite Explorer
Joined
July 14, 1999
Messages
10,418
Reaction score
646
City, State
Omao, Kauai
Year, Model & Trim Level
'93 Ranger XLT 4X4
So, how'd it go?
 






DryDog

Active Member
Joined
February 14, 2004
Messages
93
Reaction score
3
City, State
Woodbury, MN
Year, Model & Trim Level
'91 XL
I had to borrow a friends car today...

The cone on my slave doesn't have a goove and is tapered at the end. When I release compression on the spring the ring would just shoot off. But the bearing is stuck on good. The slave I took off doesn't have a retaining ring. My Haynes shows just what I have. You have to twist the bearing/carrier to release some internal catch, then the bearing comes off.

I have e-mail in to Dan at Luk tech support. He said what you said but my slave doesn't look like yours and I don't thing that ring was supposed to come with my kit.

I am a newbie at X repair and too chicken sh1t to disregard that ring. So it took me 14 hours to decide to put the truck back together as it is. I should be running by Wed.
Matt
 






DryDog

Active Member
Joined
February 14, 2004
Messages
93
Reaction score
3
City, State
Woodbury, MN
Year, Model & Trim Level
'91 XL
I received a reply from Luk today. The repset I got (07-904) should not have had a retaining ring in it.
 






RangerX

Elite Ranger
Staff member
Moderator
Elite Explorer
Joined
July 14, 1999
Messages
10,418
Reaction score
646
City, State
Omao, Kauai
Year, Model & Trim Level
'93 Ranger XLT 4X4
Yeah, I've heard that there are some differences in the slave from year to year. Mine is the only one I've actually seen.
 






Top