Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

Nightmare Installing Aftermarket DRL's on 2015 Explorer Sport - PLEASE HELP!!!

Discussion in 'Performance Lighting' started by austinseanchris, December 1, 2016.

^^Searches ExplorerForum.com^^



Do Not Sell My Personal Information



  1. austinseanchris

    austinseanchris New Member

    Joined:
    December 1, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    City, State:
    Mt. Pleasant, NC
    Year, Model & Trim Level:
    2015 Explorer Sport
    Hello all,

    First time on the forum and hoping some fellow members can help me out with a dilemma I'm having. My father-in-law has a 2015 Explorer Sport thats fully loaded. He wanted aftermarket HID's to help him see better at night. He asked if I could install them for him as every car I own has the same kits in them. So. he ordered the kit for the headlight and foglights from DDM Tuning. Everything came in, everything went in without a hitch. He then told me he had ordered a set of daytime run lights(or DRL's) that he wanted installed as well. This is how the nightmare started...

    Where do I begin? Well, the lights were "universal 6-LED" drl's. I mounted them under the bumper and all looked great. Time to run the wires. Well, the sheet that was given to me for assembly was the following:
    [​IMG]

    I hook up everything as above and wired the white wire to the accessory source in the fuse panel under the hood. I turned the lights from the off position onto the On position. Tried it numerous times and everything worked good. Only hitch i noticed was if the car is running(and DRL's are on), if you open the door, they go out and park lamps come on. Closet he door and 10 secs later, DRL's come back on. Im guessing this has something to do with courtesy lights when you enter/exit the vehicle. I thought I had it right but its all over the place now. First it was the park lights that would come on. Now, just the fog lamps turn on and go out after 10 secs. And now, 3 nights after install, when you turn on all the lights(manually), now the DRL's come on as well. Its like it changes the way it wants to operate daily.

    Im yanking my hair out over here...is there a way for them to work correctly...like DRL's are suppose to? On if the ignition is on and headlights are off. Turn the headlights on and the DRL's go off. I dont know why its changing what it does now. Im at my witts end and I cant seem to find anything on the forum here...just numerous posts about people having issues with factory DRL's. Is there a simple solution or particular wire I need to tap in to? He plans to p/u his car this weekend so I want it to be right.

    Any help would be greatly appreciated! Thanks for the help!!!
     
  2. Support EF

    Join the Elite Explorers for $20.

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no advertisements, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. MrWickd

    MrWickd Elite Explorer

    Joined:
    January 20, 2017
    Messages:
    47
    Likes Received:
    26
    Trophy Points:
    18
    City, State:
    California
    Year, Model & Trim Level:
    2015 Explorer Sport
    Just wondering, how do the HID's look ? I have the same yr/model & I bought a set of Kensun HID's and the beam pattern was all over the place. I ended up putting LED's in but they aren't that bright.
     

Share This Page







We Support Our Troops!