Dismiss Notice



Register Today It's free! This box will disappear once registered!

one of thoes random accidents

Discussion in 'General Explorations!!' started by Audio_1, October 8, 2002.

  • Searches ExplorerForum.com
    1. Audio_1

      Audio_1 Active Member

      Joined:
      February 27, 2002
      Messages:
      284
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Toledo, OH
      Year, Model & Trim Level:
      97 XLT
      ok, so i go and drain the oil out of my x i take off the oil filter(not noticeing at the time, when i took it off the o-ring stuck to the place where you screw it on). put the new oil in, new filter on. i cstart the x up and the preassuse goes up and then the pressuse starts fluctuationg then goes away imeatily, so i hurried up and sut it off and i got out and i steaped in a large pool of oil. so im like wtf:confused: so i get under there(laying in the oil,fun) i take the filter off and im like wtf is going on. then i look beside me and there is a o-ring laying there, i look at the filter and the ring is on that. so i go look at the old filter and it was off of that one. so what happend was the old ring was stuck on there, and i thought the filter was on there good and snug, but actuly there was a big gap caused by this, there were 3-4 quarets of oil on the garage floor. and oil all over the engine bay of my x from the splatter. i cleaned it all up and now im reflecting on the incident
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. Alec

      Alec Elite Moderator Moderator Emeritus

      Joined:
      April 25, 2000
      Messages:
      15,997
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Houston, Texas
      Year, Model & Trim Level:
      2008 JK
      um, oops?
       
    4. 88vert

      88vert Explorer Addict

      Joined:
      August 24, 2001
      Messages:
      5,333
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      clinton,iowa
      Year, Model & Trim Level:
      94 unlimited
      good thing you pay close attention or it could have been alot worse:(
       
    5. jimbo74

      jimbo74 Elite Exploder Elite Explorer

      Joined:
      December 27, 2000
      Messages:
      18,450
      Media:
      9
      Albums:
      1
      Likes Received:
      4
      Trophy Points:
      58
      City, State:
      Nor*Cal
      Year, Model & Trim Level:
      2001, F150, XLT 4x4
      good thing you didnt do any engine damage.... or did you? that kind of mistake can cuase an engine failure :(.... hopefully all is well and you were able to catch it before it siezed up on you.... i bet you will check for that next time ;)
       
    6. zekex2

      zekex2 Active Member

      Joined:
      September 22, 2002
      Messages:
      158
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      CA
      Year, Model & Trim Level:
      98 XLT 5.0 L AWD
      Yea, I hate that. I have a SAAB sonnet. that i had just rebuilt the motor in (many Moons ago). I has a for V-4 in it. I had just put the thing together. It was beautiful and everthing was race ready. started it up. drained the oil, flushed the motor. got the good stuff out and start to fill it with oil again. I put in 5 qts. checked the dip stick. added some more checked again. Took a step and ended up on my A** in a puddle of expensive oil. Never in the 20+ years since then have ever not put a drain plug back in. Its funny now but not when I was on my butt on the floor. Slip Happens.
       
    7. espnfreak

      espnfreak Well-Known Member

      Joined:
      February 5, 2001
      Messages:
      3,797
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Elgin, IL
      Year, Model & Trim Level:
      '99 Maxima SE-L *5spd
      Whoa, i can identify with ya there, ive had a few whoops in my explorer. 1 my hood flying open on the road, and 2 was that i backed into a truck. 3. almost hit my house. I seem to reflect for long periods of time afterwards also
       
    8. '96explorereddiebauer

      '96explorereddiebauer Well-Known Member

      Joined:
      June 11, 2000
      Messages:
      3,757
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Clemmons, NC
      Year, Model & Trim Level:
      '06 Honda Accord EX-L
      I had that happen once. I guess I screwed in the filter wrong or something. I started the car and the oil gauge never rise to the normal level so I shut it off. After that, I got off the truck and smelled something bad so I was like "OH S***!!!" So I had to scoop up the oil and had to go get another 5 quarts of Mobil1 and a new filter. Got everything in correctly, started, and worked like normal since. I'm glad I didn't cause any engine damage.
       

    Share This Page







    We Support Our Troops!