1996 Explorer5.0 awd Won't start with key | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

1996 Explorer5.0 awd Won't start with key

Fred Ramburger

New Member
Joined
August 26, 2019
Messages
2
Reaction score
0
City, State
Philpot Ky
Year, Model & Trim Level
1996 Explorer Limited
Have a 1996 and 5.0 explorer and only clicks when trying to start it with the key. Replaced the starter solenoid and neutral saftey switch. Can't figure out. Please help!!
 






Mike65

Elite Explorer
Joined
December 31, 2013
Messages
4,234
Reaction score
481
Location
In my garage working on one of our vehicles.
City, State
Horsepasture, Virginia.
Year, Model & Trim Level
00 Ranger 4x4, 99 Sport.
Welcome Fred. First thing to check would be your battery connections, make sure they are clean & tight, then check to make sure the wire at the starter is not loose. You could also try if the above doesn't work, have a helper try to start the truck while you hit the body of the starter with a hammer several times.
 






Fred Ramburger

New Member
Joined
August 26, 2019
Messages
2
Reaction score
0
City, State
Philpot Ky
Year, Model & Trim Level
1996 Explorer Limited
Welcome Fred. First thing to check would be your battery connections, make sure they are clean & tight, then check to make sure the wire at the starter is not loose. You could also try if the above doesn't work, have a helper try to start the truck while you hit the body of the starter with a hammer several times.
Thanks I'll try that. It starts fine if I jump it across the solenoid.
 






Top