• Register Today It's free! This box and some ads will disappear once registered!

2017 Explorer sport cold air intake issue


Mlim_556

Member
Joined
January 23, 2017
Messages
50
Reaction score
5
City, State
Northern MA
Year, Model & Trim Level
2017 Ford Explorer Sport
I have a Windstorm cold air intake installed in my 2017 sport. It makes a weird popping noise when accelerating. It doesn't matter if it's full throttle or gradual acceleration. It happens low speed as well as highway speeds. Anyone experience this noise on an aftermarket intake?
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




Magnetic619

Elite Explorer
Joined
January 29, 2015
Messages
40
Reaction score
7
City, State
San Diego, CA
Year, Model & Trim Level
2017 Ford Explorer Sport
Is it a swoosh popping sound? From the BOV's?
 




Mlim_556

Member
Joined
January 23, 2017
Messages
50
Reaction score
5
City, State
Northern MA
Year, Model & Trim Level
2017 Ford Explorer Sport
I don't hear a swooshing noise, just popping. I doubt it's the bov because it'll do it when I am feathering the throttle, or increasing speed gradually
 




Magnetic619

Elite Explorer
Joined
January 29, 2015
Messages
40
Reaction score
7
City, State
San Diego, CA
Year, Model & Trim Level
2017 Ford Explorer Sport
Any check engine lights? Is the IAT sensor plugged in?
 




Mlim_556

Member
Joined
January 23, 2017
Messages
50
Reaction score
5
City, State
Northern MA
Year, Model & Trim Level
2017 Ford Explorer Sport
No check engine lights, and everything is plugged in
 




rhaviation

New Member
Joined
October 3, 2006
Messages
9
Reaction score
2
City, State
Huntsville, Alabama
Year, Model & Trim Level
2016 Explorer Sport Black
Callsign
Viper-6
I have also noticed this just recently. It’s almost like a slight thump or thud barely audible but also seem to feel it in the gas pedal. Have to have all audio off, ac off and easier to hear/feel when the windows are up since the boost and intake sound tends to over ride the new noise.
 




MagneticCharm

New Member
Joined
March 26, 2018
Messages
32
Reaction score
6
City, State
Cincinnati, OH
Year, Model & Trim Level
2015, Explorer AWD, XLT
I can't imagine what could be 'popping' in the Windstorm CAI unless you have something 'odd' inside of the tube or filter. Have you taken it back off to make certain there is no cardboard/plastic packing type material? If I had to guess the noise/thumping is coming from something else. Did you keep the factory intake? I would suggest swapping it back and seeing if the noise/thud goes away.
 




Mlim_556

Member
Joined
January 23, 2017
Messages
50
Reaction score
5
City, State
Northern MA
Year, Model & Trim Level
2017 Ford Explorer Sport
I have also noticed this just recently. It’s almost like a slight thump or thud barely audible but also seem to feel it in the gas pedal. Have to have all audio off, ac off and easier to hear/feel when the windows are up since the boost and intake sound tends to over ride the new noise.
you are dead on..I still haven't figured out what it is yet
 




Mlim_556

Member
Joined
January 23, 2017
Messages
50
Reaction score
5
City, State
Northern MA
Year, Model & Trim Level
2017 Ford Explorer Sport
I can't imagine what could be 'popping' in the Windstorm CAI unless you have something 'odd' inside of the tube or filter. Have you taken it back off to make certain there is no cardboard/plastic packing type material? If I had to guess the noise/thumping is coming from something else. Did you keep the factory intake? I would suggest swapping it back and seeing if the noise/thud goes away.
My factory system has been on, and it only does it with the CAI. It's nothing on my part, for some reason the CAI is causing this noise.
 




MagneticCharm

New Member
Joined
March 26, 2018
Messages
32
Reaction score
6
City, State
Cincinnati, OH
Year, Model & Trim Level
2015, Explorer AWD, XLT
Can you replicate it without driving it? Get a friend/significant other to rev it while you listen with the hood up. Hold the tube, place your hand on the filter box etc?
 




Mlim_556

Member
Joined
January 23, 2017
Messages
50
Reaction score
5
City, State
Northern MA
Year, Model & Trim Level
2017 Ford Explorer Sport
Can you replicate it without driving it? Get a friend/significant other to rev it while you listen with the hood up. Hold the tube, place your hand on the filter box etc?
The sound only happens when i'm driving
 




rhaviation

New Member
Joined
October 3, 2006
Messages
9
Reaction score
2
City, State
Huntsville, Alabama
Year, Model & Trim Level
2016 Explorer Sport Black
Callsign
Viper-6
Can you replicate it without driving it? Get a friend/significant other to rev it while you listen with the hood up. Hold the tube, place your hand on the filter box etc?

I too agree that I have only been able to replicate it while actually putting the vehicle under a load driving. I’m going to have to try putting my OEM filter back on also to check.
 




rhaviation

New Member
Joined
October 3, 2006
Messages
9
Reaction score
2
City, State
Huntsville, Alabama
Year, Model & Trim Level
2016 Explorer Sport Black
Callsign
Viper-6
My factory system has been on, and it only does it with the CAI. It's nothing on my part, for some reason the CAI is causing this noise.

Do you have any of the other Livernois kit installed or tune? I have the 93per tune, down pipes, 3 BAR MAP, thermostat, and Borla Cat Back and CAI so I’m concerne going back to my OEM filter while modded.
 




Mlim_556

Member
Joined
January 23, 2017
Messages
50
Reaction score
5
City, State
Northern MA
Year, Model & Trim Level
2017 Ford Explorer Sport
Do you have any of the other Livernois kit installed or tune? I have the 93per tune, down pipes, 3 BAR MAP, thermostat, and Borla Cat Back and CAI so I’m concerne going back to my OEM filter while modded.
I'm tuned with a 3 bar, and thermostat. Swapping out your intake won't do anything to your vehicle fyi, It's safe to use the factory or aftermarket intake
 




FlipSavage

New Member
Joined
February 18, 2018
Messages
11
Reaction score
1
City, State
Glendale, AZ
Year, Model & Trim Level
2017, Explorer Base 4wd
You might check the mounting of the aftermarket CAI. i have found on past vehicles that some do not mount solidly to allow "flex" when the engine moves causing a thud/thump sound that is not consistently replicated. This could also explain why you feel it when it happens.
 




rhaviation

New Member
Joined
October 3, 2006
Messages
9
Reaction score
2
City, State
Huntsville, Alabama
Year, Model & Trim Level
2016 Explorer Sport Black
Callsign
Viper-6
You might check the mounting of the aftermarket CAI. i have found on past vehicles that some do not mount solidly to allow "flex" when the engine moves causing a thud/thump sound that is not consistently replicated. This could also explain why you feel it when it happens.

I tried physically moving anything in the area even around the new CAI, to include lines etc that might be flexing or knocking together. Even so far as to zip tying lines that are movable. The only major discrepancy I can see is the front of the intake where air comes in sits higher it appears. This troubleshooting has actually got me puzzled.
 




FlipSavage

New Member
Joined
February 18, 2018
Messages
11
Reaction score
1
City, State
Glendale, AZ
Year, Model & Trim Level
2017, Explorer Base 4wd
if it sits higher in the front could it be getting interference from the hood when it is closed?


I tried physically moving anything in the area even around the new CAI, to include lines etc that might be flexing or knocking together. Even so far as to zip tying lines that are movable. The only major discrepancy I can see is the front of the intake where air comes in sits higher it appears. This troubleshooting has actually got me puzzled.
 




rhaviation

New Member
Joined
October 3, 2006
Messages
9
Reaction score
2
City, State
Huntsville, Alabama
Year, Model & Trim Level
2016 Explorer Sport Black
Callsign
Viper-6
if it sits higher in the front could it be getting interference from the hood when it is closed?

Highly doubting it. I tried a chalk/baby powder on the tall seal around the top of the air box and even it’s not showing any contact but the front lip in the grill area could be something hhhmmmm.
 




SJExplorer

Elite Explorer
Joined
June 4, 2013
Messages
57
Reaction score
2
City, State
Philly Burbs, PA
Year, Model & Trim Level
‘17 Sport
Is it a distinct "loud" pop? If it does it under load, when pulling your foot off of the gas quickly, it could be the throttle plate in the throttle body slamming shut. The lack of a resonator with the new intake is going to make any intake noise more pronounced. Someone mentioned blow off valves, but factory engines have diverter valves, not BOVs. (They both prevent compressor surge, but vent differently) They don't vent to the atmosphere. You could also be hearing the diverter valves actuating.
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




Chris Kauffman

New Member
Joined
May 21, 2018
Messages
3
Reaction score
0
City, State
Felton, Pa
Year, Model & Trim Level
2016 Ford Explorer Sport
Your not alone. I started hearing the pop noise at part throttle too when I installed the intake. Not loud, really only notice it if the radio is off. I put the stock setup back on and it goes away. So I’m sure it normal, just the windstorm makes it more noticeable.
 




Top