• Register Today It's free! This box and some ads will disappear once registered!

Another MFT/SYNC crash...

JohnnyDop

Well-Known Member
Joined
July 11, 2011
Messages
221
Reaction score
1
City, State
Long Island, NY
Year, Model & Trim Level
2012 Limited AWD
MFT Issues

May very well be that there is more than one bug causing problems, and that the bugs are triggered by a number of specific factors (ie. only when ambient lighting is on green, and have switched from phone to nav within the last 5 seconds - or something else as equally strange)

I'm looking to buy a new Explorer but it pains me to read all about these MFT issues. I used to own a Blackberry that used to freeze up, lag, and crash all the time and the only way to restart it was to pull the battery out, completely unacceptable. I now have an iPhone and it simply works. No crashes, no bugs, it works. Being somewhat tech savy my biggest fear would getting the new explorer and have to deal with blank screens and reboots.

Being that its already July i'm told if i put an order in it would be for a 2012.

In all honesty, do you think these issues will be recitfied in the 2012 model. How could they not? All the great reviews they've gotten so far will soon get squashed with user reviews that indicate otherwise. :(
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




jrmexplorer

Explorer Addict
Joined
April 19, 2011
Messages
1,109
Reaction score
1
Year, Model & Trim Level
2011 Limited
I'm looking to buy a new Explorer but it pains me to read all about these MFT issues. I used to own a Blackberry that used to freeze up, lag, and crash all the time and the only way to restart it was to pull the battery out, completely unacceptable. I now have an iPhone and it simply works. No crashes, no bugs, it works. Being somewhat tech savy my biggest fear would getting the new explorer and have to deal with blank screens and reboots.

Being that its already July i'm told if i put an order in it would be for a 2012.

In all honesty, do you think these issues will be recitfied in the 2012 model. How could they not? All the great reviews they've gotten so far will soon get squashed with user reviews that indicate otherwise. :(

For the record, I have had only minor issues and had to pull fuse 29 to reset the system exactly once in almost 3 months of driving. I like the MFT system and I like the explorer. Still, after 3 months, look forward to driving it home from work - almost the favorite part of my day (seeing my kids is #1).
 




JDJones

Active Member
Joined
March 26, 2011
Messages
92
Reaction score
0
City, State
Houston
Year, Model & Trim Level
2011 Silver Limited
Like JRM, I have had very minor slowness issues, have never pulled a fuse or removed the battery cable. With about 7K miles on it since April, I would compare initial quality to my Acura or Honda when they were new. Having driven it round trip to Florida on vacation and terrible stop and go commute in Houston, I look forward to driving the truck every chance I get.
 




ThumperBalm

New Member
Joined
July 12, 2011
Messages
3
Reaction score
0
City, State
Oceanside, California
Year, Model & Trim Level
2011 Explorer Limited 4WD
Just pick up my new 2011 Ford Explorer Limited 4WD and had the same problem. Black screen, no AC, no sensors, no radio, phone or Nav. They reset the system but not sure how many more times this might happen.
 




JIMBO2289

New Member
Joined
May 26, 2011
Messages
3
Reaction score
0
City, State
NEW JERSEY
Year, Model & Trim Level
11 X
Mft went black

Well after waiting 5 months to get my truck and having only 550 miles and jusyt got done working a 11 hr day. I couldn't wait to get in my x and drive home. Well i get in and guess what my MFT is black. Nothing working no NAV,PHONE,RADIO not even my back up camera. Can anyone help with this. TY
 




vfral1

Well-Known Member
Joined
February 8, 2011
Messages
260
Reaction score
0
City, State
Cumming, GA
Year, Model & Trim Level
'11 LTD Golden Bronze
Well after waiting 5 months to get my truck and having only 550 miles and jusyt got done working a 11 hr day. I couldn't wait to get in my x and drive home. Well i get in and guess what my MFT is black. Nothing working no NAV,PHONE,RADIO not even my back up camera. Can anyone help with this. TY

If it doesn't come back the next time you start up, the "official" recommendation is to pull and replace fuse 29. If that doesn't work, then you can disconnect and replace the negative battery cable. If neither of those are successful, you have to go to the dealer.
 




FordService

Official Ford Rep
Joined
October 25, 2010
Messages
5,281
Reaction score
12
City, State
Dearborn, MI
Year, Model & Trim Level
2014
...Good luck. Oh and if you need to, you can always Private Message Cory (Username: FordCustSrvc) - he works for Ford and monitors these forums and has the ability to escalate issues up the chain of command at Ford and has helped many Explorer owners on this site.

-J
Thanks for the great recommendations jrmexplorer! Our In-Vehicle Technology team will be posting here to help as well! They will assist with any issues including SYNC, MyFord Touch, and Navigation. I wanted to take a moment to pass the word along, so you can welcome them to the community!

Cory
 




Top