Battery light is on | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Battery light is on

bludmon

Member
Joined
January 5, 2009
Messages
45
Reaction score
0
City, State
Hartford,Wisconsin
Year, Model & Trim Level
1998 Ford Explorer
Hey guys I have a question about my 1993 Ford Explorer. MY BATTERY LIGHT IS ON BUT MY GUAGE IS READING NORMAL WHEN THE CAR IS RUNNING.I TOOK IT TO AUTOZONE AND THEY TESTED THE BATTERY AND ALTERNATOR AND EVERYTHING CHECKED OUT FINE. ANY iDEAS? COULD IT BE MY STARTER SOLENOID? tHANKYOU FOR ANY HELP YOU CAN GIVE ME IN THIS MATTER>
 
<



jmn822000

New Member
Joined
February 13, 2010
Messages
8
Reaction score
0
City, State
Mount Pleasant, South Carolina
Year, Model & Trim Level
1993 Eddie Bauer
fuse under the hood 15A for the alternator
 
<



catfisher81

Member
Joined
June 22, 2009
Messages
38
Reaction score
0
City, State
London, Kentucky
Year, Model & Trim Level
1989 Ford Ranger XLT
I had this same problem and i actually did a few weird things that some grease monkeys suggested and it fixed it..
first i removed the started and wire brushed around the rim and flat part were it mounts to the tranny and put a few extra grounds on it too. i had checked all the fuses and none were blown. but after i cleaned up the started were it mounted and put some extra grounds and replaced the terminals with brass ones. my light shows no more.
thanks
________________________________________________
1991 ford explorer xlt 4.0ltr. 4x4 5speed
 
<



Tshark299

Well-Known Member
Joined
October 29, 2004
Messages
118
Reaction score
0
City, State
Upstate NY
Year, Model & Trim Level
'93 XLT
I had a thread last summer about how mine came on after replacing my battery cables. Where the positive cable attaches to the starter solenoid I took it back apart again and cleaned the contact points of each wire that attaches to that terminal. My light briefly lit once after that but then stayed off.

Since then, late fall/early winter, the light started flickering on again, and now is just on steady any time the engine is running. Since I know my battery, alternator, and voltage gauge are all in good working condition I've mostly been ignoring it. Maybe if I have some free time when the weather is warm again I'll try cleaning up the wiring contacts again.
 
<



Top