• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

Code 0141 Oxygen Sensor


EMBPilot

New Member
Joined
November 29, 2006
Messages
43
Reaction score
0
City, State
Jersey Shore
Year, Model & Trim Level
2007 Ranger 4x4 XLT 4.0L
Hey guys, new to your forum, looks great from what ive been searching!

Im familiar with working on a hobby VW of mine but my Daily Driver is this 98 5.0L AWD Explorer and its a whole 'nother animal

Check engine light came on, hooked it up to a machine and got code 0141 O2 Sensor Heater Circuit Malfunction Bank 1 Sensor 2. im assuming i should be able to clear the code by R&R the O2 sensor and reset the OBDII.

so im under there looking at this sucker, PAX side, second sensor back behind the cat... then i gaze to see where the wire goes, HOLY *&&*! no way my hand can fit up there to plug the new one in! i read on another post that you can gain access by a panel under the center console but wasnt sure if that applied to my truck.

anyone have any guidance on the best way to go about replacement of this sensor and plugging it in?

Thanks for the help guys,
Kevin


1998 5.0L AWD Explorer XLT (all stock) 124,000mi
 

Join the Elite Explorers for $20. Gets rid of the ads!

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.



EMBPilot

New Member
Joined
November 29, 2006
Messages
43
Reaction score
0
City, State
Jersey Shore
Year, Model & Trim Level
2007 Ranger 4x4 XLT 4.0L
Follow Up

Hopefully this was a good code and a good repair, i guess i'll know in the next few hundred miles, so far, 20 miles later the lights been out. We'll see.

Replacing the Sensor was actually very easy, it took a total of about 5 min to pull the old one and stick the new one in...

now for the O2 PLUG!!! the person that designed the 02 plug harness for ford needs to be SHOT! i found it nearly impossible to reach up OVER the transmission unlock and unplug the 02 sensor plug. After searching the forums here i learned the truck has an access panel under the center console to get to the sensor plugs

my truck is an XLT, so i have the console, CD changer, and climate control on the rear of the center console making matters pretty stuffy getting the center console back.

once in the access panel, the plug was pretty straight forward.

what a PITA!





 


EMBPilot

New Member
Joined
November 29, 2006
Messages
43
Reaction score
0
City, State
Jersey Shore
Year, Model & Trim Level
2007 Ranger 4x4 XLT 4.0L
Just another follow up. Check engine light has been out for 300+ miles, and although they say this sensor doesn't effect fuel economy there has been an increase in my MPG!

good luck to anyone who uses this thread :)
 


rizzjc

Scubajoe - Radio Mod
Staff member
Moderator
Elite Explorer
Joined
July 13, 2005
Messages
3,679
Reaction score
11
Location
NC
City, State
Garner, NC
Year, Model & Trim Level
2019 F150
Callsign
N1LVN
I'm about to dig into this right now, and just found your post in a search. Thanks for the pics. I was heading for the access panel first thing (once you've taken the console out once or twice, it becomes pretty easy). I have a radio to install too, so I can kill two birds with one stone.

However, my question is about the O2 sensor. I guess I'm about to figure it out, but since I don't have the special "slotted" socket for this, I am hoping that a box-end wrech will fit. Can you tell me what you used? If I'm cursing the thing by the end of the day then I might need the "5-minute" trick.
 


ExplorerDMB

Moderator/Technician
Moderator Emeritus
Joined
January 26, 2004
Messages
6,201
Reaction score
6
City, State
Mechanicsville, Virginia
Year, Model & Trim Level
2004 Acura TL
7/8s is the usualy size of an 02 sensor - the have sockets you can buy that'll fit on them well or you can buy stubby 7/8s wrenchs, use a line wrench, or yeah boxed end or open - just use whatever to get it out. Let the car run for a bit to get the exhaust hot, then cut it off and spray some rust buster in there and then let it sit til its ok to touch and then try to get it out. 02s usually come out ok, but can be a pain sometimes. Use anti-seeze when putting it back!!!

-Drew
 


rizzjc

Scubajoe - Radio Mod
Staff member
Moderator
Elite Explorer
Joined
July 13, 2005
Messages
3,679
Reaction score
11
Location
NC
City, State
Garner, NC
Year, Model & Trim Level
2019 F150
Callsign
N1LVN
Thanks for the tips. Off to pull the console. Hoping they come out pretty easy, since rust is not much of a problem down here. I'll post back with the good or bad news.
 


rizzjc

Scubajoe - Radio Mod
Staff member
Moderator
Elite Explorer
Joined
July 13, 2005
Messages
3,679
Reaction score
11
Location
NC
City, State
Garner, NC
Year, Model & Trim Level
2019 F150
Callsign
N1LVN
Well, I don't have any 7/8" wrenches, just and adjustable, which won't fit. So, off the the auto parts store to pick up the special socket with the slot, rather than mess around with other stuff. About $11, and hopefully it'll make easy work of it.
 


EMBPilot

New Member
Joined
November 29, 2006
Messages
43
Reaction score
0
City, State
Jersey Shore
Year, Model & Trim Level
2007 Ranger 4x4 XLT 4.0L
i used a regular box wrench and was able to reach it just by rolling under the car as it was lifted. You can start the car to warm it up but i would NOT. your hands are going to be all over the exhaust pipes cause its tight, so why make matters worse and burn yourself!?

i did mine completely cold, truck had 125 K, it came right out with very little force i was pleasantly surprised.

Good luck! let us know how you make out.
 


rizzjc

Scubajoe - Radio Mod
Staff member
Moderator
Elite Explorer
Joined
July 13, 2005
Messages
3,679
Reaction score
11
Location
NC
City, State
Garner, NC
Year, Model & Trim Level
2019 F150
Callsign
N1LVN
I got it done. Ended up getting the special socket, since I didn't have a 7/8" open-end. Got both from the top. After the "CRACK!" they came right out by hand. Here are some photos.

Carpet peeled back, showing the access panel in the floor. After doing this once, I just cut the carpet under the console. Made life easier:


Panel removed:


Blue connectors are for the secondary O2 sensors, green is for the passenger side primary which is located here.


Here are the two sensors I am replacing. Left side is the passenger (Bank 1 Sensor 2), right side is the driver.


After removing:


One back in:


The tool:


A tight fit:


Everything buttoned up, and antenna wire ran:


Only cursing I did was trying to break it out. Not bad at all after that. Monday trip to work should verify the problem is solved. One thing I noticed. Car sat all night, and I just started it this morning to pull it into the garage. Pulled the Bank1 Sensor 2, and didn't notice anything out of the ordinary, but when I pulled the other secondary sensor, it was wet. I pulled the primary on that side and it too was wet, as was inside the pipe. I was worried it coulda been coolant, but couldn't get a good smell of it. The other side was dry.
 


1998rollover

Active Member
Joined
November 10, 2008
Messages
223
Reaction score
4
City, State
Weiser, ID
Year, Model & Trim Level
1998 Mountaineer
The posts with the sensor connector pictures need to be combined into one sticky post, with a title of "O2 HO2S Oxygen Sensor Connector Colors". Then Google and Yahoo searches might find it.
 


Thread starter Similar threads Forum Replies Date
M P0402 code. EEC V 1
R 2008 Explorer P0456 Code EEC V 0
V P0351 error code solution explorer EEC V 0
J OBD2 code scanner EEC V 0
R 2002 Ford Explorer XLS. Code P0303. EEC V 3
T 1997 Ranger XLT. Code P1131. EEC V 1
C 2001 Explorer. P1409 code. EEC V 3
S Code P0171. EEC V 6
W 2005 Explorer. Error code. EEC V 1
E Diagnostic code P0506. Idle air control system RPM. EEC V 2
W 1996 Explorer 4.0L with an air bag code 52. EEC V 10
B Code P1401. EEC V 3
J Code P0756. EEC V 2
R 2003 Ford Ranger 16V 2.3L. P2004 error code. EEC V 8
0 Help! Code P0303. EEC V 6
A 2008 Explorer 4.0L with a code P0191. EEC V 2
J Code P0128. EEC V 2
R Camshaft position sensor code P0340. EEC V 5
F 97 Explorer 5.0 V8, getting p0443 code EEC V 0
T Code P1747. EEC V 2
4 MPG recently dropped- EGR code. EEC V 9
A Code P1715. EEC V 29
F Sport Trac with a P0174 code. EEC V 5
J Rough idle with a P0179 code. EEC V 4
J Help with code number P0304. EEC V 3
K P0304 error code on a 98 Ford Explorer 4.0L OHV. EEC V 5
1 Code P0506. EEC V 8
F Error code 648. EEC V 1
R 96 Ranger with a transmission code P0761. EEC V 2
J Rough idle with a P1506 code. EEC V 3
D DTC code P0354. EEC V 3
K P1780 code. EEC V 1
SB98UKexplorer engine light on but no code? EEC V 3
S P1401 code. EEC V 3
S 1996 Ford Ranger with a P0500 code. EEC V 7
J Air bag code number 32. EEC V 1
E P0506 code on a 2004 Explorer. EEC V 2
R My 96 Explorer has a P0402 code. EEC V 1
I 2003 Explorer with a P0745 code. EEC V 3
M 2001 FORD RANGER po442 CODE EEC V 0
J Code P0153. EEC V 2
B Code P0430. EEC V 1
W Code P0735 on a 2000 Explorer. EEC V 3
D Error code P1309. EEC V 3
E 2003 Explorer with a code P0430. EEC V 2
T PO446 Code on 2007 EB Explorer V8 EEC V 2
E Code P0141 on a 1997 Explorer with a V8. EEC V 4
W Airbag Code 45. EEC V 1
M need help, error code P0155, smog test coming up EEC V 1
D '03 Explorer Limited V8. Code P0300 rough idle. EEC V 28
Similar threads


















































Top