• Register Today It's free! This box and some ads will disappear once registered!

Door ajar light stays on and alarm won't go off...


MintyFresh

New Member
Joined
December 6, 2015
Messages
37
Reaction score
0
Year, Model & Trim Level
2002 XLT Explorer
door ajar light stuck on along with interior lights.

Thoughts?
 
Last edited:


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.








MintyFresh

New Member
Joined
December 6, 2015
Messages
37
Reaction score
0
Year, Model & Trim Level
2002 XLT Explorer
Did that, no luck.

Edit: the door alarm doesn't go off on the front left door so I pin pointed it to that door.

Took door latch off and everything looks ok. Maybe the electrical inside the door latch is bad?
 












TechGuru

Well-Known Member
Joined
August 23, 2015
Messages
2,005
Reaction score
249
Location
Texas
Year, Model & Trim Level
2003 XLS 4X4 4.0L FLEX




LMHmedchem

Active Member
Joined
October 28, 2011
Messages
270
Reaction score
1
Year, Model & Trim Level
2002 Explorer XLT v8
This can also be a broken wire in in the door boot. I can't say which is more trouble to check. I guess the boot can be checked and ruled out without buying any replacement parts.

Here is a great thread by synyster for checking for broken wires, link courtesy of BigRondo,
http://www.explorerforum.com/forums/showthread.php?t=270081

and for removing the door panel, from the same source,
http://www.explorerforum.com/forums/showthread.php?t=303524

If it does end up being the switch, this is a thread from borland, also courtesy of BigRondo.
http://www.explorerforum.com/forums/showthread.php?t=249253

You do have to use allot of WD40 on the door latches, so if you only used a little, it is worth trying again.

LMHmedchem
 




TechGuru

Well-Known Member
Joined
August 23, 2015
Messages
2,005
Reaction score
249
Location
Texas
Year, Model & Trim Level
2003 XLS 4X4 4.0L FLEX
You do have to use allot of WD40 on the door latches, so if you only used a little, it is worth trying again.

LMHmedchem
+10 :thumbsup:

Spray like you're trying to wash it, not oil it, then open/close the door many times.
 




MintyFresh

New Member
Joined
December 6, 2015
Messages
37
Reaction score
0
Year, Model & Trim Level
2002 XLT Explorer
Thanks guys, I sprayed 2 different kinds of lubes over the past 3 days and still doesn't work. Just going to buy a new switch and hopefully that does the trick!
 




Top