Livernois Motorsports and Engineering Announces New & Improved Custom Tuning | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Livernois Motorsports and Engineering Announces New & Improved Custom Tuning

Livernois

EF Vendor
Joined
July 16, 2013
Messages
726
Reaction score
57
City, State
Dearborn Heights, MI
Year, Model & Trim Level
2013 Explorer Sport
Guys,

We have some great news for those of you with our Mycal tuning device for the 2013+ Explorer Sport and 2013+ SHO models. We have just released a new tune revision that has some very noticeable improvements in engine performance, transmission performance, and overall drivability characteristics. These new tune files have gained upwards of 10hp over our previous tunes here on our dyno. We have also eliminated the need for a special cold weather (CW) tune, and improved upon the "no shift" condition present on these cars on the 1-2 shift. This 1-2 shift issue has even been present on completely stock vehicles that we have encountered, so this is a big improvement in that area.

For updated tune file requests or to place your new orders please email or PM your requests including Full name, current modifications, and serial number of your tuner info@livernoismotorsports.com Click here to visit our website
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





bigmoose15

Well-Known Member
Joined
January 15, 2013
Messages
138
Reaction score
1
City, State
Cambridge, MA
Year, Model & Trim Level
2013 ExSport
Great news. I sent an email to Anthony about an update for my SN. I'm interested to see how much the shifting is improved. I'm not sure if its different but i found it annoying when in Manual Mode I launch in 1st, then at about 6k I'd hit the paddle for 2nd and it would skip to 3rd.
 






jays05

Member
Joined
July 9, 2013
Messages
32
Reaction score
3
Year, Model & Trim Level
2013 Explorer Sport
I emailed last night, got the tuner updated this afternoon, and flashed the new tune. I'll give some feedback tomorrow after I drive it for a while.
 






jays05

Member
Joined
July 9, 2013
Messages
32
Reaction score
3
Year, Model & Trim Level
2013 Explorer Sport
1st gear doesn't seem as violent as in the v2 tune, but there is definitely more tq steer in 2nd gear. I'll refrain from commenting on the transmission until it has a few more days to learn.
 






13Sport

Explorer Addict
Joined
June 29, 2012
Messages
1,118
Reaction score
11
City, State
Los Angeles, CA
Year, Model & Trim Level
2015 Explorer Sport
Great news. I sent an email to Anthony about an update for my SN. I'm interested to see how much the shifting is improved. I'm not sure if its different but i found it annoying when in Manual Mode I launch in 1st, then at about 6k I'd hit the paddle for 2nd and it would skip to 3rd.

This is because manual mode on the Sport isn't really a manual mode. It is shifting to 2nd because your revs got too high, then hitting the paddle is causing the upshift to 3rd. I, like you, tend to shift at the exact time the computer decides it's necessary. This was my first complaint when I first got my sport and wrote a small review way back when.
 






bigmoose15

Well-Known Member
Joined
January 15, 2013
Messages
138
Reaction score
1
City, State
Cambridge, MA
Year, Model & Trim Level
2013 ExSport
This is because manual mode on the Sport isn't really a manual mode. It is shifting to 2nd because your revs got too high, then hitting the paddle is causing the upshift to 3rd. I, like you, tend to shift at the exact time the computer decides it's necessary. This was my first complaint when I first got my sport and wrote a small review way back when.

I had suspected this was the issue. If that's the case then I don't even need to upshift in that situation if it does it for me at 6k.
 






13Sport

Explorer Addict
Joined
June 29, 2012
Messages
1,118
Reaction score
11
City, State
Los Angeles, CA
Year, Model & Trim Level
2015 Explorer Sport
I had suspected this was the issue. If that's the case then I don't even need to upshift in that situation if it does it for me at 6k.

Yeah.. the only usefulness the paddles have are downshifting... for max performance just leave it in D ... you can downshift using the paddles while you are in D. The only time I use M is in the mountains to keep the transmission from gear searching.
 






Livernois

EF Vendor
Joined
July 16, 2013
Messages
726
Reaction score
57
City, State
Dearborn Heights, MI
Year, Model & Trim Level
2013 Explorer Sport
Guys,

Just wanted to keep everyone informed. The tune updates have been pouring in and we are doing are best to get everyone updated as soon as possible. We have received hundreds of tune requests over the past few days and so far the feedback has been great. We appreciate your patience and hope everyone has a great weekend!

LMS
 






ibmike

Member
Joined
February 25, 2014
Messages
48
Reaction score
14
City, State
Mi
Year, Model & Trim Level
2014 explorer sport
I dont have much time on this new tune, But my preliminary opinion is thats its better in every way!
 






vteckiller2000

Well-Known Member
Joined
March 4, 2013
Messages
205
Reaction score
0
City, State
Iowa City
Year, Model & Trim Level
2013 Explorer Sport
It seems as if the boost has been grossly limited in the lower and mid range rpms. Is this true Livernois?
 






vteckiller2000

Well-Known Member
Joined
March 4, 2013
Messages
205
Reaction score
0
City, State
Iowa City
Year, Model & Trim Level
2013 Explorer Sport
Just went out and logged.

Boost is way lower, and my truck is marginally slower to 60 and much slower to the 1/4 mile.

I used to have 12-13 psi boost in the midrange holding around 13 up top. Now I have 8-9 in the midrange tapering to 7 at the top end.

Timing looks to be higher though. Was about 16-19* before and is in the low-mid 20's now.

Third gear and above now feels very slow.
 






TouchOfEvil

Active Member
Joined
August 28, 2013
Messages
85
Reaction score
0
Year, Model & Trim Level
2014 Explorer Sport
Just went out and logged.

Boost is way lower, and my truck is marginally slower to 60 and much slower to the 1/4 mile.

I used to have 10-12 psi boost in the midrange and up to 14 in the top end. Now I have 8-9 in the midrange and 10-11 at the top end. Peak boost used to be ~16 psi and is now 13 psi.

Timing looks to be higher though. Was about 16-19* before and is in the low-mid 20's now.

Do you log absolute throttle position? I'm curious if they give you full throttle with the new tune vs the cold winter tune that is dialed back throughout most of the rpm band.
 






vteckiller2000

Well-Known Member
Joined
March 4, 2013
Messages
205
Reaction score
0
City, State
Iowa City
Year, Model & Trim Level
2013 Explorer Sport
Do you log absolute throttle position? I'm curious if they give you full throttle with the new tune vs the cold winter tune that is dialed back throughout most of the rpm band.

I wasn't logging throttle position this time, but when I am at WOT my data has always maxed out at 75% open unless the computer was pulling throttle when the fuel pressure tanked.
 






TouchOfEvil

Active Member
Joined
August 28, 2013
Messages
85
Reaction score
0
Year, Model & Trim Level
2014 Explorer Sport
I wasn't logging throttle position this time, but when I am at WOT my data has always maxed out at 75% open unless the computer was pulling throttle when the fuel pressure tanked.

I believe WOT for me was around 86% but with the CW tune i might hit that for half a second at the very top of the gear. It's around 45-65 for most of the rpm band now.
 






Carnivore

Well-Known Member
Joined
January 30, 2011
Messages
184
Reaction score
2
City, State
Virginia
Year, Model & Trim Level
2013 sport
Just went out and logged.

Boost is way lower, and my truck is marginally slower to 60 and much slower to the 1/4 mile.

I used to have 10-12 psi boost in the midrange and up to 14 in the top end. Now I have 8-9 in the midrange and 10-11 at the top end. Peak boost used to be ~16 psi and is now 13 psi.

Timing looks to be higher though. Was about 16-19* before and is in the low-mid 20's now.

uhhhhhhhhhh so if this is true, why are we upgrading?
 






broken strut

Well-Known Member
Joined
June 9, 2012
Messages
733
Reaction score
4
City, State
CHIMOMAN VILLE
Year, Model & Trim Level
2013 White Sport
What's marginally slower? Are you using a smart phone app again? Those are junk for getting proper readings. Much slower? 1 second? 2 seconds? Were you on the race track or a back road? Full tank? 1/4 tank? Was it a head wind or a tail wind? LOL
 






vteckiller2000

Well-Known Member
Joined
March 4, 2013
Messages
205
Reaction score
0
City, State
Iowa City
Year, Model & Trim Level
2013 Explorer Sport
What's marginally slower? Are you using a smart phone app again? Those are junk for getting proper readings. Much slower? 1 second? 2 seconds? Were you on the race track or a back road? Full tank? 1/4 tank? Was it a head wind or a tail wind? LOL

Dedicated GPS performance logging device, not smart phone.

0-60 was 4.6 seconds before and is now 4.8 sec.

Quarter mile is about .5 seconds slower now.




Also, I updated the above post to more accurately reflect what I am seeing.
 






TouchOfEvil

Active Member
Joined
August 28, 2013
Messages
85
Reaction score
0
Year, Model & Trim Level
2014 Explorer Sport
Just went out and logged.

Boost is way lower, and my truck is marginally slower to 60 and much slower to the 1/4 mile.

I used to have 12-13 psi boost in the midrange holding around 13 up top. Now I have 8-9 in the midrange tapering to 7 at the top end.

Timing looks to be higher though. Was about 16-19* before and is in the low-mid 20's now.

Third gear and above now feels very slow.

Not sure if you ever bothered to log the stock tune? I have and it's a 8 psi boost that inches up to 10-11 at midrange rpm before tapering back to 8 psi for the shift with timing in the low to mid 20's.

Just spit balling but maybe you loaded a stock or got a mislabled tune from them.
 






vteckiller2000

Well-Known Member
Joined
March 4, 2013
Messages
205
Reaction score
0
City, State
Iowa City
Year, Model & Trim Level
2013 Explorer Sport
Not sure if you ever bothered to log the stock tune? I have and it's a 8 psi boost that inches up to 10-11 at midrange rpm before tapering back to 8 psi for the shift with timing in the low to mid 20's.

Just spit balling but maybe you loaded a stock or got a mislabled tune from them.

It would be pretty weird if I did and it still runs seeing as I have a 3 bar MAP on the car as well.
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





TouchOfEvil

Active Member
Joined
August 28, 2013
Messages
85
Reaction score
0
Year, Model & Trim Level
2014 Explorer Sport
It would be pretty weird if I did and it still runs seeing as I have a 3 bar MAP on the car as well.

Guess that answers that then. I don't have the new tune so i can't be of any help on that i guess.
 






Top