1. Register Today It's free! This box and some ads will disappear once registered!

    Dismiss Notice

2007 Heat A/C issues

Discussion in 'Stock 2006 -2010 Explorers' started by rudymags, September 28, 2014.

^^Searches ExplorerForum.com^^



Do Not Sell My Personal Information


  1. rudymags

    rudymags New Member

    Joined:
    September 28, 2014
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Lubbock,TX
    Year, Model & Trim Level:
    2007 Explorer
    I do have a tech question. I just finished putting in a new heater/ac actuator in my 2007 Explorer. It was making that thumping sound when I tried to get heat from the unit. Now my a/c is blowing hot air. The actuator I replaced was located on the driver side, just behind & below the console panel. It stopped the thumping & I got hot air in the bottom after that.
    Today I turned on the a/c and all I get is hot air blowing out the top vents & no hot air from the bottom, when I switch to heat. What do I need to look for to try to fix?

    addendum: I just finished taking pff the new actuator and now have cold air from the a/c. Can you tell me something to help me figure this out? I turn the knob to heat, and I do get air from the bottom, but seems that it is not hot air.
    :help::help:
     
    Last edited: September 28, 2014
  2. Support EF

    Join the Elite Explorers for $20.

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no advertisements, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



Share This Page







We Support Our Troops!