Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

No Heat Passenger Side

Discussion in 'Stock 2006 -2010 Explorers' started by pzy3339, November 24, 2016.

^^Searches ExplorerForum.com^^





  1. pzy3339

    pzy3339 Active Member

    Joined:
    November 29, 2012
    Messages:
    244
    Likes Received:
    1
    Trophy Points:
    18
    City, State:
    columbus ohio
    Year, Model & Trim Level:
    2006, 4x4 Limited 4.6
    HVAC issue here.

    Can someone describe how this system operates for me please.

    I have dual zone climate control, the passenger side does not get any heat.

    Do I need to look for a coolant flow regulator, or a blend door actuator? What could prevent the passenger zone from getting heat?

    I am assuming there is 1 heat exchanger and two blend doors with individual actuators.

    Thanks
     
  2. Support EF

    Elite Explorer 2 for 1 Sale! $20 for 2 years!

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. Rcflyer330

    Rcflyer330 Active Member

    Joined:
    March 23, 2014
    Messages:
    530
    Likes Received:
    24
    Trophy Points:
    28
    City, State:
    Michigan
    Year, Model & Trim Level:
    2010 Ford Explorer XLT V6
    Blend door most likely.
     
  4. pzy3339

    pzy3339 Active Member

    Joined:
    November 29, 2012
    Messages:
    244
    Likes Received:
    1
    Trophy Points:
    18
    City, State:
    columbus ohio
    Year, Model & Trim Level:
    2006, 4x4 Limited 4.6
  5. dantheman68

    dantheman68 New Member

    Joined:
    November 2, 2015
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    City, State:
    Milwaikee, WI
    Year, Model & Trim Level:
    2007 Explorer Limted
    x2 blend door.

    You can run the EATC check, get the Truck up to temp and have the EATC off, then press the off button and front defrost at the same time and then and immedately press the automatic button. The system will test and then display a code, otherwise the entire display will light up. Just another way to troubleshoot to try and be sure.

    Mine had the same symptoms, and the EATC check showed all good, I replaced the blend door actuator anyway and its been good for over a year now.
     

Share This Page







We Support Our Troops!