iac | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

iac

  1. E

    IAC and Block Vent Hoses

    Hey Guys, I rescued a 130K 2001 Explorer Sport. Reading and learning. It apparently adopted a human. My first questions. This a photo of a 2000, and we see a Block Vent Hose and an IAC Hose. 1. Why is there no IAC hose on my 2001? 2. Reading about block vent hoses, on some of the diagrams I...
  2. D

    93 Explorer surge at 45...another MAF??

    Hi guys. Hey I had an issue last week coming home from a fishing trip up to the lake. Almost home and the engine started to surge at...from what I noticed....at around 45 mph. Freaked me out as I was towing a John boat and didn't want to have a breakdown. I've had her sitting until I got info...
  3. N

    2007 Ford Explorer IAC

    I cannot find my idle air control valve location at all. Does anyone know where it is located?
  4. W

    CEL with code P0102 and already replaced MAF. Please help

    My 99 explorer 5.0 has CEL P0102 low voltage MAF sensor. I have replaced the sensor, the connector, throttle body sensor, IAC valve, gaskets and checked for vacumm leak although there seems to be a leak i can't find after the MAF sensor. What else can be causing this code? I can't get it smogged...
  5. Z

    93 Explorer can't even complete an engine test without stalling.

    Last time that I ran the codes on my explorer i got a new code 412 (iac causing it to idle to low). So I used some Gumout to try and clean out the iac control valve. When I started it up after that, it seemed to start even stronger than it did before. But when I started to drive it. I got like...
  6. G

    changed iac valve, now revs to 3k rpm on start up

    i just changed my IAC valve on my 2002 4.6, i changed it because of rough idle. when i took the old one off it was missing the spring. but now it idles fine and runs smooth. but on startup it revs to almost 3k rpm for about 5 seconds then drops to normal idle rpm. is this normal? kinda freaked...
  7. D

    2007 IAC valve?

    Hi all!- I'm new here this is my first post. Tried searching for this but didn't come up with anything. My 2007 4L xlt explorer has an issue- when it comes down to idle speed it revs back up and repeats this again and again, even when moving and foot off the gas, it'll rev back up to 2000 before...
  8. R

    Having idle issues and can't figure out the solution

    Hi there I'm new to this forum and hope this is the right place to ask this question since I can't find anyone with the same issue as me. I have a 1992 ford explorer 4.0 I just but this about a month ago. So the issue is when I first start it up the rpms jump to 2000 then slowly go down then...
  9. M

    2002 Explorer idles high when slowing down

    Hey, I have a 2002 Explorer 4.6L and I recently changed the IAC valve because when the car was cold it would not stay on. Changing the IAC did fix the issue of it not staying on when it was cold but now I find it pulls hard as I slow down to stop and once I am about to stop the rpm's drop and it...
  10. D

    Throttle body cleaning messed up Expo

    2004 Ford Explorer V6 4.0. So, I was cleaning the throttle body with the car running using carb/choke cleaner. Had someone inside the car giving it gas and letting off while I was spraying the inside of the butterfly valve. It was working fine and then it started to stall. It was able to restart...
  11. L

    '02 Explorer 4.6 idle issues. Where to start? Techies pls chime in

    2002 (10/06) Explorer 4.6, 4x4 First off there are no DTC's in the ECU Issues are: sporadic idle, stalling, idle after throttle sticks around 2000rpm, drops to 450-500rpm, delayed throttle response. Engine load at 21% at idle also TPS at 16.4%. This vehicle is giving me the run around. It...
  12. E

    1992 explorer bucks like a bronco!

    ..1992 Explorer...when passing on the freeway or just wot to get on the freeway, she bucks / stumbles quite suddenly at almost exactly 4000 rpm....then picks back up as the revs drop just 1-2 x....i can get over 4000 but I have to wot PAST 4000 to avoid the buck.... Fuel pressure was tested...
  13. V

    1994 explorer IAC vs the 1995 explorer IAC

    So guys, my IAC recently hit the bucket, you can only clean them but so many times till they finally fail on you. At the junk yard i picked up a IAC from another 95 explorer. I also picked up one from a 1994 explorer because they have the same exact wire harness connector and bolt up the same...
  14. A

    Engine issues when idling and in neutral - possible vacuum leak

    Last summer I purchased a 1996 4.0 L V6 Ford Explorer with a manual transmission and 135,000. Aside from a small oil leak from the valve covers I had repaired, I had no problems until the alaskan winter set in. After the temps dipped down into the single digits, I noticed startup become a lot...
  15. G

    New IAC CAUSED howling noise

    I've seen a bunch of posts regarding old IAC's causing a howling noise, and cleaning/replacing made them better; however, I just installed a new IAC and now I have howling at idle when I didn't have it before. I bought the cheapest one, duh...
  16. C

    4.0L-OHV Throttle Body / Intake Plenum Interchange - Need Quick Answer

    I have a '93 Ranger. My throttle has developed a nasty habit of sticking halfway open!:eek: No, cleaning it won't help. I've tried. I believe the return spring is worn, and/or the shaft bushings are bad. My question is what other year throttle bodies will bolt right on? The BBK TB is listed...
  17. N

    2001 Explorer, idle/oil pressure correlation?

    Hello, I have a question about the possibility of a link between a bad IAC valve and a loss of oil pressure at idle? The specifics are, truck has been running great. Only major thing so far has been fixing the rear timing chain. Truck has 180K miles on it with regular maintenance. For...
  18. P

    Belt Tensioner

    Broke off while driving. Replaced the entire belt tensioner assembly. Just replaced the belt itself less than 4 months ago. Didn't think I need to replace the belt...but, how would one tell that it needs to be replaced? Also...the 95 Ford Explorer OHV with 127,000 mi on it...has trouble...
  19. H

    Smoke test for Vacuum Leak

    Hey guys..I'm getting the infamous right/left bank running lean on my 2000 Explorer. So I ran a smoke test to see if there was a vacuum leak. The upper intake manifold is def leaking in one spot so I guess I'm replacing the gasket for that for sure. I also saw smoke coming out of the "knob"...
  20. F

    IAC Moose call/Vacuum Cleaner fix

    Hi guys, I've read up on alot of the IAC issues people have had in the past here. I know most ppl recommend replacing them. However, they cost about $800 pesos($75 dollars) here in Mexico. So finding a way to make it work again is not a bad thing. At least I feel it may buy you some time. I...
  21. 9

    high idle!!!

    im new here bout my 93 sport bout two weeks ago i got something going on with the rpms i start it and it sticks at 3000 rpms and stay there i unplug the MAF and it drops some but stays up higher then normal ive heard vac lines and IAC but i would like a second opinion cause if i can do it my...
  22. P

    Wrong Idle Air Control Valve??

    I have all the symptomns of a bad IAC but I can't seem to find the correct Valve at any auto parts stores my vlalve looks like this.... but this one is off a 2001 explorer sport not sport trac. All the stores tell me that this is the one i want... which actually runs well...
  23. E

    93 xlt maf problems

    with WOT (from a stop or at any speed) cuts rpms to an idle and will stall if pedal kept depressed. FPR i assume is good. checked with pressure test. new IAC, MAF, FUEL PUMP, fuel intake line,starter, battery, fuel filter, ect, brakebooster,TPS,plugs and wires, coil pack, an o2 sensor, and an...
  24. S

    Bad IAC Valve?

    I got my Explorer a couple of years ago and I have had no problems so far except for a humming noise that I can hear under the hood, mostly while idling. After doing a little bit of research I think that the problem is the Idle Air Control Valve. I have tried cleaning it out about three times...
  25. S

    Hot start problem

    I have an intermitent problem that occationally occurs after I drive for a while. Stop, turn off the Explorer. 5-10 minutes later the truck wont start. Cools for an hour & it starts & runs full power. No problems. What could it be. I was thinking fuel pump but I tried starting fluid while having...
Top