• Register Today It's free! This box and some ads will disappear once registered!

  • We are aware of the issue with our internal search engine and we will be bringing it back online shortly. For now please use the Google search bar near the top of each page. Thanks, Rick
^^Searches ExplorerForum.com^^

2000 AWD Xploder from Turbo back to NA


CDW6212R

Hauls the mail.
Elite Explorer
Joined
June 17, 2004
Messages
20,121
Reaction score
1,344
City, State
Knoxville, TN
Year, Model & Trim Level
98 Limited AWD
I like those, and my lights look just like your old ones.

But those new lights would be too pretty for my mail truck. I'm in Pigeon Forge now, I could join one of the cars shows right?
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




willzilla

Elite Explorer
Joined
July 14, 2010
Messages
1,019
Reaction score
29
City, State
San Antonio, TX
Year, Model & Trim Level
2000 XLT AWD
I like those, and my lights look just like your old ones.

But those new lights would be too pretty for my mail truck. I'm in Pigeon Forge now, I could join one of the cars shows right?
Haha, of course!

I ended up needing to build an entire new harness to switch from the Bi-Xenon to the single HID low beams with halogen High beams... Got it all wired up nice and went to put in the blinker and one of the other stock bulbs into the new fancy housing and the damn connector just crumbled apart :-/ Ordered 4 new connectors to replace all 4 and will try again in a few days... Still need to build the other harness for the drivers side (ties in the halo rings and day time running led lights into the old day time running light wire harness) and also splice the new lens wires for the hi and lows into the power relay so I can split the lows from the igniter/ballast and the highs direct from the stock connector (built a plug and play connector that plugs right into the stock headlight connector). All worked nicely until the dang old connectors shattered lol.

Put some new taillights on my WRX yesterday that look awesome as well so it's been busy busy LOL.

Started a cheesy youtube video, mostly WRX stuff planned, but doing some Xploder and Smart car (wife's) stuff on it as well. Only have a few videos right now but hope to add many more soon, including the funky headlight conversion I'm doing on the Xploder :D haha... Everyone welcome to sub ;) LOL

yt.vu/+WRXZILLA

Will Green on Instagram: “The OLM Spec CR Sequential tail lights (dark smoked lens w/black base and clear running light) on my black #2017 #Subaru #WRX #Limited …”
 




CDW6212R

Hauls the mail.
Elite Explorer
Joined
June 17, 2004
Messages
20,121
Reaction score
1,344
City, State
Knoxville, TN
Year, Model & Trim Level
98 Limited AWD
Very cool, sounds well thought out. I won't do anything with my 99 Explorer, but this 98 I'll convert to the Mountaineer grille and lights at some point. I like the Mercury headlights better, but unfortunately there are no aftermarket choices.

I need to talk you into converting your Explorer, so you can build something for it like what you're doing now.
 




willzilla

Elite Explorer
Joined
July 14, 2010
Messages
1,019
Reaction score
29
City, State
San Antonio, TX
Year, Model & Trim Level
2000 XLT AWD
Headlight install has been a total pain in the ass.. I'm sure it would be easy if I just kept it plug and play with the included halogen bulbs, well, easier... still not perfect though, with these Spyder headlights. The twist lock bulb sockets are orientated differently with the Spyder headlight which causes some fitment issues and pushing the housing in place. Had to also dremel out some space to fit the sockets into place as there was weird overlap with the hole in the back of the housing and the reflective lens within. Had to also pull the snap plug from the back of the HID as it stuck up to far from the back and caused fitment issues and while pushing headlight into place caused the bulb to friggin shatter, lol :*(. Ended up pulling the back piece off the bulb with the plug and it left 2 connector holes and I just tight fit 2 soldered up wires that snapped into place and went with that. Was able to get it back into place and finished up the drivers headlight and test it out... Seems to work, so far, haha. Still need to wait for replacement bulb to arrive and to tweak how I direct connect wires into it when it does arrive.

I also wired in all new blinker and running light plugs and also plug n play connectors for the headlight to snap into to remove the headlight.











 




willzilla

Elite Explorer
Joined
July 14, 2010
Messages
1,019
Reaction score
29
City, State
San Antonio, TX
Year, Model & Trim Level
2000 XLT AWD
Had to run to Autozone as it was getting dark... took the Xploder as my WRX suspension is completely out while I revamp it all and put it on coilovers... The ONE headlight that is installed seems to be working nicely and looks pretty good... Here is a quick shot of the cutoff of the beam and the highs:





Did have a weird issue going from lows to highs and back to lows... would make clicking sound and lows wouldn't come back on until I took switch off and put it back on... Not sure what's up with that, haha. Turned car on again a little later and didn't happen again, weird. My blinker is hyper speed blinking so probably need the led adjusted blinker module.
 




willzilla

Elite Explorer
Joined
July 14, 2010
Messages
1,019
Reaction score
29
City, State
San Antonio, TX
Year, Model & Trim Level
2000 XLT AWD
Got my replacement HID bulb in today after work, should be able to finish up my other headlight and have both up and running. Did notice, with a single headlight, occasionally enabling brights and switching back to lows... and I no lows come on, lol. Dunno what's up with that, so, will only use lows until high/low switch is figured out better. Not sure if it's something to do with how the wiring is done or what.

Rear brake caliper loosened up a bit... Tightened all brake caliper and bleeders to spec and while I was under the truck replace the rear diff abs sensor... And... abs sensor light still on :*( lol, ugh.
 




CDW6212R

Hauls the mail.
Elite Explorer
Joined
June 17, 2004
Messages
20,121
Reaction score
1,344
City, State
Knoxville, TN
Year, Model & Trim Level
98 Limited AWD
How old are your front hubs, which have the ABS sensor in them? If they might be old, one may be worn out and the bearing movement affects the ABS sensor. Check those bearings.
 




willzilla

Elite Explorer
Joined
July 14, 2010
Messages
1,019
Reaction score
29
City, State
San Antonio, TX
Year, Model & Trim Level
2000 XLT AWD
How old are your front hubs, which have the ABS sensor in them? If they might be old, one may be worn out and the bearing movement affects the ABS sensor. Check those bearings.
I assume the front hubs are as old as the truck, lol. A buddy of mine has a new tool he just got that can run abs codes, I'll see if to can work on my truck and read the code and figure out actual issue.. hopefully something simple.

Also, almost done with my headlights... So many projects only get a little time on each haha.
 




willzilla

Elite Explorer
Joined
July 14, 2010
Messages
1,019
Reaction score
29
City, State
San Antonio, TX
Year, Model & Trim Level
2000 XLT AWD
Found old thread and read it over... Looks like front hubs were replaced in 2011.
 




willzilla

Elite Explorer
Joined
July 14, 2010
Messages
1,019
Reaction score
29
City, State
San Antonio, TX
Year, Model & Trim Level
2000 XLT AWD
Finally finished up the projector hid setup... Pita getting hids to work with the damn headlight housing I got... All works but for whatever reason the driver side turn signal blinks fast and passenger side turn signal blinks regular speed, lol.

A couple photos:








Did a video of much of it that I'll try to get edited and posted on my YouTube channel sometime soon.
 




CDW6212R

Hauls the mail.
Elite Explorer
Joined
June 17, 2004
Messages
20,121
Reaction score
1,344
City, State
Knoxville, TN
Year, Model & Trim Level
98 Limited AWD
Very good, one project at a time.
 




willzilla

Elite Explorer
Joined
July 14, 2010
Messages
1,019
Reaction score
29
City, State
San Antonio, TX
Year, Model & Trim Level
2000 XLT AWD
Well.. low beams worked fine for a few days and don't come on at all now, as of yesterday lol. Need to see if I popped a fuse or something. High beams and DRLs and blinkers all still work fine, just no low beams (both). Odd. Was dark and couldn't delve into it last night.
 




willzilla

Elite Explorer
Joined
July 14, 2010
Messages
1,019
Reaction score
29
City, State
San Antonio, TX
Year, Model & Trim Level
2000 XLT AWD
Ok, seems my self made pin to fit into the H1 HID socket is the cause of the problem of the bulbs taking a dump on me, lol. Ordering a new set of bulbs and will have to cut a chunk out behind the headlight so they fit comfortably with the actual connector in place :D lol.
 




willzilla

Elite Explorer
Joined
July 14, 2010
Messages
1,019
Reaction score
29
City, State
San Antonio, TX
Year, Model & Trim Level
2000 XLT AWD
As usual.. have been busy busy with work. Took a new job down in San Antonio Texas as a contractor for the Air Force... Drove my WRX down and now the explorer just sits. I did finish the headlights thankfully! Re-did the housing so the bulb connection is good now and legit, not just a self made pin anymore but actual bulb connectors lol. May end up selling the explorer though, sadly, as I don't know if I'd have an easy way to transport it down to Texas and am currently in an apartment (wife and kids still in TN until end of the school year). If anyone interested in perhaps buying the explorer let me know <3 Located in West TN still... runs and drives great (though still needs the fresh transmission fluid as I still haven't gotten around to doing that, lol.. have the fluid and filter just been busy! Lol). :D
 




CDW6212R

Hauls the mail.
Elite Explorer
Joined
June 17, 2004
Messages
20,121
Reaction score
1,344
City, State
Knoxville, TN
Year, Model & Trim Level
98 Limited AWD
Congratulations with the job, I hope that becomes a welcome change. I just bought another 98 Limited with the 302/AWD, I have too many myself.
 




willzilla

Elite Explorer
Joined
July 14, 2010
Messages
1,019
Reaction score
29
City, State
San Antonio, TX
Year, Model & Trim Level
2000 XLT AWD
Haha.. nice! And yeah... same type of work I was doing for the Navy but with the AF now... and double the pay. Cost of living in this area is cheap as it was in west TN so that's nice! Hopefully I'll be able to figure out an easy way to bring the Xploder down with me when I sell my TN house and buy one here in TX but we'll see! Sucks living in an apartment with no tools and no garage or driveway!
 




CDW6212R

Hauls the mail.
Elite Explorer
Joined
June 17, 2004
Messages
20,121
Reaction score
1,344
City, State
Knoxville, TN
Year, Model & Trim Level
98 Limited AWD
Very good. I'd drive it there if possible, since you know it fairly well and know what it needs.
 




willzilla

Elite Explorer
Joined
July 14, 2010
Messages
1,019
Reaction score
29
City, State
San Antonio, TX
Year, Model & Trim Level
2000 XLT AWD
Listed the truck up for sale :-/... To much going on to keep at it and it would be to much of a hassle to move it down here to Texas WITH 2 other cars + UHAUL (which may be a few trips itself)... 800 miles each way and limited PTO to take to make it happen, unfortunately.

Truck runs great... Looks great (in my opinion) and is stocked full of new or near new parts (suspension, brakes, ac parts, wheels, tires, etc, etc). I have a ton of high quality parts on this car and it's semi-unique (torque monster headers, meziere water pump, custom e-fan setup cooling system, etc). Has a few minor issues.. Transmission fluid needs flushed and re-filled (brand new AMSOIL auto transmission fluid and filter included), tune could be re-done (has check engine light for the EGR being deleted... current tune is done by Henson before he retired or whatever.. comes with SCT3 programmer). No rust other than the typical surface stuff underneath you can see on the metal parts.. nothing abnormal.. plus a tiny bit surface stuff on a cpl small rock chips that could be sanded a bit and touched up (have paint matched paint pens and primer/etc that can be included if desired). Even has fresh nice HIDs with custom projector housings lol :)

2000 AWD 5.0 XLT 144k or so miles. Runs great (may need a jump or charged for sitting on and off past 4 months.. I tell wife to drive it and she does if she remembers lol).

I was thinking maybe $3000 obo.. See if I get any bites.. post is over at: For Sale - 2000 Ford Explorer XLT 5.0 AWD Modified (Torque Monster headers, etc)

Thank you everyone for all the of the constant help with all of my stupid questions! Overall I think I've learned a TON and everything I learned working on this truck enabled me to do a ton of my own work on my WRX and my wife's Smartcar, her old van, and if need be, her new 2019 Nissan nv3500 :D If I do end up finding a buyer I plan to stick around to haunt people with more dumb questions ;)
 
Last edited:




CDW6212R

Hauls the mail.
Elite Explorer
Joined
June 17, 2004
Messages
20,121
Reaction score
1,344
City, State
Knoxville, TN
Year, Model & Trim Level
98 Limited AWD
I hope your move to Texas is great for you and the family. Good luck with the move, that could be tough if you have to make a number of trips. A solid 302 Explorer is worth $2500 in good condition, I'm sure you'll find a buyer soon. I have about that much invested in my new white 98 now, that's not a bad price.
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




willzilla

Elite Explorer
Joined
July 14, 2010
Messages
1,019
Reaction score
29
City, State
San Antonio, TX
Year, Model & Trim Level
2000 XLT AWD
I hope your move to Texas is great for you and the family. Good luck with the move, that could be tough if you have to make a number of trips. A solid 302 Explorer is worth $2500 in good condition, I'm sure you'll find a buyer soon. I have about that much invested in my new white 98 now, that's not a bad price.
Thanks man!

I'm somewhat flexible on price as well, lol, so it's obo. Maybe someone will snatch it up and continue on the long legacy haha.
 




Thread starter Similar threads Forum Replies Date
willzilla Willzilla's 2000 5.0L AWD Turbo Xploder Need for Speed! 45
justin146 My turbocharged 2000 5.0 AWD.... Need for Speed! 220
O 2000 explorer v6 to 302 swap? Need for Speed! 0
Dono Turbo on 2000 Limited 5.0 Need for Speed! 957
Dono 2000 Ford 4.0 OHV Manual Need for Speed! 0
V 2000 Explorer Dynotunning Video Need for Speed! 6
ebox86 2001 Ford Explorer vs 2000 Chevy POS Blazer Need for Speed! 31
C 5.0 2000 Limited Dynoed today bone stock Need for Speed! 4
C 2000 V8 5.0 Exploder Limited Need for Speed! 4
E Mass air flow sensor for 2000 5.0 V8? Need for Speed! 2
9 Maximum Torque through Stock 4WD/AWD system? Need for Speed! 8
R 03 awd explorer turbo build Need for Speed! 10
F 347 RE-Power 1996 Limited AWD Need for Speed! 252
T Best way to launch 5.0 AWD Explorers Need for Speed! 11
S Turbo SOHC to Turbo 5.0 V-8 AWD Need for Speed! 40
N 1997 explorer limited AWD 5.0 vs 2002 explorer V6 SOHC 4x4 Need for Speed! 19
I AWD Burn Out Need for Speed! 100
B How-To Get Low 15/High 14 seconds In V8 AWD? Need for Speed! 37
Turdle AWD dyno Need for Speed! 5
A supercharger 5.0 awd Need for Speed! 13
1 removal of front driveshaft and other 5.0 AWD questions Need for Speed! 3
B 1999 V8 AWD Need for Speed! 7
A awd gears???? Need for Speed! 3
M AWD Tcase on built 302? will it hold? Need for Speed! 7
P Found one!!! AWD dyno - Finally Need for Speed! 9
Mike AWD 5.0 mods?! ideas? Need for Speed! 15
B AWD front end power capabilities Need for Speed! 3
C Can I turbocharge my xploder Need for Speed! 18

Similar threads

Top