• Register Today It's free! This box and some ads will disappear once registered!

  • We are aware of the issue with our internal search engine and we will be bringing it back online shortly. For now please use the Google search bar near the top of each page. Thanks, Rick
^^Searches ExplorerForum.com^^

Explorer Navigation Tracking Problem


Sgt1411

Elite Explorer
Joined
February 22, 2011
Messages
4,307
Reaction score
338
City, State
VanBC/GoodyearAZ
Year, Model & Trim Level
2017 Explorer SPORT
It might also help you troubleshoot the problem if you put your MFT into Diagnostic Mode.

This procedure is described in one of the "Sticky" threads at the top of the main page for the MFT Section of the 2014 Explorer Forum.

One of the things you can monitor is how many satellites the GPSM is seeing.
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




Hombrewr

New Member
Joined
August 15, 2013
Messages
9
Reaction score
0
City, State
Sandy, Ut
Year, Model & Trim Level
2014 Explorer
Sgt1411 - Thanks for the tip, I saw that and may try it this weekend just out of curiosity - on the flip side since I removed the "-" battery terminal and forced a master reset, my Navigation "seems" to be working OK. Time will tell
 




JohnBoyToo

Active Member
Joined
April 4, 2013
Messages
453
Reaction score
1
City, State
DFW, TexUS
Year, Model & Trim Level
13 Sport, 13 F350 6.7CCSB
I do too much troubleshooting @ work :)

and is not something I want to do on a brand new car.... I just want it to work and I want them to fix what I paid for...

is it life threatening --- not usually, but I paid for something and it doesn't work...
my wife won't even use it and wants me to buy another garmin for her!

This old Garmin is over 5 years old and works perfectly -
I don't recall the last time I felt I couldn't trust it.... and the new ones are even better...
 




Matrix848

New Member
Joined
June 28, 2012
Messages
31
Reaction score
1
City, State
Toronto, Ontario
Year, Model & Trim Level
2017 Ford Explorer Sport
I had similar issues when I first got my sport. I took it to the dealership and they had a look but couldn't fix it. I put it in to diagnostic mode to see if I could pin point where the problem was myself (# of satellites etc..) and pretty much seemed to fix itself.

Now I don't use it very often (maybe once every couple of weeks) but since then it's worked flawlessly. No idea why, maybe less sun spot activity? or the NSA stopped tracking me? :p
 




JohnBoyToo

Active Member
Joined
April 4, 2013
Messages
453
Reaction score
1
City, State
DFW, TexUS
Year, Model & Trim Level
13 Sport, 13 F350 6.7CCSB
K - brought it into the dealer and this issue is so prevalent that the svc writer was joking about other customers saying it took them into the lake, etc....

HE thought it quite funny that the navigation fails at navigation :)

He said there was an update recently --- I said I did it --- he said no a new one about a month ago -- I said I DID it ! we'll see...
 




Hombrewr

New Member
Joined
August 15, 2013
Messages
9
Reaction score
0
City, State
Sandy, Ut
Year, Model & Trim Level
2014 Explorer
My dealer also said they may have an update but... Now for my update; It has now been over a week since I disconnected my Neg Bat Terminal and left it hanging for 15 min; so far it has been working the way it is suppose to be! I can honestly say it works like a champ and I have been using it regularly, trying to get it to mess up but...
 




wadge

New Member
Joined
November 14, 2012
Messages
28
Reaction score
0
City, State
Northern Ontario
Year, Model & Trim Level
2013 Explorer limited
I had the update done on friday. Tracking still not working properly, my explorer jumps from the correct position to the trees or lake every time I take a corner. I will let my dealer know the bad news in the morning.
 




RJT

Member
Joined
October 23, 2001
Messages
73
Reaction score
0
City, State
Martinez, CA
Year, Model & Trim Level
2011 limited/ '97 xlt
Same with me...its hopeless. Navigation simply does work. End of Story
 




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
28,108
Reaction score
1,673
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
Same with me...its hopeless. Navigation simply does work. End of Story
I assume you meant to say "simply does NOT work". Unfortunately it just doesn't work for you and a few other members for some reason. As for navigation in general, it works fine for me and many others, so navigation does work.

Peter
 




JohnBoyToo

Active Member
Joined
April 4, 2013
Messages
453
Reaction score
1
City, State
DFW, TexUS
Year, Model & Trim Level
13 Sport, 13 F350 6.7CCSB
Well, our definition of 'works' must be different :)

My 5 year old garmin 5000 WORKS, mft failed again on me yesterday....

Had to run down here for a part yesterday:
Ancira RV
5201 S Interstate 35 W
Alvarado, TX 76009

took 2 seconds to find on google,
about 1 minute to type into garmin,
and no matter what I did with mft, never found it ....

but it is a new motorhome dealer - only been there since 1971 :)


I will say we LOVE everything else about the lil sport ---
since my 350 was hooked to the rv, I drove the Ex last night and still amazed at the ride and drive !
(and we just came out of a 2011 Audi turbo!)
 




FordIVTteam

Official Ford Rep
Joined
July 13, 2011
Messages
1,690
Reaction score
1
City, State
Dearborn, MI
Year, Model & Trim Level
Ford Explorer
Well, our definition of 'works' must be different :)

My 5 year old garmin 5000 WORKS, mft failed again on me yesterday....

Had to run down here for a part yesterday:
Ancira RV
5201 S Interstate 35 W
Alvarado, TX 76009

took 2 seconds to find on google,
about 1 minute to type into garmin,
and no matter what I did with mft, never found it ....

but it is a new motorhome dealer - only been there since 1971 :)


I will say we LOVE everything else about the lil sport ---
since my 350 was hooked to the rv, I drove the Ex last night and still amazed at the ride and drive !
(and we just came out of a 2011 Audi turbo!)
Good morning, JohnBoyToo,

I checked my MFT (v3.6.2 with an A4 SD card) to see if I could find the address you posted; I found it within a minute and a half. What I did was this:

~Went to the Street Address option on the navigation screen.
~Changed my state from Michigan to Texas.
~Typed in ALVA and Alvarado automatically populated.
~Typed SOUTH I and S Interstate 35 W automatically populated.
~Typed in 5201 and pressed GO.
~I then set it as my destination.

I also performed the above steps with the A3 SD card and had the same results. If you're still not able to find this address in your navigation, I suggest a trip to your dealership. You can show them this address isn't populating for you, and have them try it on a different vehicle with the same software/SD card.

Rebecca
 




RJT

Member
Joined
October 23, 2001
Messages
73
Reaction score
0
City, State
Martinez, CA
Year, Model & Trim Level
2011 limited/ '97 xlt
[MENTION=163604]peterk9[/MENTION]…thanks for pointing out that critical missing word. Yep, I meant to say, “Does Not work”. But here’s the thing; I currently have a Tom-Tom, Garmin and Garmin Legend for backpacking. All of these devices work. They simply work. There’s no, “Did you try a reboot?”, Did you try a hard boot?”, “do you have the latest software?”, “have you taken out the batteries and left it for 5 minutes?”. This is not new technology.
There are times I just smile at what my nav system is doing. Granted it doesn’t happen all the time but this issue never occurred in early ownership. Now its 10-15 minutes of driving time before a lock occurs. Then, it often goes off course maybe 15% of the time while driving – all under clear unobstructed skies. But, when I’m in the Sierras on a Forest Service Road with plenty of sky view and my nav fails to work, then yes…it is a huge problem.
Now for my ‘old man…get off my lawn rant’. Within this thread there are probably 15 or 20 “home remedies” for a potential fix. I’m thankful for all the suggestions and responses but really, doesn’t this point out an issue to you? I’m at a loss at what “As for navigation in general, it works fine for me and many others, so navigation does work”, brings to the table. This topic has been near or at the top of this forum for months. There are over 8 pages and hundreds of comments regarding nav issues. Consider that this is a specialized forum and consider that the general population of EX owners would never even know that these discussions are taking place. My point being that yeah, within the ownership population ‘in general’, I believe that nav lock is an issue.
 




JohnBoyToo

Active Member
Joined
April 4, 2013
Messages
453
Reaction score
1
City, State
DFW, TexUS
Year, Model & Trim Level
13 Sport, 13 F350 6.7CCSB
Thanks for the testing rebecca...
but point being I didn't know the address... with that, and parking on the side of the road for a few minutes, it can be found - my goodness, at least I hope it can be :)

I was trying to do what you can in google on my tablets or phones when you don't know the address - a poi search by voice prompt -
since it won't let you do typing while driving even if your spouse is doing it

(Maybe they can change the code to query the passenger air bag switch to know when a passenger can use the nav ?)

and so I tried Ancira, I tried RV, I tried Motorhome, I tried ....

and whoever decided that you need to choose a category before looking for a poi should be beat with a wet noodle as how do WE know what category someone else decides to put something under... (I know, makes for quicker and smaller searches with a subset of the data.... but :) )
ok - off my soapbox - glad I like both my loaded 2013 F-350 platinum and 2013 Explorer Sport otherwise !!!
 




lazychuck49

New Member
Joined
October 3, 2013
Messages
6
Reaction score
0
Year, Model & Trim Level
2012 Explorer
i seem to be having the same issue as others have with the nav system not locking in on the current location accurately, tho i've seen something that was a surprise to me. i have all the recent updates and i tried the reboot app from http://outofmytouch.com/reboot.html but it did not fix the problem.

perhaps others have seen this but when my explorer is parked at home i can start the thing and select "navigate". the map shows correctly but the red marker that should show my current location appears to be 1/2 mile or so from my home.

as an experiment i then set the destination to "home". guess what? the map showed the destination location correctly (my home) and the system immediately announced that i've reached my destination (with a moving time of "0" minutes). it knew i was home, but the initial display was dead wrong. to get these results, it seems to me that the gps system must have been working accurately.
 
Last edited:




thestumper

Member
Joined
August 28, 2013
Messages
50
Reaction score
0
City, State
Pittsburgh, PA
Year, Model & Trim Level
2013 Ford Explorer Sport
It is strange. Mine works perfectly 85-90% of the time, but when it's off, it's never off by more than 1/8 of a mile - sometimes less. Often I'll see myself driving just off the side of the road along my route on the map screen. I have noticed that it seems to be more prone to going off track if I drive on a road it doesn't know about or if I spend any time in a large parking lot. It may just be coincidence, but it almost seems to confuse MFT. The reboot trick helped the last time - I've been good for 5 days now.

Per the post above, that would make sense. The GPS itself seems to know exactly where you are but the mapping implementation is buggy. I'm running 3.6.2 and still struggle with this and the constant device indexing on particular devices (iPhone works great, iPod Disk is a mess, jury still out on USB thumb drive).

Note to Ford/MS: This is bush league stuff. Other people have been doing this correctly for quite some time. :thumbdwn:
 




tucker_bmd

Active Member
Joined
January 14, 2011
Messages
105
Reaction score
0
Year, Model & Trim Level
2012 XLT AWD
GPS status

...the map shows correctly but the red marker that should show my current location appears to be 1/2 mile or so from my home. ...
Can you clarify please, when this happened had you acquired GPS yet?
 




vfral1

Active Member
Joined
February 8, 2011
Messages
260
Reaction score
0
City, State
Cumming, GA
Year, Model & Trim Level
'11 LTD Golden Bronze
My NAV generally works ok (ok, not great like garmin), but it seems lose satellite signal quite easily on a regular basis. I know this from the red X over the GPS symbol that pops up. Usually it can find its way eventually, but yesterday it was waay off (8 miles or so) for my whole 30 min trip home. Thought it was a satellite problem, but it appears that it just needed a reload, because I popped the A4 card out, and after reinserting it regained its accuracy.

Still, I agree with other posters, that even the least expensive Garmins do this flawlessly and give a lot more data. I would think for an $800 option (for my MY) we would have gotten much better functionality.
 








lazychuck49

New Member
Joined
October 3, 2013
Messages
6
Reaction score
0
Year, Model & Trim Level
2012 Explorer
more unexpected strangeness.

this morning when i started the suv for the first time since yesterdays post my location shown on the map display was still off by 1/2 mile or so. i entered a new destination and before moving selected make destination. the display then corrected itself and the nav directed me to the destination correctly (no "off route" messages either). i used the nav system several more times today and all seems well.

so today i'm wondering if the app i downloaded yesterday actually worked, even tho it had startup issues. or was it just a coincidence that the nav started working correctly at that exact moment?
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




rmp301

Active Member
Joined
October 19, 2011
Messages
313
Reaction score
0
City, State
Yonkers, New York
Year, Model & Trim Level
2012 Explorer XLT
Navigation Fault

While using navigation on a rainy Saturday night, map screen went gray and curser moved in direction I was last travelling with "Off Route" displayed. I was able to recover screen again by parking and re-inputting destination. I am wondering if satellite signal was lost, as has happened with Sirius on past occasions, or if there was a glitch in the navigation as everything was lost on the screen. Has anyone else experienced this? It is a first for me. :(
 




Thread starter Similar threads Forum Replies Date
A Aftermarket 12.1" Android Navigation Radio for Explorer 2011-2016 My Ford Touch / In Vehicle Technology 4
K Another Explorer Navigation Error 2011-2016 My Ford Touch / In Vehicle Technology 9
S Does Explorer 2012 XLT have Navigation? 2011-2016 My Ford Touch / In Vehicle Technology 5
B Navigation for Explorer 2013 XLT 2011-2016 My Ford Touch / In Vehicle Technology 15
R POI problem with Explorer's navigation system 2011-2016 My Ford Touch / In Vehicle Technology 13
D 2014 Explorer Limited Cannot use both USB ports at the same time 2011-2016 My Ford Touch / In Vehicle Technology 5
C 2013 Explorer Rearview Camera Issue 2011-2016 My Ford Touch / In Vehicle Technology 3
S Adding One Touch to rear windows 2018 Explorer Sport? 2011-2016 My Ford Touch / In Vehicle Technology 5
J 2013 Ford Explorer XLT - Controls not working 2011-2016 My Ford Touch / In Vehicle Technology 9
M 2016 Explorer Limited - Front USB ports not working 2011-2016 My Ford Touch / In Vehicle Technology 13
P 2011 Explorer XLT APIM issues 2011-2016 My Ford Touch / In Vehicle Technology 1
iTonyp Sync 3 2016 Explorer 2011-2016 My Ford Touch / In Vehicle Technology 2
E 911 Assist Fault Explorer 2013 2011-2016 My Ford Touch / In Vehicle Technology 12
N 2016 Explorer Sport Front Camera Doesn't Work 2011-2016 My Ford Touch / In Vehicle Technology 1
D 2011 Ford Explorer Sync 2 replacement 2011-2016 My Ford Touch / In Vehicle Technology 2
R 2013 Explorer Sport Cruise Control 2011-2016 My Ford Touch / In Vehicle Technology 21
S 2012 explorer cross traffic fault blind spot fault 2011-2016 My Ford Touch / In Vehicle Technology 1
J 2015 Explorer Sport - upgrading Sync 2 to Sync 3 - have few ?'s 2011-2016 My Ford Touch / In Vehicle Technology 14
M 2013 Explorer - Left Information Display - White with black lines 2011-2016 My Ford Touch / In Vehicle Technology 15
S Issue with 2015 Ford Explorer Key Fob 2011-2016 My Ford Touch / In Vehicle Technology 3
N 2012 Explorer XLT Keyless Entry Inoperable 2011-2016 My Ford Touch / In Vehicle Technology 4
W 2011 Explorer XLT - Radio Problems 2011-2016 My Ford Touch / In Vehicle Technology 2
J 2013 Ford Explorer message 2011-2016 My Ford Touch / In Vehicle Technology 8
P Upgrading 2016 Explorer to Sync 3 - FORScan questions 2011-2016 My Ford Touch / In Vehicle Technology 28
G Software updates for 2014 Explorer XLT 2011-2016 My Ford Touch / In Vehicle Technology 1
A 2011 Explorer APIM Question 2011-2016 My Ford Touch / In Vehicle Technology 3
F 2013 Explorer Media Interface Question. 2011-2016 My Ford Touch / In Vehicle Technology 5
K Newbie to the Explorer forum question 2011-2016 My Ford Touch / In Vehicle Technology 8
K 2013 Ford Explorer 200 Plug In Play Remote Start Key Fob not working 2011-2016 My Ford Touch / In Vehicle Technology 4
W 2017 Explorer D.I.Y. Remote Start.. 2011-2016 My Ford Touch / In Vehicle Technology 18
J Issue with Sync in 2011 Explorer 2011-2016 My Ford Touch / In Vehicle Technology 14
A Radio wiring diagram for a 2013 Explorer XLT 2011-2016 My Ford Touch / In Vehicle Technology 14
S Add (after market) Collision Avoidance to 2015 Explorer Sport 2011-2016 My Ford Touch / In Vehicle Technology 3
G Android screens for ford explorer 2011-2015 2011-2016 My Ford Touch / In Vehicle Technology 3
G Ford Explorer 2015 XLT additional key 2011-2016 My Ford Touch / In Vehicle Technology 2
L 2013 ford explorer sport headrest DVD. HELP! 2011-2016 My Ford Touch / In Vehicle Technology 2
G Installing Backup Camera and 8" Screen in my 2013 Explorer - Is it possible? 2011-2016 My Ford Touch / In Vehicle Technology 3
H Location of 2013 Explorer Service Button 2011-2016 My Ford Touch / In Vehicle Technology 14
J SYNC 3 in a 2016 Explorer 2011-2016 My Ford Touch / In Vehicle Technology 259
J Siri and XM Radio Questions - New 16 Explorer Platinum 2011-2016 My Ford Touch / In Vehicle Technology 8
M 2012 Explorer USB Ports 2011-2016 My Ford Touch / In Vehicle Technology 1
G Buying a 2012 Explorer - Nervous about MFT Issues (please advise) 2011-2016 My Ford Touch / In Vehicle Technology 7
R 2011 Explorer XLT alarm issue 2011-2016 My Ford Touch / In Vehicle Technology 0
D 2015 Explorer Sport - Intermittant no-start with push button start 2011-2016 My Ford Touch / In Vehicle Technology 21
S Installing a Blackvue in a 2016 Explorer 2011-2016 My Ford Touch / In Vehicle Technology 9
P 2016 Ford Explorer and Remote Climate Control 2011-2016 My Ford Touch / In Vehicle Technology 2
J 2016 Explorer with MFT - Add Climate Control to Instrument Cluster 2011-2016 My Ford Touch / In Vehicle Technology 25
J Add HD Radio to your Explorer 2011-2016 My Ford Touch / In Vehicle Technology 1
M 2013 Explorer Security & Remote Starter Options 2011-2016 My Ford Touch / In Vehicle Technology 16
J MFT SYNC 3.8 SIRI Eyes Free - Avail. on SYNCMYRIDE.COM for 2011-2015 Explorer 2011-2016 My Ford Touch / In Vehicle Technology 330

Similar threads

Top