• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

lifter/rocker ticking at cold start up

puddle jumper

Member
Joined
August 18, 2004
Messages
32
Reaction score
0
City, State
Broadway,NC
Year, Model & Trim Level
`93 Eddie Bauer
ever since i bought my 93 exp it has had a loud lifter/rocker arm tick at a cold start up , but after it warmed up the noise went away,,after reading about lifter and rocker arm wear in the old posts and the trouble and cost involved to replace them , i just accepted the noise and went on about driveing it daily untill one day i decided to run the sea-foam treatment through a vacume port in the throttle body to see if it would make the engine perform better like described by some of the site members, well , it worked just liked i had read it would and now , wouldnt ya know it ,,the lifter/rocker arm tick is completely gone !!! how did that happen ?? i previously used engine flush before an oil change and a quart of Riseoline with my oil changes and that has never done any thing to help quiet the noise ,, so what happened ?? just coincindence ?? does anyone have a clue ???
 




clok1966

Member
Joined
February 15, 2005
Messages
28
Reaction score
0
City, State
West Fargo, ND
Year, Model & Trim Level
92 XLT
I'm suprised this helped Lifter tick, when dumped into the vacume it shpould never actually get on the lifter, or oil passages. Glad it did the trick, I also have lifter tick only on startup for about 1 minute or so. Been trying to sell my truck and that tick is a killer.. I spose I could hide it bend a rocker arm or ?? but thats seems so wrong..


Clok
 




exploded99

Well-Known Member
Joined
June 20, 2005
Messages
320
Reaction score
0
City, State
Denver
Year, Model & Trim Level
99 AWD
Clok1966 has a good point there.....

When you put seafoam in the intake it would have gotten on the valve stems / seats. Perhaps it was a bit of a sticky valve?
 




Top