• Register Today It's free! This box and some ads will disappear once registered!

AC and blowers working but won't blow hot air?


withey92

New Member
Joined
August 16, 2016
Messages
6
Reaction score
0
Year, Model & Trim Level
1996 Explorer Eddie Bauer
I have a 96 Explorer EB edition and the AC works fine and blows cold air but when I turn up the heat the temperature doesn't rise? There's still air blowing through just doesn't get hotter.

I need the heater to work as I'm heading up to Canada for the Winter and won't last long without heat in my car! Any help is greatly appreciated!
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




koda2000

Explorer Addict
Joined
September 2, 2011
Messages
13,843
Reaction score
1,442
Year, Model & Trim Level
x
I have a 96 Explorer EB edition and the AC works fine and blows cold air but when I turn up the heat the temperature doesn't rise? There's still air blowing through just doesn't get hotter.

I need the heater to work as I'm heading up to Canada for the Winter and won't last long without heat in my car! Any help is greatly appreciated!

It could be the notorious blend door problem, a bad blend door actuator, a bad heater control valve or no vacuum to the heater control valve.
 




Speakerboy

New Member
Joined
June 29, 2015
Messages
4
Reaction score
0
City, State
Fort Wayne, IN
Year, Model & Trim Level
1998 Mercury Mountaineer
I drop all winter with no heat just to find in springtime it was a stupid fuse. Check those first, cheap cheap fix if so. My AC would blow cold, but no heat.
 




dr fildo

Member
Joined
May 1, 2012
Messages
96
Reaction score
10
Year, Model & Trim Level
1999 Mercury Mounaineer
Check your radiator for proper fluid level. When very low, it won't blow hot.
 




withey92

New Member
Joined
August 16, 2016
Messages
6
Reaction score
0
Year, Model & Trim Level
1996 Explorer Eddie Bauer
I drop all winter with no heat just to find in springtime it was a stupid fuse. Check those first, cheap cheap fix if so. My AC would blow cold, but no heat.
Where abouts and which fuse is it for the heater? I'm going to make my way through the list of what you guys have given me! I'll keep updating to see how it progresses
 




Hatcher686

New Member
Joined
July 6, 2015
Messages
4
Reaction score
0
Year, Model & Trim Level
1997 Ford Explorer Sport
If your antifreeze level is good and still no heat then it is your Thermostat sensor. This happened to me last winter. The part is like 10 bucks and you will need to drain the antifreeze before you change out the part.
 




Top