Anyone using Autolite plugs and wires | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! Once registered you can join the Elite Explorers to eliminate ads from the website.

Anyone using Autolite plugs and wires

njkev7

Member
Joined
September 6, 2009
Messages
19
Reaction score
0
City, State
Jersey City NJ
Year, Model & Trim Level
1999
Heading to the the auto parts store this week to pick up Autolite plugs and wires. This is my first Ford and first American car so I'm use to NGK and DENSO. I was advised to get Motorcaft or Autolite so just checking before I spend $$$.
 



Join the Elite Explorers $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links.
Add an avatar, upload photo attachments, and more!
.



gruss01

Member
Joined
August 12, 2009
Messages
31
Reaction score
0
City, State
Toledoish, OH
Year, Model & Trim Level
2003 XLT 1998 XLT
i just put them on the 98 about 1000 miles ago, no problems. Ran them in my Rangers before with no problems either.
 






celly

disturber of the peace
Joined
July 28, 2004
Messages
6,849
Reaction score
11
City, State
calgary
Year, Model & Trim Level
99 eb 5.0 awd
You'll find that by far the most common recommendation you'll get for Fords is OEM, i.e. Motorcraft plugs and wires. Autolite makes Motorcraft plugs so Autolite tend to be recommended for our applications too. Not sure about the wires. You can't go wrong with Autolite plugs. No comment on the wires only because I don't have a clue and Motorcraft wires are the best for my application (which includes headers). Motorcraft wires have built in heat shields for my application which is ideal for the headers. (I have a 5.0 V8 in mine).
 






jd4242

Explorer Addict
Joined
October 15, 2008
Messages
10,797
Reaction score
292
City, State
va beach
Year, Model & Trim Level
92explorer&94 ranger
i run autolite plugs and they suck,i will be going back to Motorcraft
 






Dan Whitaker

One fast putty tat
Elite Explorer
Joined
December 24, 2001
Messages
7,095
Reaction score
33
City, State
Raytown MO (Kansas City suburb)
Year, Model & Trim Level
No Mounty no more.
I'm running NGK V-Groove copper plugs with zero problems. They are still fine after a heavy Seafoam dousing.:)
 






bp1506

Well-Known Member
Joined
October 9, 2005
Messages
349
Reaction score
0
City, State
Calgary,AB
Year, Model & Trim Level
98 Sport
I run autolite double platinum plugs and autilite wires. no complaints here. I had bosch plugs in there before and they didnt last long. Took em out a week later.. just didnt run good for some reason.
 






Top