Heat is Warm but not Hot | Page 3 | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Heat is Warm but not Hot

massacre

Elite Explorer
Joined
January 24, 2018
Messages
969
Reaction score
248
Year, Model & Trim Level
‘94 Explorer
‘19 Nautilus
I have a feeling it was just a bad part. The temp gauge hasn’t gone above the bottom 1/3 of it’s travel in that thermostat’s life.
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




massacre

Elite Explorer
Joined
January 24, 2018
Messages
969
Reaction score
248
Year, Model & Trim Level
‘94 Explorer
‘19 Nautilus
I have an additional question, didn’t want to start a new thread, but will if necessary.
When I was searching threads about mice in the heater box (which I had in this case), I read where some people would close the recirc door before shutting the truck off to keep the mice out.
I can see my recirc door and the actuator, but could not get the door to close.
Does the door only open/close when in the AC position?
Thanks
 




CDW6212R

Hauls the mail.
Elite Explorer
Joined
June 17, 2004
Messages
22,135
Reaction score
2,546
City, State
Knoxville, TN
Year, Model & Trim Level
98 Limited AWD
I think the air only recirculates for the MAX AC setting(95+ Explorers), or with the Recirc button on rare models.
 




massacre

Elite Explorer
Joined
January 24, 2018
Messages
969
Reaction score
248
Year, Model & Trim Level
‘94 Explorer
‘19 Nautilus
Thank you!
Think I might have a vacuum issue, I’ll start a new thread.
 




MakinJeepsWeep!

Elite Explorer
Joined
October 1, 2020
Messages
421
Reaction score
117
City, State
Polk County Texas
Year, Model & Trim Level
96 Explorer 5.0L AWD
Callsign
Big Red
I too have had two failed moto rad tstats. Times when i could not wait for the mocraft to come in. Glad to hear that was the issue! And yes you should see a general better running all over because it wont be trying to stay slighlty rich.
 




MakinJeepsWeep!

Elite Explorer
Joined
October 1, 2020
Messages
421
Reaction score
117
City, State
Polk County Texas
Year, Model & Trim Level
96 Explorer 5.0L AWD
Callsign
Big Red
Also as far as the door i always swap all my stuff to off before shutting down the truck. Everything is susposedly off when cranking but i like to give it a few seconds before i turn extra loads on. An at least on my 96 the door is only open on max as CDW said above.
 




massacre

Elite Explorer
Joined
January 24, 2018
Messages
969
Reaction score
248
Year, Model & Trim Level
‘94 Explorer
‘19 Nautilus
It seems that the recirc door does not move, no matter the position.
and can hear a slight hiss under the dash.
So prob a vac line leaking, I’ll jump into that tomorrow
 




MakinJeepsWeep!

Elite Explorer
Joined
October 1, 2020
Messages
421
Reaction score
117
City, State
Polk County Texas
Year, Model & Trim Level
96 Explorer 5.0L AWD
Callsign
Big Red
I have been lucky enough to not have to repair one of those yet. Let us know how you do it.
 




massacre

Elite Explorer
Joined
January 24, 2018
Messages
969
Reaction score
248
Year, Model & Trim Level
‘94 Explorer
‘19 Nautilus
Will do!
 




massacre

Elite Explorer
Joined
January 24, 2018
Messages
969
Reaction score
248
Year, Model & Trim Level
‘94 Explorer
‘19 Nautilus
So I started a new thread
 




Top