High speed wobble | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

High speed wobble

OC sporttrac

New Member
Joined
December 22, 2013
Messages
8
Reaction score
0
City, State
Ocean City, NJ
Year, Model & Trim Level
2004 explorer sport trac
Brand new to the board. Thanks for having me.

I have a high speed wobble that I can't seem to get a correct diagnosis. When I am moving on a highway or off ramp, if I hit a bump straight on, then no problem. If I hit it slightly turned I get a shake in the steering wheel. Enough that it really concerns me. I had the ball joints replaced last spring. Uppers and lowers. Shocks were replaced about 40,000 miles ago

Truck has 110,000 miles. Since I moved to the beach 3 years ago, I'm having a lot of front end problems.

Thanks for all the help
 


Holiday Special! Join the Elite Explorers $20 for 2 years! Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




OC sporttrac

New Member
Joined
December 22, 2013
Messages
8
Reaction score
0
City, State
Ocean City, NJ
Year, Model & Trim Level
2004 explorer sport trac
I'm following up on this post in case anyone has similar issues. I drove to PA (100 miles) and had an ok drive. I got about 3 miles from my destination and the truck started doing weird things. Every time I turned left it felt like I was in a severe under steer/sliding. I finally took it to a pro (very rare) and he couldn't figure it out at first. The issue was there was no sound. Turns out it was tread separation on the left front tire. Someone was looking out for me.
 




D Hook

Elite Explorer
Joined
October 10, 2010
Messages
1,070
Reaction score
45
City, State
Omaha, NE
Year, Model & Trim Level
06 Explorer Limited V-8
Thanks for posting the follow-up.
 




fusseli

Well-Known Member
Joined
June 1, 2010
Messages
326
Reaction score
1
Year, Model & Trim Level
2002 4.6L
I had shaky stability problems hitting bumps on the highway, it turned out that my rear sway bar was broken. I would check everything in the front end as closely as you can, control arms, ball joints, sway bar, end links, tie rods, etc. Any play anywhere means something is shot.
 




OC sporttrac

New Member
Joined
December 22, 2013
Messages
8
Reaction score
0
City, State
Ocean City, NJ
Year, Model & Trim Level
2004 explorer sport trac
Thanks for the sway bar suggestion. I had checked all connections, just did check the tires. I put new tires on and it's all good. Great set of firestones for 500 installed at tires plus. Everything can be negotiated.
 




Top