• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

HVAC Control panel


Albertreact44

New Member
Joined
May 6, 2019
Messages
1
Reaction score
0
City, State
North wales pa
Year, Model & Trim Level
13 Ford Explorer
about a week ago my control panel started making the sound as if I was pressing a control button. I’ve seem to have pinpointed it to one button- the fan down button. It will randomly do this and it is a repetitive click/ blip as the fan controls go down. Doesn’t matter if the climate system is powered on or not. I’ve resorted to hitting the bottom of the control panel like the fonZ in order to stop the annoying repetitive clicking/blip noise.
I was thinking of upgrading to a newer explorer, but this one more issues I need to deal with and I’m thinking against that decision. Any help?
 




Rainlord

Elite Explorer
Joined
June 16, 2017
Messages
178
Reaction score
77
City, State
Zurich, Switzerland
Year, Model & Trim Level
Explorer 2012 XLT
You're trying to decide if you want to upgrade to a new Explorer, but you're on the fence because of a faulty button?

First, I would just stop by a dealer and get that taken care of. Or, you can replace the HVAC front yourself if you assume it's broken (two trim panels to pop off, 4 screws to unscrew, a couple of connectors to click out, repeat process backwards. Takes about 20 min).

Your reasons to upgrade to a new Explorer should probably be based on if you like the car as a whole or not. All cars have issues. Some cars have less issues than others. Even new cars have issues. Some cars have different issues than others (for example, I don't recall seeing anyone on here having your button problem). Based on that, you can decide if you want a new version of the same car, or try your luck with another model/brand ;)
 








peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
29,085
Reaction score
1,865
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
about a week ago my control panel started making the sound as if I was pressing a control button. I’ve seem to have pinpointed it to one button- the fan down button. It will randomly do this and it is a repetitive click/ blip as the fan controls go down. Doesn’t matter if the climate system is powered on or not. I’ve resorted to hitting the bottom of the control panel like the fonZ in order to stop the annoying repetitive clicking/blip noise.
I was thinking of upgrading to a newer explorer, but this one more issues I need to deal with and I’m thinking against that decision. Any help?
Welcome to the Forum Albert.:wave:
If you are truly interested in a newer Explorer then a faulty button shouldn't stand in your way. A newer one may have issues of its own since very few are totally trouble free. Since you haven't entered which trim level you have in your profile it is difficult to tell which panel you have. Have you checked to see if perhaps the button is stuck in the pressed position?

Peter
 




Top