O/D light flashing | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

O/D light flashing

Ray Ramos

New Member
Joined
May 15, 2017
Messages
2
Reaction score
0
City, State
Joplin, missouri
Year, Model & Trim Level
1998 ford explorer
I have 5R55E tranny. 1998 ford explorer.
O/D light comes on,drive with it on for a few miles. Then light goes off. Vehicle drives fine. Until light flashes. Hard clunk, hard shift 2ND to 3rd or when slowing down 3rd to 2nd. I've got a P1740 and a P0720 codes. Can someone help me,as to what I need to do. I bought this vehice a month ago. I can't afford a shop doing the work.so I'll tackle this myself. Thank you in advance for any help you all can give me
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





I would start by checking your Output Speed Sensor on the trany and/or the wiring to the sensor from the control unit.
 






I would start by checking your Output Speed Sensor on the trany and/or the wiring to the sensor from the control unit.
I'll try that . Thanks for the advice.
 






Not to hijack your thread but I have a similar problem. Bought a 2000 Explorer with 4.0L OHV with the 5R55E. Guy said the OD light started flashing and he just parked it. I drove it home and no OD light flashing was present. Now it does have a bad tach that stays stuck on 4500 RPM most of the time, can tap on dash sometimes it will drop to around 1500 RPM but it is not displaying the actual RPM In either case. So it seemed to drive fine the next day when I drove it to work about 30 miles almost all highway, approx 5 miles city on the begining and end of the drive. On the way home when it was much warmer outside the OD light started flashing when I was a few miles from home and it seemed like it had very little power. Once it OD light started flashing it seems like I am taking off in 2 or 3rd. Not too sure if it is actually shifting up past 3rd gear and due to tach problem it is very hard to tell. Any suggestions on where to start?
 












Back
Top