Using Forscan to change Battery_Type | Page 2 | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Using Forscan to change Battery_Type

thefranchise713

Explorer Addict
Joined
April 22, 2016
Messages
1,246
Reaction score
160
City, State
Buffalo, NY
Year, Model & Trim Level
'18 Toyota Prius Prime
Remember that the PID for battery current is a net change, not an absolute. A value near 0 isn't necessarily an issue. What does it show KOEO? IIRC, it should be -20A or so. You seem to understand the theory and operation of this well--is this immediately after start or sometime thereafter when the charge has recovered?

if it's still showing 0, I'm still coming back to the hall effect sensor having issues. Take a picture of your physical battery setup including the sensor assembly, if you could. Is there a chance the sensor isn't attached right to the rest of the assembly?

FWIW, I'm also not dismissing that you need to update your BCM charging strategy for an AGM setup, but I'm still disconcerted about the way that PID is coming back...
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




stuarto

Active Member
Joined
December 22, 2015
Messages
80
Reaction score
8
City, State
Toronto, Ontario
Year, Model & Trim Level
Explorer XLT 2013
Thanks (again!)

So, to answer your question, I took that shot after approx 30 mins of driving. I actually waited longer just to wait until it went from 2, 1, to 0.

For KOEO, confirming that it sits around -20 as 'default". When I first started looking into this, I did check that there was some expected fluctuation by, for instance, flicking on high beams - there was.
 
<



thefranchise713

Explorer Addict
Joined
April 22, 2016
Messages
1,246
Reaction score
160
City, State
Buffalo, NY
Year, Model & Trim Level
'18 Toyota Prius Prime
This also throws me:

This aside though, it is still an issue for me that the Battery_Type is set to an 80Ah AGM battery as this must affect the way the battery charge state is calculated. I have a 110Ah Lead Acid

Is this setting the one that was on the car stock, or after playing with it with FORScan? No Explorer in your model years that I know of -- hell to this point even -- came AGM, so I'd bet that FORScan interpreted the value wrong if the value was how it appeared 'stock.'
 
<



thefranchise713

Explorer Addict
Joined
April 22, 2016
Messages
1,246
Reaction score
160
City, State
Buffalo, NY
Year, Model & Trim Level
'18 Toyota Prius Prime
Also, are there any DTCs in the PCM, BCM, or APIM?
 
<



stuarto

Active Member
Joined
December 22, 2015
Messages
80
Reaction score
8
City, State
Toronto, Ontario
Year, Model & Trim Level
Explorer XLT 2013
FYI, I'm stuck with measuring the current. I only have a cheapo clamp to hand and it's AC only - so now I can't easily check the hall effect sensor. I do have a big shunt in a box some where so I could still measure this but I'm not in a rush to go searching for it right now.

When I got the car it had the "standard" lead acid battery in it and the first thing I did was pull it out and replace for one with greater CCA. To my knowledge, it's never had an AGM in there.
Also, to further clarify, I have only seen this value displayed by forscan and not another. Also, I haven't modified it. If I knew how to, I would! ;)

Confirming, no DTC's.

The devil in me might just have me disconnect the hall sensor and see how that affects both the charge rate and the state of charge...
 
<



thefranchise713

Explorer Addict
Joined
April 22, 2016
Messages
1,246
Reaction score
160
City, State
Buffalo, NY
Year, Model & Trim Level
'18 Toyota Prius Prime
Tomorrow I will pull that PID and see what it says for me.

Per workshop manual for my 2017, if you disconnect the hall effect sensor it should trigger a DTC which will fault out (and disable) the advanced charging strategy for a more traditional calculation method. The SoC PID will probably get ignored.

I also reviewed the WSM for a troubleshooting strategy on the 3.5L NA; going down the path they say you should look at connector C139 for fitment--I will try to post a diagram pic.

Edit: Diagram pic

Connector C139.PNG
 
<



stuarto

Active Member
Joined
December 22, 2015
Messages
80
Reaction score
8
City, State
Toronto, Ontario
Year, Model & Trim Level
Explorer XLT 2013
Really appreciate that, thanks in advance.

I like the idea of disabling the "advanced charging strategy" :) I'm an old school guy and never had any charging problems in the pre-fancy-ECM-days! It actually annoys the [email protected]##$ out of me that something so simple needs to be so complicated. For instance, when the charge state is on 37%, the moment you put the key in the ignition, the dash turns on and immediately gives the warning of shutting down due to low battery.
 
<



thefranchise713

Explorer Addict
Joined
April 22, 2016
Messages
1,246
Reaction score
160
City, State
Buffalo, NY
Year, Model & Trim Level
'18 Toyota Prius Prime
No problem.

It's actually a pretty cool system--I'm not sure what the impact is, but it's all about fuel economy--and to an extent battery wear (when it works.) Having seen it in action and monitored the PIDs, I've been impressed with what Ford engineers have accomplished in the strategy. Don't give up on this yet!
 
<



peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
32,024
Reaction score
2,532
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
Just to chime in, I've never had a starting issue with the OEM battery, even in the coldest temps here in the Ottawa area. I've also never used the block heater that comes with the vehicle. I do park in my garage but that doesn't make much of a difference when it is -20C.:)
 
<



thefranchise713

Explorer Addict
Joined
April 22, 2016
Messages
1,246
Reaction score
160
City, State
Buffalo, NY
Year, Model & Trim Level
'18 Toyota Prius Prime
@stuarto -- I'm sorry, I tried to pull the BATTERY_TYPE PID but it doesn't appear to exist on my 2017. I checked all modules, couldn't find it.
 
<



stuarto

Active Member
Joined
December 22, 2015
Messages
80
Reaction score
8
City, State
Toronto, Ontario
Year, Model & Trim Level
Explorer XLT 2013
Thanks and really appreciated. It's probably gonna be the weekend until I have time to check the connector now
 
<



stuarto

Active Member
Joined
December 22, 2015
Messages
80
Reaction score
8
City, State
Toronto, Ontario
Year, Model & Trim Level
Explorer XLT 2013
Hey folks,
I took another look at this today. Why not, it's only -20c after all!

I am surprised to say that I am now wondering with the battery state was actually being reporting accurately. Although I was inclined to disbelieve the state could drop to about 30% after a few days, after a BMS reset, I may have found the start of a culprit - ridiculous parasitic current drain. I'll start a new thread on this so as not to merge different topics.

Happy New Year!
 
<



metroplex

Well-Known Member
Joined
October 29, 2000
Messages
478
Reaction score
54
Location
Detroit, MI
City, State
Detroit, MI
Year, Model & Trim Level
2018 Ford Explorer XLT
My guess is that the battery type controls the alternator regulator. AGM batteries use a different charging curve than flooded batteries, and there may be different curves for the other flooded battery types. The charge curves allow for temperature compensation as well as getting the right charge based on chemistry. I know for some HD commercial applications, the regulators we use have a setting for flooded and a setting for AGM. Resetting the BMS is necessary for the PCM to recognize a new battery is installed. I've also left a de-sulfating maintainer on the battery for months during storage.
 
<



pzero

New Member
Joined
February 5, 2016
Messages
6
Reaction score
0
City, State
Vaughan, on
Year, Model & Trim Level
2017 Explorer XLT 3.5L V6
This isn't required on a 2013 as in your profile(2011-2015 don't have this type of BMS), but the 2016-2017 do have specific battery settings and require a BMS Reset when changing the battery.

Please see the tab "Battery Settings" on my spreadsheet if you do have a 2016-2017

FORScan 2011-2018 Explorers

Here is the reset procedure for your 2013:

2011-2015 Battery Relearn Procedure

Because your vehicle’s engine is electronically controlled by a computer, some control conditions are maintained by power from the battery. When the battery is disconnected or a new battery is installed, the engine must relearn its idle and fuel trim strategy for optimum driveability and performance. To begin this process:

1. With the vehicle at a complete stop, set the parking brake.
2. Put the gearshift lever in P (Park), turn off all accessories and start the engine.
3. Run the engine until it reaches normal operating temperature.
4. Allow the engine to idle for at least one minute.
5. Turn the A/C on and allow the engine to idle for at least one minute.
6. Drive the vehicle to complete the relearning process.
Hi there, do you have this spreasheet still available? the link seems to not work. I am trying to upgrade my 2017 explorer to an AGM battery from costco with a 750 CCA rating. thank you
 
<



PlatinumOwner

Well-Known Member
Joined
March 6, 2016
Messages
374
Reaction score
67
Year, Model & Trim Level
2016 Explorer Platinum
Hi there, do you have this spreasheet still available? the link seems to not work. I am trying to upgrade my 2017 explorer to an AGM battery from costco with a 750 CCA rating. thank you
I just updated the link in the post
 
<



peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
32,024
Reaction score
2,532
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
Just tried it and it isn't working.

Peter
 
<



Top