• Register Today It's free! This box and some ads will disappear once registered!

Window Side Vents / Deflectors


dragonexplorer12

Active Member
Joined
October 8, 2012
Messages
185
Reaction score
0
Year, Model & Trim Level
2013 Ford Explorer LTD
Thanks Ron! But I do wish the OEM deflector kit was made to be more tailor fit at edge tabs so no gap would result when installed. It's minor so its ok i guess =)
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




ExplorerUSA

Member
Joined
November 12, 2012
Messages
52
Reaction score
0
City, State
Lexington, KY.
Year, Model & Trim Level
2011-Up Ford Explorer
Thanks for the reply dragonexplorer12. Please explain to me when you say that these are OEM ventvisors. When I think of OEM; I always think of that these ventvisors or any other part were actually made by Ford themselves and were offered as either standard or as an option from the factory. Please correct me if I am totally wrong; but all ventvisors are made strictly by aftermarket manufacturers such as Auto Ventshade; WeatherTech and etc. and not produced by Ford themselves; or any other auto manufacturer for that matter. Therefore you can not call this item OEM in my opinion only.
 




dragonexplorer12

Active Member
Joined
October 8, 2012
Messages
185
Reaction score
0
Year, Model & Trim Level
2013 Ford Explorer LTD
Well, the kit directly came from FORD Philippines and is offered as an option. The deflectors also have the FoMoCo imprint. These deflectors are probably made by vendor and sold as OEM. I don't know...
 




ExplorerUSA

Member
Joined
November 12, 2012
Messages
52
Reaction score
0
City, State
Lexington, KY.
Year, Model & Trim Level
2011-Up Ford Explorer
Thanks for the update dragonexplorer12. I did not know that ventvisors were offered as a factory option on this vehicle. It is good to know now.
 




GeoMimi89

Active Member
Joined
June 28, 2012
Messages
106
Reaction score
2
City, State
NY
Year, Model & Trim Level
2016 Explorer Sport
Just got a set of EGR vent shades in channel. Installed the rear, looked like the window wasn't happy with it in there...lol. Installed the front and the window would not stay up! Kept opening half way. Thought I didn't install correctly and did it over and over. Same result so going to return and get the outside vent shades from ford!
 




dragonexplorer12

Active Member
Joined
October 8, 2012
Messages
185
Reaction score
0
Year, Model & Trim Level
2013 Ford Explorer LTD
These WINDOW VENT VISORS were so helpful during our weekend getaway! Had to pass several cars on a rural highway and the exhaust smell came in. Opened the window just to air out and in seconds back to normal. *whew*
 




ExplorerUSA

Member
Joined
November 12, 2012
Messages
52
Reaction score
0
City, State
Lexington, KY.
Year, Model & Trim Level
2011-Up Ford Explorer
GeoMimi89; Sorry to hear about the problem with your EGR ventvisors. You might try contacting EGR or your retailer since EGR products are guaranteed to fit your vehicle and come with a lifetime warranty. They do make quality products though.
 




Lethal-Wombat

New Member
Joined
May 11, 2013
Messages
32
Reaction score
0
City, State
Wash Dc / formerly Perth, Aus
Year, Model & Trim Level
2016 Explorer XLT
Problem with Rain/Wind Deflectors ....

1st post from a newbie in this forum ... :)

I purchased Rain/Wind deflectors for all 4 doors on my 2013 explorer xlt and unfortunately the front windows now dont stay all the way up !! Ive spent the last 4 hours researching, and it seems it is because of the "bounce-back" feature OR the auto-click-wind up ....(where you hit the button once, and it winds itself up automatically) ....

Ive come across several "solutions" that so far, havnt worked.... has anyone come across the same problem and managed to solve it ??????

Tia,
Tracey
 




LukerDooker

Active Member
Joined
March 25, 2013
Messages
886
Reaction score
8
City, State
N.E.
Year, Model & Trim Level
2013Limited 301A TuxBlack
If they are installed in the window channel, follow the video or instructions regarding the auto up/down feature. The directions will apply to any brand.
weathertechinstall

For the WeatherTech - they are in channel.
You need to test 4 or 5 times when done, including if necessary, using the button & your hands to push the windows all the way closed, then leave the windows closed 12 hours.
 
Last edited:




Lethal-Wombat

New Member
Joined
May 11, 2013
Messages
32
Reaction score
0
City, State
Wash Dc / formerly Perth, Aus
Year, Model & Trim Level
2016 Explorer XLT
Thnkx sooo much ...... got the windows up, now going to wait the 12 hours .... somehow i really dont think its gonna work though ... *crosses fingers* ....;)
 




WOLFexplorer

Active Member
Joined
February 25, 2013
Messages
125
Reaction score
2
City, State
Massachusetts
Year, Model & Trim Level
2011 Explorer Limited
take a picture of your window. the deflector has to be on top of rubber piece from of window
 




Lethal-Wombat

New Member
Joined
May 11, 2013
Messages
32
Reaction score
0
City, State
Wash Dc / formerly Perth, Aus
Year, Model & Trim Level
2016 Explorer XLT
Well ......the windows still bounce-back even after 48 hours of leaving them up :( ..... and Wolf, yup the vents are placed on top of the rubber .....

I saw a new toyota forerunner with the same vents installed and asked the owner if he had the same prob. ... YUP, and he just "lives with it", and each time he closes his windows he does it manually .... :(

So, im guessing, unless i REALLY get pissed with the hassle of the windows not going up on auto, ill live with it to ..... just a little worried about the window motors ...... :eek:

Thanks for the help guys !!!!:)
 




Azazell64

Active Member
Joined
February 27, 2013
Messages
156
Reaction score
0
City, State
Saskatchewan, Canada
Year, Model & Trim Level
2013 Explorer Sport
Not looking forward to this as I have purchased these as well and am just waiting for some decent weather to put them on...
 




LukerDooker

Active Member
Joined
March 25, 2013
Messages
886
Reaction score
8
City, State
N.E.
Year, Model & Trim Level
2013Limited 301A TuxBlack
The Weathertech vents are working fine for me.
 




Azazell64

Active Member
Joined
February 27, 2013
Messages
156
Reaction score
0
City, State
Saskatchewan, Canada
Year, Model & Trim Level
2013 Explorer Sport
The ones I have are the Ford OEM ones, not sure if their fitment will be better or worse.
 




WOLFexplorer

Active Member
Joined
February 25, 2013
Messages
125
Reaction score
2
City, State
Massachusetts
Year, Model & Trim Level
2011 Explorer Limited
i have weathertech and love them, no issues. i have a 2011 ex
 




Lethal-Wombat

New Member
Joined
May 11, 2013
Messages
32
Reaction score
0
City, State
Wash Dc / formerly Perth, Aus
Year, Model & Trim Level
2016 Explorer XLT
Well ..... kinda good news .... today i tried again with the auto-up ... and BOTH WINDOWS STAYED UP !!!!!! :thumbsup:

Tried again ... drivers window bounced-back half way .... sooo, im hoping that eventually they will work all the time ....

I will fess up and say i bought/ordered a no-name brand from Pep-boys ... the only name on the packaging is AVS - auto-vent shade; so i guess i shouldnt have been such a tight-wad and just bought the Weathershield brand !!!

*crossin fingers windows will eventually close ALL of the time*:dpchug:
 




LukerDooker

Active Member
Joined
March 25, 2013
Messages
886
Reaction score
8
City, State
N.E.
Year, Model & Trim Level
2013Limited 301A TuxBlack
Mine(in-channel Weathertech) did bump the rear end of the visor on the front windows, when raising them.
That did stop them going up, they would bump and go back down.
But that only happened during my test after install.
I used my hands for the final test, once they were closed I left them for a day.

After that they still bumped for approx 1 week, but worked fine, the visors were not loose or moving.
Now they are settled and no bump, work great. It takes a while for the visor to be really seated and it must move a bit every time the window is closed, at first.
 




CajunFordEx

Active Member
Joined
June 11, 2012
Messages
241
Reaction score
1
City, State
Cajun Country La
Year, Model & Trim Level
2017 Kia Sorento LX
Callsign
KC5OAO
Well ..... kinda good news .... today i tried again with the auto-up ... and BOTH WINDOWS STAYED UP !!!!!! :thumbsup:

Tried again ... drivers window bounced-back half way .... sooo, im hoping that eventually they will work all the time ....

I will fess up and say i bought/ordered a no-name brand from Pep-boys ... the only name on the packaging is AVS - auto-vent shade; so i guess i shouldnt have been such a tight-wad and just bought the Weathershield brand !!!

*crossin fingers windows will eventually close ALL of the time*:dpchug:
I have the AVS in channel vent visors since they first came out and they have worked perfectly since installing them. You have to follow the directions exactly to get them to work right. There was a thread on here over a year ago with someone that installed them without reading the directions and came to the conclusion they would not work, but after a while they read the directions and correctly installed them and they have worked for them ever since.
Good Luck.
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




Lethal-Wombat

New Member
Joined
May 11, 2013
Messages
32
Reaction score
0
City, State
Wash Dc / formerly Perth, Aus
Year, Model & Trim Level
2016 Explorer XLT
There was a thread on here over a year ago with someone that installed them without reading the directions and came to the conclusion they would not work, but after a while they read the directions and correctly installed them


<------ is a woman so i READ the instructions !!! :D :D :D :D :D :D

(couldnt resist sorry ..... :D)

Today both windows are working FINE each time i test .... YAY !!!! and once again THANKS FOR ALL THE HELP and ADVICE !!!
 




Top